Merge branch 'master' of https://github.com/Wedmer/packages
authorVasilis Tsiligiannis <acinonyx@openwrt.gr>
Sun, 27 Mar 2016 12:39:40 +0000 (15:39 +0300)
committerVasilis Tsiligiannis <acinonyx@openwrt.gr>
Sun, 27 Mar 2016 12:39:40 +0000 (15:39 +0300)
22 files changed:
admin/zabbix/files/mac80211
admin/zabbix/files/network
admin/zabbix/files/wifi
admin/zabbix/patches/015-daemon-foreground.patch
libs/libsoxr/Makefile
net/adblock/Makefile
net/adblock/files/adblock-update.sh
net/nsd/Makefile
sound/mpd/Makefile
sound/mpd/patches/100-musl_gcc5_fixes.patch
sound/pulseaudio/Makefile
utils/bandwidthd/Makefile
utils/cmdpad/Makefile
utils/crelay/Makefile
utils/gammu/files/gammu.init
utils/hamlib/Makefile
utils/hamlib/patches/100-override-autoconf-detection.patch [deleted file]
utils/openocd/Makefile
utils/opensc/patches/0024-OpenPGP-Fix-crash-after-accessing-inexistent-file.patch
utils/pps-tools/Makefile
utils/smstools3/files/smstools3.init
utils/watchcat/Makefile

index 93d8351898dfa42b59288270f71211b19829fc14..afa50aeba5e9d2ecd594fa1ba023b250a0e62107 100644 (file)
@@ -2,10 +2,10 @@
 
 # If you want to know the exact meaning of an UserParameter, you can search in the ieee80211 standard:
 # http://standards.ieee.org/getieee802/download/802.11-2012.pdf
-# exemple: for mac80211.ACKFailureCount search for dot11ACKFailureCount (page 2145)
+# example: for mac80211.ACKFailureCount search for dot11ACKFailureCount (page 2145)
 
 # mac80211 phy discovery (like 'phy0')
-# exemple: {"data":[{"{#PHY}":"phy0"}]}
+# example: {"data":[{"{#PHY}":"phy0"}]}
 #
 UserParameter=mac80211.phydiscovery,zabbix_helper_mac80211 discovery
 
index 51cb1cbc254fabf252eb259eb82cfda00088996f..b68e2a50549ee0dab5fcada47732ddb528aa44e9 100644 (file)
@@ -1,7 +1,7 @@
 #see http://wiki.openwrt.org/doc/howto/zabbix for ready to use templates
 
 # network interface discovery
-# exemple: {"data":[{"{#IF}":"lo", "{#NET}":"loopback"},{"{#IF}":"br-lan", "{#NET}":"lan"},{"{#IF}":"eth0.1", "{#NET}":"wan"}]}
+# example: {"data":[{"{#IF}":"lo", "{#NET}":"loopback"},{"{#IF}":"br-lan", "{#NET}":"lan"},{"{#IF}":"eth0.1", "{#NET}":"wan"}]}
 #
 UserParameter=netowrt.discovery,lua -l uci -e 'x = uci.cursor(nil, "/var/state");list = "{\"data\":[";x:foreach("network", "interface", function(s) list=list.."{\"{#IF}\":\""..s.ifname.."\", \"{#NET}\":\""..s[".name"].."\"}," end); list=string.gsub(list,",$",""); print(list.."]}")'
 
index 6315ea995b2fa17e7bb6e401941c92e618902b1b..f03d9b41ebe06be2e9f14fa22a20b1fdb18673e0 100644 (file)
@@ -1,7 +1,7 @@
 #see http://wiki.openwrt.org/doc/howto/zabbix for ready to use templates
 
 # wifi interface discovery
-# exemple: {"data":[{"{#IF}":"wlan0", "{#MODE}":"ap", "{#SSID}":"Openwrt", "{#NET}":"lan", "{#DEV}":"radio0", "{#ENC}":"psk2+ccmp", "{#TYPE}":"mac80211", "{#HWMODE}":"11ng", "{#CHANNEL}":"11", "{#BSSID}":"xx:xx:xx:xx:xx:xx"}]}
+# example: {"data":[{"{#IF}":"wlan0", "{#MODE}":"ap", "{#SSID}":"Openwrt", "{#NET}":"lan", "{#DEV}":"radio0", "{#ENC}":"psk2+ccmp", "{#TYPE}":"mac80211", "{#HWMODE}":"11ng", "{#CHANNEL}":"11", "{#BSSID}":"xx:xx:xx:xx:xx:xx"}]}
 # ubus call only work as root so you need to run zabbix as root to use wifi.ifdiscovery
 UserParameter=wifi.ifdiscovery, lua -l ubus -l iwinfo -e 'u=ubus.connect();list="{\"data\":[";stat=u:call("network.wireless", "status", {});for dev, dev_table in pairs(stat) do for i, iface in pairs(dev_table["interfaces"]) do c=iface["config"];i=iface["ifname"];t=iwinfo.type(i);iw=iwinfo[t];e = iw.encryption(i);e = e and e.description or "None";n = table.concat(c["network"]," ");list=list.."{\"{#IF}\":\""..i.."\", \"{#MODE}\":\""..iw.mode(i).."\", \"{#SSID}\":\""..c["ssid"].."\", \"{#NET}\":\""..n.."\", \"{#DEV}\":\""..dev.."\", \"{#ENC}\":\""..e.."\", \"{#TYPE}\":\""..t.."\", \"{#HWMODE}\":\"".."?".."\", \"{#CHANNEL}\":\""..iw.channel(i).."\", \"{#BSSID}\":\""..iw.bssid(i).."\"},";end;end;list=string.gsub(list,",$","");print(list.."]}")'
 
index 364e70360492959da1e7b2009cb84b48587eff49..a0fd9b98be82a3f60de9452193980781b8a97053 100644 (file)
@@ -39,7 +39,7 @@
 + * Parameters: allow_root     - allow root permission for application         *
 + *             user           - user on the system to which to drop the       *
 + *                              privileges                                    *
-+ *             run_foreground - should it close its controling tty            *
++ *             run_foreground - should it close its controlling tty           *
   *                                                                            *
   * Author: Alexei Vladishev                                                   *
   *                                                                            *
index 8f69803f8e7ec631016e7bde21033b090fbffa1b..9881fbb9d8717b708ffa4ae7ff2f3ca68d46f8a0 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2014 OpenWrt.org  
+# Copyright (C) 2014-2016 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -10,7 +10,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=libsoxr
 PKG_VERSION:=0.1.1
-PKG_RELEASE:=2
+PKG_RELEASE:=3
 
 PKG_SOURCE_PROTO:=git
 PKG_SOURCE_URL:=git://git.code.sf.net/p/soxr/code
@@ -18,6 +18,9 @@ PKG_SOURCE_VERSION:=$(PKG_VERSION)
 PKG_SOURCE_SUBDIR:=$(PKG_NAME)-$(PKG_VERSION)
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION)-$(PKG_SOURCE_VERSION).tar.gz
 
+PKG_MAINTAINER:=Ted Hess <thess@kitschensync.net>, \
+               Mike Brady <mikebrady@eircom.net>
+
 PKG_LICENSE:=LGPL-2.1
 PKG_LICENSE_FILES:=LICENCE
 
@@ -25,6 +28,7 @@ PKG_FIXUP:=libtool
 PKG_REMOVE_FILES:=autogen.sh
 
 PKG_BUILD_PARALLEL:=1
+PKG_INSTALL:=1
 
 include $(INCLUDE_DIR)/package.mk
 include $(INCLUDE_DIR)/cmake.mk
@@ -34,7 +38,6 @@ define Package/libsoxr
   CATEGORY:=Libraries
   TITLE:=The SoX Resampler library
   URL:=http://sourceforge.net/projects/soxr/
-  MAINTAINER:=Mike Brady <mikebrady@eircom.net>
   DEPENDS:= +libpthread
 endef
 
@@ -43,20 +46,20 @@ define Package/libsoxr/description
   High quality, one-dimensional sample-rate conversion library
 endef
 
-CMAKE_OPTIONS:= -DBUILD_SHARED_LIBS=OFF -DBUILD_TESTS=0 -DBUILD_EXAMPLES=0
+CMAKE_OPTIONS:= -DBUILD_TESTS=0 -DBUILD_EXAMPLES=0
 CMAKE_OPTIONS+= -DHAVE_WORDS_BIGENDIAN_EXITCODE=$(if $(CONFIG_BIG_ENDIAN),0,1)
 
 define Build/InstallDev
        $(INSTALL_DIR) $(1)/usr/include
-       $(CP) $(PKG_BUILD_DIR)/src/soxr.h $(1)/usr/include/
-       $(INSTALL_DIR) $(1)/usr/lib
-       $(CP) $(PKG_BUILD_DIR)/src/*.a $(1)/usr/lib/
+       $(CP) $(PKG_INSTALL_DIR)/usr/include/soxr.h $(1)/usr/include/
+       $(INSTALL_DIR) $(1)/usr/lib/pkgconfig
+       $(CP) $(PKG_INSTALL_DIR)/usr/lib/libsoxr.so* $(1)/usr/lib/
+       $(CP) $(PKG_INSTALL_DIR)/usr/lib/pkgconfig/soxr.pc $(1)/usr/lib/pkgconfig/
 endef
 
 define Package/libsoxr/install
        $(INSTALL_DIR) $(1)/usr/lib
-       $(CP) $(PKG_BUILD_DIR)/src/*.a $(1)/usr/lib/
+       $(CP) $(PKG_INSTALL_DIR)/usr/lib/libsoxr.so* $(1)/usr/lib/
 endef
 
-
 $(eval $(call BuildPackage,libsoxr))
index cffa23d3759a079689206e3ce7fe70e4d5d45818..3fcbc9d8445a971f96fb01aa916a4842da76014d 100644 (file)
@@ -7,7 +7,7 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=adblock
-PKG_VERSION:=1.0.1
+PKG_VERSION:=1.0.2
 PKG_RELEASE:=1
 PKG_LICENSE:=GPL-3.0+
 PKG_MAINTAINER:=Dirk Brenken <openwrt@brenken.org>
index 56ea4a0fe82222dd5fdcf326b7d51e60f2cdbc36..f516e414def74b0dbc250bbc24f1fc95664d60a3 100755 (executable)
@@ -36,7 +36,7 @@ fi
 # get current directory, script- and openwrt version
 #
 adb_scriptdir="${0%/*}"
-adb_scriptver="1.0.1"
+adb_scriptver="1.0.2"
 openwrt_version="$(cat /etc/openwrt_version)"
 
 # source in adblock function library
@@ -124,9 +124,12 @@ then
                 f_log "   source archive (pre-)processing finished"
             else
                 rc=0
+                adb_srclist="! -name ${adb_dnsprefix}.${src_name}"
+                adb_errsrclist="-name ${adb_dnsprefix}.${src_name}"
             fi
         else
             rc=0
+            adb_srclist="! -name ${adb_dnsprefix}.${src_name}"
             adb_errsrclist="-name ${adb_dnsprefix}.${src_name}"
             f_log "   source archive download failed"
         fi
index 14b2144a4b80e0913b527e616a6340214a109ace..d0817a3b64d52fd27bba07023a1fb6a04354814f 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2014-2015 OpenWrt.org
+# Copyright (C) 2014-2016 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -8,12 +8,12 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=nsd
-PKG_VERSION:=4.1.2
+PKG_VERSION:=4.1.9
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=http://www.nlnetlabs.nl/downloads/nsd
-PKG_MD5SUM:=73014bab5514b9babaf6c9007a6b36d8
+PKG_MD5SUM:=9ac1d5ba51351d3d98b7de765439af57
 PKG_FIXUP:=autoreconf
 PKG_INSTALL:=1
 
index 3c7e5a2248a68557d61f4e1aa8d7e05a9528404a..ae444a81bc9053221685364bb7eea009cb26fc9a 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2007-2015 OpenWrt.org
+# Copyright (C) 2007-2016 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -8,12 +8,12 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=mpd
-PKG_VERSION:=0.19.11
+PKG_VERSION:=0.19.14
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
 PKG_SOURCE_URL:=http://www.musicpd.org/download/mpd/0.19/
-PKG_MD5SUM:=78935f6c464b67e19b4dc65bdb80319e
+PKG_MD5SUM:=9f99340ec6b77bea4ba3729e3b76fd7c
 PKG_MAINTAINER:=Ted Hess <thess@kitschensync.net>
 
 PKG_LICENSE:=GPL-2.0
@@ -137,6 +137,7 @@ CONFIGURE_ARGS += \
        --disable-wildmidi \
        --disable-zzip \
        --with-zeroconf=no \
+       --disable-soxr \
        \
        --enable-curl \
        --enable-flac \
index 8795cc618940efcc5dbfa54060de59ac32005a80..924cc40bd7be8c6054b50a6d8c86b0f2ce8f1f44 100644 (file)
@@ -26,25 +26,3 @@ Volatile in the type is necessary. without that, LTO can break the code.
        constexpr
  #endif
        notify():pending(false) {}
---- a/src/thread/PosixCond.hxx
-+++ b/src/thread/PosixCond.hxx
-@@ -41,7 +41,7 @@ class PosixCond {
-       pthread_cond_t cond;
- public:
--#if defined(__NetBSD__) || defined(__BIONIC__)
-+#if !defined(__GLIBC__)
-       /* NetBSD's PTHREAD_COND_INITIALIZER is not compatible with
-          "constexpr" */
-       PosixCond() {
---- a/src/thread/PosixMutex.hxx
-+++ b/src/thread/PosixMutex.hxx
-@@ -41,7 +41,7 @@ class PosixMutex {
-       pthread_mutex_t mutex;
- public:
--#if defined(__NetBSD__) || defined(__BIONIC__)
-+#if !defined(__GLIBC__)
-       /* NetBSD's PTHREAD_MUTEX_INITIALIZER is not compatible with
-          "constexpr" */
-       PosixMutex() {
index 909d7902c7c4f13dcb279d7fc739e651480baace..b84449f071a36027a85731b060da000be55d0265 100644 (file)
@@ -99,7 +99,8 @@ CONFIGURE_ARGS += \
        --disable-udev \
        --without-fftw \
        --disable-avahi \
-       --disable-dbus
+       --disable-dbus \
+       --without-soxr
 
 CONFIGURE_VARS += \
        PKG_CONFIG_LIBDIR="$(STAGING_DIR)/usr/lib/pkgconfig"
@@ -144,7 +145,7 @@ define Package/pulseaudio-daemon/install
                ./files/pulseaudio.init \
                $(1)/etc/init.d/pulseaudio
 
-       $(INSTALL_CONF) \
+       $(INSTALL_DATA) \
                $(PKG_INSTALL_DIR)/etc/pulse/* \
                $(1)/etc/pulse
 
@@ -164,7 +165,6 @@ define Package/pulseaudio-daemon/install
                $(PKG_INSTALL_DIR)/usr/lib/pulse-$(PKG_VERSION)/modules/module*.so \
                $(1)/usr/lib/pulse-$(PKG_VERSION)/modules/
 
-       chmod -R 0644 $(1)/etc/pulse/*
 endef
 
 define Package/pulseaudio-tools/install
@@ -181,11 +181,11 @@ define Package/pulseaudio-profiles/install
                $(1)/usr/share/pulseaudio/alsa-mixer/paths \
                $(1)/usr/share/pulseaudio/alsa-mixer/profile-sets
 
-       $(INSTALL_CONF) \
+       $(INSTALL_DATA) \
                $(PKG_INSTALL_DIR)/usr/share/pulseaudio/alsa-mixer/paths/* \
                $(1)/usr/share/pulseaudio/alsa-mixer/paths
 
-       $(INSTALL_CONF) \
+       $(INSTALL_DATA) \
                $(PKG_INSTALL_DIR)/usr/share/pulseaudio/alsa-mixer/profile-sets/* \
                $(1)/usr/share/pulseaudio/alsa-mixer/profile-sets
 endef
index ad5fde4daa0de144730893ad13dc57d6aa80cce9..3d6514a5ed790d927ad99425e66cee64668c1ea3 100644 (file)
@@ -54,11 +54,11 @@ With the ability to store in a postgresql database.
 endef
 
 define Package/bandwidthd/daemon
- This package contains bandwidthd a bandwith tracking utility.
+ This package contains bandwidthd a bandwidth tracking utility.
 endef
 
 define Package/bandwidthd-pgsql/daemon
- This package contains bandwidthd a bandwith tracking utility.
+ This package contains bandwidthd a bandwidth tracking utility.
 endef
 
 ifeq ($(BUILD_VARIANT),no-pgsql)
index 5b9f52d1c25f6b90ef5b7544677474609aa6aff5..c092fc90bd4933d2273bb7641d6451bca127d5a9 100644 (file)
@@ -34,7 +34,7 @@ CONFIGURE_ARGS += \
 
 define Package/cmdpad/description
        cmdpad - execute commands when a key is pressed, released or hold down.
-       Should be started from /etc/rc or /etc/rc.local. To run it as deamon you
+       Should be started from /etc/rc or /etc/rc.local. To run it as daemon you
        need to start it with '&'. All logs are printed to standard out and standard
        error (to write the log to disk use cmdpad > /var/log/cmdpad). Cmdpad
        searches for /etc/cmdpad.conf and load the key bindings. Then wait for
index 04fa0ae26abf98af22ee82959d2c3493e2b2f574..6445f8d8cc1ddfbc7344e2adddfcecb0e3b1a7ea 100644 (file)
@@ -36,7 +36,7 @@ define Package/crelay/description
  crelay is used to control different relay cards in a unified manner. It provides
  several interfaces for controlling the relays locally or remotely by a web browser
  or a smartphone.  The card which is detected first will be used. A WebUI control is
- availble on port 8000 (default)
+ available on port 8000 (default)
  .
  Currently supported relay cards:
       - Conrad USB 4-channel relay card
index 6a391d4ac8e0fe784d70188ae1727c6793c1aa8d..37232457770b5e79f90aee8694a8dddcd2e6a0ac 100755 (executable)
@@ -15,7 +15,7 @@ start_instance() {
        config_get_bool item "$conf" enabled 0
        [ $item = 0 ] && return
 
-       echo -e "; dont edit. instead look into /etc/config/gammu\n[gammu]\n" > $conffile
+       echo -e "; don't edit. instead look into /etc/config/gammu\n[gammu]\n" > $conffile
 
        config_get item "$conf" device
        [ -z "$item" ] && return
index dec78f643a3addd5ddca31b430143c52a45d00a3..3787bced63036123b4bbc72b630026197376ad7d 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2014 OpenWrt.org
+# Copyright (C) 2014-2016 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -7,9 +7,9 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=hamlib
-PKG_VERSION:=1.2.15.3
-PKG_RELEASE:=3
-PKG_MD5SUM:=3cad8987e995a00e5e9d360e2be0eb43
+PKG_VERSION:=3.0.1
+PKG_RELEASE:=1
+PKG_MD5SUM:=451acb9f727ed706ae2f59ee3f0e03c7
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=@SF/hamlib
@@ -39,7 +39,7 @@ define Package/hamlib
   TITLE+= utilities
   SECTION:=utils
   CATEGORY:=Utilities
-  DEPENDS:=+libpthread +libhamlib
+  DEPENDS:=+libhamlib
 endef
 
 define Package/hamlib/description
@@ -57,7 +57,7 @@ endef
 
 define Package/libhamlib
   $(call Package/libhamlib/Default)
-  DEPENDS:=+libusb-1.0 +libltdl
+  DEPENDS:=+libusb-1.0
   MENU:=1
 endef
 
@@ -67,222 +67,6 @@ define Package/libhamlib/description
   This package contains the hamlib shared library.
 endef
 
-define Package/hamlib-adat
-  $(call Package/libhamlib/Default)
-  TITLE:= for ADAT
-  DEPENDS:=libhamlib
-endef
-
-define Package/hamlib-alinco
-  $(call Package/libhamlib/Default)
-  TITLE:= for Alinco
-  DEPENDS:=libhamlib
-endef
-
-define Package/hamlib-amsat
-  $(call Package/libhamlib/Default)
-  TITLE:= for AMSAT
-  DEPENDS:=libhamlib
-endef
-
-define Package/hamlib-aor
-  $(call Package/libhamlib/Default)
-  TITLE:= for AOR
-  DEPENDS:=libhamlib
-endef
-
-define Package/hamlib-ars
-  $(call Package/libhamlib/Default)
-  TITLE:= for ARS
-  DEPENDS:=libhamlib
-endef
-
-define Package/hamlib-celestron
-  $(call Package/libhamlib/Default)
-  TITLE:= for Celestron
-  DEPENDS:=libhamlib
-endef
-
-define Package/hamlib-drake
-  $(call Package/libhamlib/Default)
-  TITLE:= for Drake
-  DEPENDS:=libhamlib
-endef
-
-define Package/hamlib-dummy
-  $(call Package/libhamlib/Default)
-  TITLE:= for dummy
-  DEPENDS:=libhamlib
-endef
-
-define Package/hamlib-easycomm
-  $(call Package/libhamlib/Default)
-  TITLE:= for EasyComm
-  DEPENDS:=libhamlib
-endef
-
-define Package/hamlib-flexradio
-  $(call Package/libhamlib/Default)
-  TITLE:= for FlexRadio
-  DEPENDS:=libhamlib
-endef
-
-define Package/hamlib-fodtrack
-  $(call Package/libhamlib/Default)
-  TITLE:= for FodTrack
-  DEPENDS:=libhamlib
-endef
-
-define Package/hamlib-gs232a
-  $(call Package/libhamlib/Default)
-  TITLE:= for GS-232A
-  DEPENDS:=libhamlib
-endef
-
-define Package/hamlib-heathkit
-  $(call Package/libhamlib/Default)
-  TITLE:= for Heathkit
-  DEPENDS:=libhamlib
-endef
-
-define Package/hamlib-icom
-  $(call Package/libhamlib/Default)
-  TITLE:= for ICOM
-  DEPENDS:=libhamlib
-endef
-
-define Package/hamlib-jrc
-  $(call Package/libhamlib/Default)
-  TITLE:= for JRC
-  DEPENDS:=libhamlib
-endef
-
-define Package/hamlib-kachina
-  $(call Package/libhamlib/Default)
-  TITLE:= for Kachina
-  DEPENDS:=libhamlib
-endef
-
-define Package/hamlib-kenwood
-  $(call Package/libhamlib/Default)
-  TITLE:= for Kenwood
-  DEPENDS:=libhamlib
-endef
-
-define Package/hamlib-kit
-  $(call Package/libhamlib/Default)
-  TITLE:= for kits
-  DEPENDS:=libhamlib
-endef
-
-define Package/hamlib-lowe
-  $(call Package/libhamlib/Default)
-  TITLE:= for Lowe
-  DEPENDS:=libhamlib
-endef
-
-define Package/hamlib-m2
-  $(call Package/libhamlib/Default)
-  TITLE:= for M2
-  DEPENDS:=libhamlib
-endef
-
-define Package/hamlib-pcr
-  $(call Package/libhamlib/Default)
-  TITLE:= for PCR
-  DEPENDS:=libhamlib
-endef
-
-define Package/hamlib-prm80
-  $(call Package/libhamlib/Default)
-  TITLE:= for PRM80
-  DEPENDS:=libhamlib
-endef
-
-define Package/hamlib-racal
-  $(call Package/libhamlib/Default)
-  TITLE:= for Racal
-  DEPENDS:=libhamlib
-endef
-
-define Package/hamlib-rft
-  $(call Package/libhamlib/Default)
-  TITLE:= for RFT
-  DEPENDS:=libhamlib
-endef
-
-define Package/hamlib-rotorez
-  $(call Package/libhamlib/Default)
-  TITLE:= for Rotor-EZ
-  DEPENDS:=libhamlib
-endef
-
-define Package/hamlib-rs
-  $(call Package/libhamlib/Default)
-  TITLE:= for R&S
-  DEPENDS:=libhamlib
-endef
-
-define Package/hamlib-sartek
-  $(call Package/libhamlib/Default)
-  TITLE:= for SARtek
-  DEPENDS:=libhamlib
-endef
-
-define Package/hamlib-skanti
-  $(call Package/libhamlib/Default)
-  TITLE:= for Skanti
-  DEPENDS:=libhamlib
-endef
-
-define Package/hamlib-spid
-  $(call Package/libhamlib/Default)
-  TITLE:= for SPID
-  DEPENDS:=libhamlib
-endef
-
-define Package/hamlib-tapr
-  $(call Package/libhamlib/Default)
-  TITLE:= for TAPR
-  DEPENDS:=libhamlib
-endef
-
-define Package/hamlib-tentec
-  $(call Package/libhamlib/Default)
-  TITLE:= for TenTec
-  DEPENDS:=libhamlib
-endef
-
-define Package/hamlib-ts7400
-  $(call Package/libhamlib/Default)
-  TITLE:= for TS-7400
-  DEPENDS:=libhamlib
-endef
-
-define Package/hamlib-tuner
-  $(call Package/libhamlib/Default)
-  TITLE:= for Video for Linux tuner
-  DEPENDS:=libhamlib
-endef
-
-define Package/hamlib-uniden
-  $(call Package/libhamlib/Default)
-  TITLE:= for Uniden
-  DEPENDS:=libhamlib
-endef
-
-define Package/hamlib-wj
-  $(call Package/libhamlib/Default)
-  TITLE:= for Watkins - Johnson
-  DEPENDS:=libhamlib
-endef
-
-define Package/hamlib-yaesu
-  $(call Package/libhamlib/Default)
-  TITLE:= for Yaesu
-  DEPENDS:=libhamlib
-endef
-
 define Build/InstallDev
        $(INSTALL_DIR) $(1)/usr/include/hamlib
        $(CP) $(PKG_INSTALL_DIR)/usr/include/hamlib/*.h $(1)/usr/include/hamlib
@@ -293,11 +77,15 @@ define Build/InstallDev
 endef
 
 CONFIGURE_ARGS+= \
+       --disable-html-matrix \
+       --disable-winradio \
+       --without-readline \
        --without-cxx-binding \
-       --without-winradio \
-       --without-rpc-backends \
        --with-pic \
 
+CONFIGURE_VARS+= \
+       LIBUSB_LIBS="-lusb-1.0" \
+
 define Package/hamlib/install
        $(INSTALL_DIR) $(1)/usr/bin
        $(CP) $(PKG_INSTALL_DIR)/usr/bin/{rig,rot}* $(1)/usr/bin/
@@ -308,222 +96,5 @@ define Package/libhamlib/install
        $(CP) $(PKG_INSTALL_DIR)/usr/lib/libhamlib.so* $(1)/usr/lib/
 endef
 
-define Package/hamlib-adat/install
-       $(INSTALL_DIR) $(1)/usr/lib/hamlib
-       $(CP) $(PKG_INSTALL_DIR)/usr/lib/hamlib/hamlib-adat.so* $(1)/usr/lib/hamlib
-endef
-
-define Package/hamlib-alinco/install
-       $(INSTALL_DIR) $(1)/usr/lib/hamlib
-       $(CP) $(PKG_INSTALL_DIR)/usr/lib/hamlib/hamlib-alinco.so* $(1)/usr/lib/hamlib
-endef
-
-define Package/hamlib-amsat/install
-       $(INSTALL_DIR) $(1)/usr/lib/hamlib
-       $(CP) $(PKG_INSTALL_DIR)/usr/lib/hamlib/hamlib-amsat.so* $(1)/usr/lib/hamlib
-endef
-
-define Package/hamlib-aor/install
-       $(INSTALL_DIR) $(1)/usr/lib/hamlib
-       $(CP) $(PKG_INSTALL_DIR)/usr/lib/hamlib/hamlib-aor.so* $(1)/usr/lib/hamlib
-endef
-
-define Package/hamlib-ars/install
-       $(INSTALL_DIR) $(1)/usr/lib/hamlib
-       $(CP) $(PKG_INSTALL_DIR)/usr/lib/hamlib/hamlib-ars.so* $(1)/usr/lib/hamlib
-endef
-
-define Package/hamlib-celestron/install
-       $(INSTALL_DIR) $(1)/usr/lib/hamlib
-       $(CP) $(PKG_INSTALL_DIR)/usr/lib/hamlib/hamlib-celestron.so* $(1)/usr/lib/hamlib
-endef
-
-define Package/hamlib-drake/install
-       $(INSTALL_DIR) $(1)/usr/lib/hamlib
-       $(CP) $(PKG_INSTALL_DIR)/usr/lib/hamlib/hamlib-drake.so* $(1)/usr/lib/hamlib
-endef
-
-define Package/hamlib-dummy/install
-       $(INSTALL_DIR) $(1)/usr/lib/hamlib
-       $(CP) $(PKG_INSTALL_DIR)/usr/lib/hamlib/hamlib-dummy.so* $(1)/usr/lib/hamlib
-endef
-
-define Package/hamlib-easycomm/install
-       $(INSTALL_DIR) $(1)/usr/lib/hamlib
-       $(CP) $(PKG_INSTALL_DIR)/usr/lib/hamlib/hamlib-easycomm.so* $(1)/usr/lib/hamlib
-endef
-
-define Package/hamlib-flexradio/install
-       $(INSTALL_DIR) $(1)/usr/lib/hamlib
-       $(CP) $(PKG_INSTALL_DIR)/usr/lib/hamlib/hamlib-flexradio.so* $(1)/usr/lib/hamlib
-endef
-
-define Package/hamlib-fodtrack/install
-       $(INSTALL_DIR) $(1)/usr/lib/hamlib
-       $(CP) $(PKG_INSTALL_DIR)/usr/lib/hamlib/hamlib-fodtrack.so* $(1)/usr/lib/hamlib
-endef
-
-define Package/hamlib-gs232a/install
-       $(INSTALL_DIR) $(1)/usr/lib/hamlib
-       $(CP) $(PKG_INSTALL_DIR)/usr/lib/hamlib/hamlib-gs232a.so* $(1)/usr/lib/hamlib
-endef
-
-define Package/hamlib-heathkit/install
-       $(INSTALL_DIR) $(1)/usr/lib/hamlib
-       $(CP) $(PKG_INSTALL_DIR)/usr/lib/hamlib/hamlib-heathkit.so* $(1)/usr/lib/hamlib
-endef
-
-define Package/hamlib-icom/install
-       $(INSTALL_DIR) $(1)/usr/lib/hamlib
-       $(CP) $(PKG_INSTALL_DIR)/usr/lib/hamlib/hamlib-icom.so* $(1)/usr/lib/hamlib
-endef
-
-define Package/hamlib-jrc/install
-       $(INSTALL_DIR) $(1)/usr/lib/hamlib
-       $(CP) $(PKG_INSTALL_DIR)/usr/lib/hamlib/hamlib-jrc.so* $(1)/usr/lib/hamlib
-endef
-
-define Package/hamlib-kachina/install
-       $(INSTALL_DIR) $(1)/usr/lib/hamlib
-       $(CP) $(PKG_INSTALL_DIR)/usr/lib/hamlib/hamlib-kachina.so* $(1)/usr/lib/hamlib
-endef
-
-define Package/hamlib-kenwood/install
-       $(INSTALL_DIR) $(1)/usr/lib/hamlib
-       $(CP) $(PKG_INSTALL_DIR)/usr/lib/hamlib/hamlib-kenwood.so* $(1)/usr/lib/hamlib
-endef
-
-define Package/hamlib-kit/install
-       $(INSTALL_DIR) $(1)/usr/lib/hamlib
-       $(CP) $(PKG_INSTALL_DIR)/usr/lib/hamlib/hamlib-kit.so* $(1)/usr/lib/hamlib
-endef
-
-define Package/hamlib-lowe/install
-       $(INSTALL_DIR) $(1)/usr/lib/hamlib
-       $(CP) $(PKG_INSTALL_DIR)/usr/lib/hamlib/hamlib-lowe.so* $(1)/usr/lib/hamlib
-endef
-
-define Package/hamlib-m2/install
-       $(INSTALL_DIR) $(1)/usr/lib/hamlib
-       $(CP) $(PKG_INSTALL_DIR)/usr/lib/hamlib/hamlib-m2.so* $(1)/usr/lib/hamlib
-endef
-
-define Package/hamlib-pcr/install
-       $(INSTALL_DIR) $(1)/usr/lib/hamlib
-       $(CP) $(PKG_INSTALL_DIR)/usr/lib/hamlib/hamlib-pcr.so* $(1)/usr/lib/hamlib
-endef
-
-define Package/hamlib-prm80/install
-       $(INSTALL_DIR) $(1)/usr/lib/hamlib
-       $(CP) $(PKG_INSTALL_DIR)/usr/lib/hamlib/hamlib-prm80.so* $(1)/usr/lib/hamlib
-endef
-
-define Package/hamlib-racal/install
-       $(INSTALL_DIR) $(1)/usr/lib/hamlib
-       $(CP) $(PKG_INSTALL_DIR)/usr/lib/hamlib/hamlib-racal.so* $(1)/usr/lib/hamlib
-endef
-
-define Package/hamlib-rft/install
-       $(INSTALL_DIR) $(1)/usr/lib/hamlib
-       $(CP) $(PKG_INSTALL_DIR)/usr/lib/hamlib/hamlib-rft.so* $(1)/usr/lib/hamlib
-endef
-
-define Package/hamlib-rotorez/install
-       $(INSTALL_DIR) $(1)/usr/lib/hamlib
-       $(CP) $(PKG_INSTALL_DIR)/usr/lib/hamlib/hamlib-rotorez.so* $(1)/usr/lib/hamlib
-endef
-
-define Package/hamlib-rs/install
-       $(INSTALL_DIR) $(1)/usr/lib/hamlib
-       $(CP) $(PKG_INSTALL_DIR)/usr/lib/hamlib/hamlib-rs.so* $(1)/usr/lib/hamlib
-endef
-
-define Package/hamlib-sartek/install
-       $(INSTALL_DIR) $(1)/usr/lib/hamlib
-       $(CP) $(PKG_INSTALL_DIR)/usr/lib/hamlib/hamlib-sartek.so* $(1)/usr/lib/hamlib
-endef
-
-define Package/hamlib-skanti/install
-       $(INSTALL_DIR) $(1)/usr/lib/hamlib
-       $(CP) $(PKG_INSTALL_DIR)/usr/lib/hamlib/hamlib-skanti.so* $(1)/usr/lib/hamlib
-endef
-
-define Package/hamlib-spid/install
-       $(INSTALL_DIR) $(1)/usr/lib/hamlib
-       $(CP) $(PKG_INSTALL_DIR)/usr/lib/hamlib/hamlib-spid.so* $(1)/usr/lib/hamlib
-endef
-
-define Package/hamlib-tapr/install
-       $(INSTALL_DIR) $(1)/usr/lib/hamlib
-       $(CP) $(PKG_INSTALL_DIR)/usr/lib/hamlib/hamlib-tapr.so* $(1)/usr/lib/hamlib
-endef
-
-define Package/hamlib-tentec/install
-       $(INSTALL_DIR) $(1)/usr/lib/hamlib
-       $(CP) $(PKG_INSTALL_DIR)/usr/lib/hamlib/hamlib-tentec.so* $(1)/usr/lib/hamlib
-endef
-
-define Package/hamlib-ts7400/install
-       $(INSTALL_DIR) $(1)/usr/lib/hamlib
-       $(CP) $(PKG_INSTALL_DIR)/usr/lib/hamlib/hamlib-ts7400.so* $(1)/usr/lib/hamlib
-endef
-
-define Package/hamlib-tuner/install
-       $(INSTALL_DIR) $(1)/usr/lib/hamlib
-       $(CP) $(PKG_INSTALL_DIR)/usr/lib/hamlib/hamlib-tuner.so* $(1)/usr/lib/hamlib
-endef
-
-define Package/hamlib-uniden/install
-       $(INSTALL_DIR) $(1)/usr/lib/hamlib
-       $(CP) $(PKG_INSTALL_DIR)/usr/lib/hamlib/hamlib-uniden.so* $(1)/usr/lib/hamlib
-endef
-
-define Package/hamlib-wj/install
-       $(INSTALL_DIR) $(1)/usr/lib/hamlib
-       $(CP) $(PKG_INSTALL_DIR)/usr/lib/hamlib/hamlib-wj.so* $(1)/usr/lib/hamlib
-endef
-
-define Package/hamlib-yaesu/install
-       $(INSTALL_DIR) $(1)/usr/lib/hamlib
-       $(CP) $(PKG_INSTALL_DIR)/usr/lib/hamlib/hamlib-yaesu.so* $(1)/usr/lib/hamlib
-endef
-
 $(eval $(call BuildPackage,hamlib))
 $(eval $(call BuildPackage,libhamlib))
-$(eval $(call BuildPackage,hamlib-adat))
-$(eval $(call BuildPackage,hamlib-alinco))
-$(eval $(call BuildPackage,hamlib-amsat))
-$(eval $(call BuildPackage,hamlib-aor))
-$(eval $(call BuildPackage,hamlib-ars))
-$(eval $(call BuildPackage,hamlib-celestron))
-$(eval $(call BuildPackage,hamlib-drake))
-$(eval $(call BuildPackage,hamlib-dummy))
-$(eval $(call BuildPackage,hamlib-easycomm))
-$(eval $(call BuildPackage,hamlib-flexradio))
-$(eval $(call BuildPackage,hamlib-fodtrack))
-$(eval $(call BuildPackage,hamlib-gs232a))
-$(eval $(call BuildPackage,hamlib-heathkit))
-$(eval $(call BuildPackage,hamlib-icom))
-$(eval $(call BuildPackage,hamlib-jrc))
-$(eval $(call BuildPackage,hamlib-kachina))
-$(eval $(call BuildPackage,hamlib-kenwood))
-$(eval $(call BuildPackage,hamlib-kit))
-$(eval $(call BuildPackage,hamlib-lowe))
-$(eval $(call BuildPackage,hamlib-m2))
-$(eval $(call BuildPackage,hamlib-pcr))
-$(eval $(call BuildPackage,hamlib-prm80))
-$(eval $(call BuildPackage,hamlib-racal))
-$(eval $(call BuildPackage,hamlib-rft))
-$(eval $(call BuildPackage,hamlib-rotorez))
-$(eval $(call BuildPackage,hamlib-rs))
-$(eval $(call BuildPackage,hamlib-sartek))
-$(eval $(call BuildPackage,hamlib-skanti))
-$(eval $(call BuildPackage,hamlib-spid))
-$(eval $(call BuildPackage,hamlib-tapr))
-$(eval $(call BuildPackage,hamlib-tentec))
-$(eval $(call BuildPackage,hamlib-ts7400))
-$(eval $(call BuildPackage,hamlib-tuner))
-$(eval $(call BuildPackage,hamlib-uniden))
-$(eval $(call BuildPackage,hamlib-wj))
-$(eval $(call BuildPackage,hamlib-yaesu))
-
diff --git a/utils/hamlib/patches/100-override-autoconf-detection.patch b/utils/hamlib/patches/100-override-autoconf-detection.patch
deleted file mode 100644 (file)
index 284cc3b..0000000
+++ /dev/null
@@ -1,30 +0,0 @@
-Index: hamlib-1.2.15.3/configure.ac
-===================================================================
---- hamlib-1.2.15.3.orig/configure.ac  2012-11-01 22:27:27.000000000 +0100
-+++ hamlib-1.2.15.3/configure.ac       2014-06-15 09:34:25.557966205 +0200
-@@ -234,12 +234,12 @@
-               "You need a C99 compliant C compiler that supports struct/array intializers."
-               "Have you considered GCC lately?.")]);
--dnl libxml2 required rigmem xml support
--PKG_CHECK_MODULES([LIBXML2], [libxml-2.0],
--      [AC_DEFINE(HAVE_XML2,[1],[Define if libxml2 is available])],
--      [AC_MSG_WARN([libxml-2.0 pkg-config not found, XML support will be disabled])])
-+#dnl libxml2 required rigmem xml support
-+#PKG_CHECK_MODULES([LIBXML2], [libxml-2.0],
-+#     [AC_DEFINE(HAVE_XML2,[1],[Define if libxml2 is available])],
-+#     [AC_MSG_WARN([libxml-2.0 pkg-config not found, XML support will be disabled])])
- AC_SUBST(LIBXML2_LIBS)
- AC_SUBST(LIBXML2_CFLAGS)
- dnl Check if libgd-dev is installed, so we can enable rigmatrix
-@@ -406,7 +406,7 @@
- AM_CONDITIONAL(HAVE_USRP, test x"${cf_with_usrp}" = "xyes")
--PKG_CHECK_MODULES(LIBUSB, libusb >= 0.1, ,
-+PKG_CHECK_MODULES(LIBUSB, libusb >= 1.0, ,
-                 [AC_MSG_WARN([libusb pkg-config not found, USB backends will be disabled])])
- CFLAGS="${CFLAGS} ${LIBUSB_CFLAGS}"
- CXXFLAGS="${CXXFLAGS} ${LIBUSB_CFLAGS}"
index c72818c97bbd5b5e791d4720dbc84ed6c735901e..e18e1aa19efe577466d701cdc397f61e08976cdb 100644 (file)
@@ -40,7 +40,7 @@ define Package/openocd/description
 OpenOCD provides on-chip programming and debugging support with a
 layered architecture of JTAG interface and TAP support including:
 
-- (X)SVF playback to faciliate automated boundary scan and FPGA/CPLD
+- (X)SVF playback to facilitate automated boundary scan and FPGA/CPLD
   programming;
 - debug target support (e.g. ARM, MIPS): single-stepping,
   breakpoints/watchpoints, gprof profiling, etc;
index 22ae5f43fd0a8750d380249ba13f44c742939ca3..14184a807f4c9c38766b870bd0043c5ce488b4a5 100644 (file)
@@ -21,7 +21,7 @@ Index: opensc-20150513/src/libopensc/card-openpgp.c
        }
  
 @@ -998,7 +997,6 @@ pgp_select_file(sc_card_t *card, const s
-               /* This file ID is refered when importing key&certificate via pkcs15init, like above.
+               /* This file ID is referred when importing key&certificate via pkcs15init, like above.
                 * We pretend to successfully find this inexistent file. */
                if (id == 0x4402 || id == 0x5f48) {
 -                      priv->current = NULL;
index 91918e58b16c9dd4fb886057b076ce00df8143c5..dd4f90a10ff4e9cf80bb2b9ccaa4bda31431fd9a 100644 (file)
@@ -29,7 +29,7 @@ define Package/pps-tools
 endef
 
 define Package/pps-tools/description
-  Userland tools for GPS and DCF-77 Clock syncronization. PPS support in Kernel must be enabled.
+  Userland tools for GPS and DCF-77 Clock synchronization. PPS support in Kernel must be enabled.
 endef
 
 TARGET_CFLAGS += -I$(STAGING_DIR)/usr/include
index 1638c60c754a1f0cd6d8ddf2ade84a484deedf42..6598795b16421252fda683454ed4b8eaa4a3a1d8 100644 (file)
@@ -113,7 +113,7 @@ stop() {
                  echo ""
                  dots=0
                fi
-               echo "Timeout occured, killing $NAME hardly."
+               echo "Timeout occurred, killing $NAME hardly."
                kill -9 `ps $PSOPT | grep $NAME | grep -v grep | awk '{print $1}'` >/dev/null 2>&1
                [ -f $PIDFILE ] && rm $PIDFILE
                seconds=0
index 7459794423673f7d056e70546380b53779c22090..9160cff0afe8f36fe5eafb86513ef2b887e8bbe2 100644 (file)
@@ -23,7 +23,7 @@ define Package/watchcat
 endef
 
 define Package/watchcat/description
-Allows to configure a periodically reboot, or after loosing internet connectivity. Configured trough UCI /etc/config/system.
+Allows to configure a periodically reboot, or after losing internet connectivity. Configured trough UCI /etc/config/system.
 endef
 
 define Package/watchcat/conffiles