ar71xx: add initramfs image support for Compex devices
authorGabor Juhos <juhosg@openwrt.org>
Thu, 23 Jan 2014 12:23:10 +0000 (12:23 +0000)
committerGabor Juhos <juhosg@openwrt.org>
Thu, 23 Jan 2014 12:23:10 +0000 (12:23 +0000)
Signed-off-by: Gabor Juhos <juhosg@openwrt.org>
SVN-Revision: 39375

target/linux/ar71xx/image/Makefile

index 9be9bd025fee7ab5bbd9da88860278cb7aac0dda..e9ffd77d9c5c18b3151e9e424639d741736afabc 100644 (file)
@@ -66,6 +66,16 @@ define CompressLzma
   $(STAGING_DIR_HOST)/bin/lzma e $(1) -lc1 -lp2 -pb2 $(3) $(2)
 endef
 
+define PatchKernel
+       cp $(KDIR)/vmlinux$(3) $(KDIR_TMP)/vmlinux$(3)-$(1)
+       $(STAGING_DIR_HOST)/bin/patch-cmdline $(KDIR_TMP)/vmlinux$(3)-$(1) "$(strip $(2))"
+endef
+
+define PatchKernel/initramfs
+       $(call PatchKernel,$(1),$(2),-initramfs)
+       cp $(KDIR_TMP)/vmlinux-initramfs-$(1) $(call imgname,initramfs,$(1)).bin
+endef
+
 define PatchKernelLzma
        cp $(KDIR)/vmlinux$(4) $(KDIR_TMP)/vmlinux$(4)-$(1)
        $(STAGING_DIR_HOST)/bin/patch-cmdline $(KDIR_TMP)/vmlinux$(4)-$(1) "$(strip $(2))"
@@ -427,6 +437,7 @@ endef
 
 
 Image/Build/MyLoader/buildkernel=$(call PatchKernelLzma,$(2),$(3))
+Image/Build/MyLoader/initramfs=$(call PatchKernel/initramfs,$(2),$(3))
 
 define Image/Build/MyLoader
        -$(STAGING_DIR_HOST)/bin/mkmylofw -B $(2) -s $(4) \