php7-pecl-redis: add new package (fixes #8710)
authorMichael Heimpold <mhei@heimpold.de>
Mon, 29 Apr 2019 20:05:12 +0000 (22:05 +0200)
committerMichael Heimpold <mhei@heimpold.de>
Tue, 30 Apr 2019 18:50:20 +0000 (20:50 +0200)
This add the pecl package for communicating with redis servers.

Run-tested on mxs platform with a local redis test server.

Signed-off-by: Michael Heimpold <mhei@heimpold.de>
lang/php7-pecl-redis/Makefile [new file with mode: 0644]

diff --git a/lang/php7-pecl-redis/Makefile b/lang/php7-pecl-redis/Makefile
new file mode 100644 (file)
index 0000000..71f9ee9
--- /dev/null
@@ -0,0 +1,39 @@
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+include $(TOPDIR)/rules.mk
+
+PECL_NAME:=redis
+PECL_LONGNAME:=PHP extension for interfacing with Redis
+
+PKG_VERSION:=4.3.0
+PKG_RELEASE:=1
+PKG_HASH:=c0f04cec349960a842b60920fb8a433656e2e494eaed6e663397d67102a51ba2
+
+PKG_NAME:=php7-pecl-redis
+PKG_SOURCE:=$(PECL_NAME)-$(PKG_VERSION).tgz
+PKG_SOURCE_URL:=http://pecl.php.net/get/
+
+PKG_MAINTAINER:=Michael Heimpold <mhei@heimpold.de>
+
+PKG_LICENSE:=PHPv3.01
+PKG_LICENSE_FILES:=COPYING
+
+PKG_BUILD_DIR:=$(BUILD_DIR)/pecl-php7/$(PECL_NAME)-$(PKG_VERSION)
+PKG_BUILD_PARALLEL:=1
+
+PKG_FIXUP:=autoreconf
+
+include $(INCLUDE_DIR)/package.mk
+include $(INCLUDE_DIR)/nls.mk
+include ../php7/pecl.mk
+
+CONFIGURE_ARGS+= \
+       --enable-redis \
+       --disable-redis-igbinary \
+       --disable-redis-lzf
+
+$(eval $(call PECLPackage,$(PECL_NAME),$(PECL_LONGNAME),+php7-mod-hash +php7-mod-session,25))
+$(eval $(call BuildPackage,$(PKG_NAME)))