not files from gtk+-2 were staged correctly
authorJohn Crispin <john@openwrt.org>
Sat, 6 Oct 2007 01:01:20 +0000 (01:01 +0000)
committerJohn Crispin <john@openwrt.org>
Sat, 6 Oct 2007 01:01:20 +0000 (01:01 +0000)
SVN-Revision: 9157

XOrg/lib/gtk-2.8.20/Makefile

index 27aabb201d40a4699b76d11e54aa4825fbb57b33..ebe1dfa8b40c27e280d3f84835360be2aba1eac4 100644 (file)
@@ -50,7 +50,7 @@ endef
 define Build/InstallDev
        $(INSTALL_DIR)  $(STAGING_DIR)/usr/{lib/pkgconfig,include}
        $(CP) -r $(PKG_INSTALL_DIR)/usr/include/* $(STAGING_DIR)/include/
-       $(CP) $(PKG_INSTALL_DIR)/usr/lib/*.{la,so} $(STAGING_DIR)/usr/lib/
+       $(CP) $(PKG_INSTALL_DIR)/usr/lib/*.{la,so.*} $(STAGING_DIR)/usr/lib/
        $(CP) $(PKG_INSTALL_DIR)/usr/lib/pkgconfig/* $(STAGING_DIR)/usr/lib/pkgconfig/
        $(SED) "s,"prefix\=.*",prefix=$(STAGING_DIR)/usr," $(STAGING_DIR)/usr/lib/pkgconfig/{gtk,gdk}*.pc
        $(SED) "s,"exec_prefix\=.*",exec_prefix=$(STAGING_DIR)/usr," $(STAGING_DIR)/usr/lib/pkgconfig/{gtk,gdk}*.pc