aria2: Update to 1.35.0 10177/head
authorXingwang Liao <kuoruan@gmail.com>
Tue, 8 Oct 2019 02:04:53 +0000 (10:04 +0800)
committerXingwang Liao <kuoruan@gmail.com>
Tue, 8 Oct 2019 03:40:49 +0000 (11:40 +0800)
* remove OpenSSL patch, it has already merged to the source.

Signed-off-by: Xingwang Liao <kuoruan@gmail.com>
net/aria2/Makefile
net/aria2/patches/010-Platform-Fix-compilation-without-deprecated-OpenSSL-.patch [deleted file]

index e521b453873d86e5c95ac703d1b17b27785da455..961d076eece0f437a3e6a19d631a4f6f544e4471 100644 (file)
@@ -7,12 +7,12 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=aria2
-PKG_VERSION:=1.34.0
-PKG_RELEASE:=6
+PKG_VERSION:=1.35.0
+PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
 PKG_SOURCE_URL:=https://github.com/aria2/aria2/releases/download/release-$(PKG_VERSION)/
-PKG_HASH:=3a44a802631606e138a9e172a3e9f5bcbaac43ce2895c1d8e2b46f30487e77a3
+PKG_HASH:=1e2b7fd08d6af228856e51c07173cfcf987528f1ac97e04c5af4a47642617dfd
 PKG_INSTALL:=1
 PKG_BUILD_PARALLEL:=1
 PKG_USE_MIPS16:=0
diff --git a/net/aria2/patches/010-Platform-Fix-compilation-without-deprecated-OpenSSL-.patch b/net/aria2/patches/010-Platform-Fix-compilation-without-deprecated-OpenSSL-.patch
deleted file mode 100644 (file)
index 1458d07..0000000
+++ /dev/null
@@ -1,38 +0,0 @@
-From 0e31e37c0f6ad0b3f393f024d1f6d8ce448e4746 Mon Sep 17 00:00:00 2001
-From: Rosen Penev <rosenp@gmail.com>
-Date: Sat, 8 Dec 2018 18:39:50 -0800
-Subject: [PATCH] Platform: Fix compilation without deprecated OpenSSL APIs
-
----
- src/Platform.cc | 3 +++
- 1 file changed, 3 insertions(+)
-
-diff --git a/src/Platform.cc b/src/Platform.cc
-index ea73b6c6..d7882a97 100644
---- a/src/Platform.cc
-+++ b/src/Platform.cc
-@@ -44,6 +44,7 @@
- #ifdef HAVE_OPENSSL
- #include <openssl/err.h>
- #include <openssl/ssl.h>
-+#include "libssl_compat.h"
- #endif // HAVE_OPENSSL
- #ifdef HAVE_LIBGCRYPT
- #include <gcrypt.h>
-@@ -111,11 +112,13 @@ bool Platform::setUp()
- #endif // ENABLE_NLS
- #ifdef HAVE_OPENSSL
-+#if !OPENSSL_101_API
-   // for SSL initialization
-   SSL_load_error_strings();
-   SSL_library_init();
-   // Need this to "decrypt" p12 files.
-   OpenSSL_add_all_algorithms();
-+#endif // !OPENSSL_101_API
- #endif // HAVE_OPENSSL
- #ifdef HAVE_LIBGCRYPT
-   if (!gcry_check_version("1.2.4")) {
--- 
-2.17.1
-