Added new modules, modularize them
authorFlorian Fainelli <florian@openwrt.org>
Sat, 18 Mar 2006 22:03:33 +0000 (22:03 +0000)
committerFlorian Fainelli <florian@openwrt.org>
Sat, 18 Mar 2006 22:03:33 +0000 (22:03 +0000)
SVN-Revision: 3404

19 files changed:
openwrt/package/openser/Config.in
openwrt/package/openser/Makefile
openwrt/package/openser/ipkg/openser-mod-avp-radius.control [new file with mode: 0644]
openwrt/package/openser/ipkg/openser-mod-dispatcher.control [new file with mode: 0644]
openwrt/package/openser/ipkg/openser-mod-diversion.control [new file with mode: 0644]
openwrt/package/openser/ipkg/openser-mod-flatstore.control [new file with mode: 0644]
openwrt/package/openser/ipkg/openser-mod-gflags.control [new file with mode: 0644]
openwrt/package/openser/ipkg/openser-mod-group-radius.control [new file with mode: 0644]
openwrt/package/openser/ipkg/openser-mod-group.control [new file with mode: 0644]
openwrt/package/openser/ipkg/openser-mod-msilo.control [new file with mode: 0644]
openwrt/package/openser/ipkg/openser-mod-options.control [new file with mode: 0644]
openwrt/package/openser/ipkg/openser-mod-pdt.control [new file with mode: 0644]
openwrt/package/openser/ipkg/openser-mod-permissions.control [new file with mode: 0644]
openwrt/package/openser/ipkg/openser-mod-pike.control [new file with mode: 0644]
openwrt/package/openser/ipkg/openser-mod-uac-redirect.control [new file with mode: 0644]
openwrt/package/openser/ipkg/openser-mod-uac.control [new file with mode: 0644]
openwrt/package/openser/ipkg/openser-mod-uri-db.control [new file with mode: 0644]
openwrt/package/openser/ipkg/openser-mod-uri-radius.control [new file with mode: 0644]
openwrt/package/openser/ipkg/openser-mod-uri.control [new file with mode: 0644]

index 9bb743a9b4c4c321752a43037a923e05279398f9..4927d921e678dcb7c99055cec9f577f4ca632a57 100644 (file)
@@ -7,14 +7,6 @@ config BR2_PACKAGE_OPENSER
         Open SIP Express Router (OpenSER) is a high-performance,
         configurable, free SIP server.
 
-config BR2_PACKAGE_OPENSER_MOD_MYSQL
-       tristate "openser-mod-mysql - MySQL support"
-       default m
-       select BR2_PACKAGE_LIBMYSQLCLIENT
-       select BR2_PACKAGE_OPENSER
-       help
-         Enable MySQL support
-
 config BR2_PACKAGE_OPENSER_MOD_AUTH
        tristate "openser-mod-auth - Authentication support"
        default m
@@ -38,6 +30,14 @@ config BR2_PACKAGE_OPENSER_MOD_AUTH_RADIUS
        help
          Authentication against RADIUS
 
+config BR2_PACKAGE_OPENSER_MOD_AVP_RADIUS
+        tristate "openser-mod-avp-radius - AVP with RADIUS support"
+        default m
+        select BR2_PACKAGE_OPENSER
+       select BR2_PACKAGE_LIBRADIUSCLIENT_NG
+        help
+          Enable AVP with RADIUS support
+
 config BR2_PACKAGE_OPENSER_MOD_AVPOPS
        tristate "openser-mod-avpops - AVP options support"
        default m
@@ -45,6 +45,55 @@ config BR2_PACKAGE_OPENSER_MOD_AVPOPS
        help
          Enable AVP options support
 
+config BR2_PACKAGE_OPENSER_MOD_DISPATCHER
+        tristate "openser-mod-dispatcher - dispatcher support"
+        default m
+        select BR2_PACKAGE_OPENSER
+        help
+          Enable dispatcher options support
+
+config BR2_PACKAGE_OPENSER_MOD_DIVERSION
+        tristate "openser-mod-diversion - diversion support"
+        default m
+        select BR2_PACKAGE_OPENSER
+        help
+          Enable diversion options support
+
+config BR2_PACKAGE_OPENSER_MOD_FLATSTORE
+        tristate "openser-mod-flatstore - flatstore support"
+        default m
+        select BR2_PACKAGE_OPENSER
+        help
+          Enable flatstore support
+
+config BR2_PACKAGE_OPENSER_MOD_GFLAGS
+        tristate "openser-mod-gflags - gflags support"
+        default m
+        select BR2_PACKAGE_OPENSER
+        help
+          Enable GFlags support
+
+config BR2_PACKAGE_OPENSER_MOD_GROUP
+        tristate "openser-mod-group - group support"
+        default m
+        select BR2_PACKAGE_OPENSER
+        help
+          Enable group support
+
+config BR2_PACKAGE_OPENSER_MOD_GROUP_RADIUS
+        tristate "openser-mod-group-radius - group with RADIUS support"
+        default m
+        select BR2_PACKAGE_OPENSER
+        help
+          Enable group with RADIUS support
+
+config BR2_PACKAGE_OPENSER_MOD_LCR
+        tristate "openser-mod-lcr - Least Cost Routing support"
+        default m
+        select BR2_PACKAGE_OPENSER
+        select BR2_PACKAGE_OPENSER_MOD_MYSQL
+        help
+          Enable Least Cost Routing support
 
 config BR2_PACKAGE_OPENSER_MOD_MEDIAPROXY
        tristate "openser-mod-mediaproxy - Mediaproxy support"
@@ -53,13 +102,20 @@ config BR2_PACKAGE_OPENSER_MOD_MEDIAPROXY
        help
          Enable mediaproxy support
 
-config BR2_PACKAGE_OPENSER_MOD_LCR
-       tristate "openser-mod-lcr - Least Cost Routing support"
-       default m
-       select BR2_PACKAGE_OPENSER
-       select BR2_PACKAGE_OPENSER_MOD_MYSQL
-       help
-         Enable Least Cost Routing support
+config BR2_PACKAGE_OPENSER_MOD_MSILO
+        tristate "openser-mod-msilo - MSilo support"
+        default m
+        select BR2_PACKAGE_OPENSER
+        help
+          Enable msilo support
+
+config BR2_PACKAGE_OPENSER_MOD_MYSQL
+        tristate "openser-mod-mysql - MySQL support"
+        default m
+        select BR2_PACKAGE_LIBMYSQLCLIENT
+        select BR2_PACKAGE_OPENSER
+        help
+          Enable MySQL support
 
 config BR2_PACKAGE_OPENSER_MOD_NATHELPER
        tristate "openser-mod-nathelper - NAT helper support"
@@ -68,6 +124,34 @@ config BR2_PACKAGE_OPENSER_MOD_NATHELPER
        help
          NAT helper support
 
+config BR2_PACKAGE_OPENSER_MOD_OPTIONS
+        tristate "openser-mod-options - options support"
+        default m
+        select BR2_PACKAGE_OPENSER
+        help
+          Enable options support
+
+config BR2_PACKAGE_OPENSER_MOD_PDT
+        tristate "openser-mod-pdt - PDT support"
+        default m
+        select BR2_PACKAGE_OPENSER
+        help
+          Enable pdt support
+
+config BR2_PACKAGE_OPENSER_MOD_PERMISSIONS
+        tristate "openser-mod-permissions - Permissions support"
+        default m
+        select BR2_PACKAGE_OPENSER
+        help
+          Enable permissions support
+
+config BR2_PACKAGE_OPENSER_MOD_PIKE
+        tristate "openser-mod-pike - PIKE support"
+        default m
+        select BR2_PACKAGE_OPENSER
+        help
+          Enable pike support
+
 config BR2_PACKAGE_OPENSER_MOD_SMS
        tristate "openser-mod-sms - SMS support"
        default m
@@ -82,6 +166,41 @@ config BR2_PACKAGE_OPENSER_MOD_SPEEDDIAL
        help
          Speed Dial support
 
+config BR2_PACKAGE_OPENSER_MOD_UAC
+        tristate "openser-mod-uac - UAC support"
+        default m
+        select BR2_PACKAGE_OPENSER
+        help
+          Enable UAC support
+
+config BR2_PACKAGE_OPENSER_MOD_UAC_REDIRECT
+        tristate "openser-mod-uac - UAC redirect support"
+        default m
+        select BR2_PACKAGE_OPENSER
+        help
+          Enable UAC redirect support
+
+config BR2_PACKAGE_OPENSER_MOD_URI
+        tristate "openser-mod-uri - URI support"
+        default m
+        select BR2_PACKAGE_OPENSER
+        help
+          Enable URI support
+
+config BR2_PACKAGE_OPENSER_MOD_URI_DB
+        tristate "openser-mod-uri-db - URI database support"
+        default m
+        select BR2_PACKAGE_OPENSER
+        help
+          Enable URI database support
+
+config BR2_PACKAGE_OPENSER_MOD_URI_RADIUS
+        tristate "openser-mod-uri-radius - URI with RADIUS support"
+        default m
+        select BR2_PACKAGE_OPENSER
+        help
+          Enable URI with RADIUS support
+
 config BR2_PACKAGE_OPENSER_MOD_XLOG
        tristate "openser-mod-xlog - Logging support"
        default m
index a94bc6b080ccb83de29ce17ffa31865ad7ab1870..28d82dbaf30e4bb00f2b8dd51b8cc1159e30fafe 100644 (file)
@@ -34,13 +34,30 @@ $(eval $(call PKG_template,OPENSER_MOD_ACCOUNTING,openser-mod-acc,$(PKG_VERSION)
 $(eval $(call PKG_template,OPENSER_MOD_AUTH,openser-mod-auth,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
 $(eval $(call PKG_template,OPENSER_MOD_AUTH_DB,openser-mod-auth-db,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
 $(eval $(call PKG_template,OPENSER_MOD_AUTH_RADIUS,openser-mod-auth-radius,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
+$(eval $(call PKG_template,OPENSER_MOD_AVP_RADIUS,openser-mod-avp-radius,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
 $(eval $(call PKG_template,OPENSER_MOD_AVPOPS,openser-mod-avpops,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
+$(eval $(call PKG_template,OPENSER_MOD_DISPATCHER,openser-mod-dispatcher,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
+$(eval $(call PKG_template,OPENSER_MOD_DIVERSION,openser-mod-diversion,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
+$(eval $(call PKG_template,OPENSER_MOD_FLATSTORE,openser-mod-flatstore,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
+$(eval $(call PKG_template,OPENSER_MOD_GFLAGS,openser-mod-gflags,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
+$(eval $(call PKG_template,OPENSER_MOD_GROUP,openser-mod-group,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
+$(eval $(call PKG_template,OPENSER_MOD_GROUP_RADIUS,openser-mod-group-radius,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
 $(eval $(call PKG_template,OPENSER_MOD_LCR,openser-mod-lcr,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
 $(eval $(call PKG_template,OPENSER_MOD_MEDIAPROXY,openser-mod-mediaproxy,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
+$(eval $(call PKG_template,OPENSER_MOD_MSILO,openser-mod-msilo,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
 $(eval $(call PKG_template,OPENSER_MOD_MYSQL,openser-mod-mysql,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
 $(eval $(call PKG_template,OPENSER_MOD_NATHELPER,openser-mod-nathelper,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
+$(eval $(call PKG_template,OPENSER_MOD_OPTIONS,openser-mod-options,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
+$(eval $(call PKG_template,OPENSER_MOD_PDT,openser-mod-pdt,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
+$(eval $(call PKG_template,OPENSER_MOD_PERMISSIONS,openser-mod-permissions,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
+$(eval $(call PKG_template,OPENSER_MOD_PIKE,openser-mod-pike,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
 $(eval $(call PKG_template,OPENSER_MOD_SMS,openser-mod-sms,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
-$(eval $(call PKG_template,OPENSER_MOD_SPEEDDIAL,openser-mod-speeddial,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
+$(eval $(call PKG_template,OPENSER_MOD_UAC,openser-mod-uac,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
+$(eval $(call PKG_template,OPENSER_MOD_UAC_REDIRECT,openser-mod-uac-redirect,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
+$(eval $(call PKG_template,OPENSER_MOD_URI,openser-mod-uri,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
+$(eval $(call PKG_template,OPENSER_MOD_URI_DB,openser-mod-uri-db,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
+$(eval $(call PKG_template,OPENSER_MOD_URI_RADIUS,openser-mod-uri-radius,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
+$(eval $(call PKG_template,OPENSER_MOD_AUTH_RADIUS,openser-mod-auth-radius,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
 $(eval $(call PKG_template,OPENSER_MOD_XLOG,openser-mod-xlog,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
 
 $(eval $(call PKG_mod_template,OPENSER_MOD_ACCOUNTING,acc))
@@ -57,10 +74,20 @@ $(eval $(call PKG_mod_template,OPENSER_MOD_GROUP,group))
 $(eval $(call PKG_mod_template,OPENSER_MOD_GROUP_RADIUS,group_radius))
 $(eval $(call PKG_mod_template,OPENSER_MOD_LCR,lcr))
 $(eval $(call PKG_mod_template,OPENSER_MOD_MEDIAPROXY,mediaproxy))
+$(eval $(call PKG_mod_template,OPENSER_MOD_MSILO,msilo))
 $(eval $(call PKG_mod_template,OPENSER_MOD_MYSQL,mysql))
 $(eval $(call PKG_mod_template,OPENSER_MOD_NATHELPER,nathelper))
+$(eval $(call PKG_mod_template,OPENSER_MOD_OPTIONS,options))
+$(eval $(call PKG_mod_template,OPENSER_MOD_PDT,pdt))
+$(eval $(call PKG_mod_template,OPENSER_MOD_PERMISSIONS,permissions))
+$(eval $(call PKG_mod_template,OPENSER_MOD_PIKE,pike))
 $(eval $(call PKG_mod_template,OPENSER_MOD_SMS,sms))
 $(eval $(call PKG_mod_template,OPENSER_MOD_SPEEDIAL,speeddial))
+$(eval $(call PKG_mod_template,OPENSER_MOD_UAC,uac))
+$(eval $(call PKG_mod_template,OPENSER_MOD_UAC_REDIRECT,uac_redirect))
+$(eval $(call PKG_mod_template,OPENSER_MOD_URI,uri))
+$(eval $(call PKG_mod_template,OPENSER_MOD_URI_DB,uri_db))
+$(eval $(call PKG_mod_template,OPENSER_MOD_URI_RADIUS,uri_radius))
 $(eval $(call PKG_mod_template,OPENSER_MOD_XLOG,xlog))
 
 # Select here the modules for the ipk package
diff --git a/openwrt/package/openser/ipkg/openser-mod-avp-radius.control b/openwrt/package/openser/ipkg/openser-mod-avp-radius.control
new file mode 100644 (file)
index 0000000..1f09797
--- /dev/null
@@ -0,0 +1,5 @@
+Package: openser-mod-avp-radius
+Depends: openser
+Section: net
+Priority: optional
+Description: avp_radius support for OpenSER
diff --git a/openwrt/package/openser/ipkg/openser-mod-dispatcher.control b/openwrt/package/openser/ipkg/openser-mod-dispatcher.control
new file mode 100644 (file)
index 0000000..eabfd6d
--- /dev/null
@@ -0,0 +1,5 @@
+Package: openser-mod-dispatcher
+Depends: openser
+Section: net
+Priority: optional
+Description: dispatcher support for OpenSER
diff --git a/openwrt/package/openser/ipkg/openser-mod-diversion.control b/openwrt/package/openser/ipkg/openser-mod-diversion.control
new file mode 100644 (file)
index 0000000..bcf4011
--- /dev/null
@@ -0,0 +1,5 @@
+Package: openser-mod-diversion
+Depends: openser
+Section: net
+Priority: optional
+Description: diversion support for OpenSER
diff --git a/openwrt/package/openser/ipkg/openser-mod-flatstore.control b/openwrt/package/openser/ipkg/openser-mod-flatstore.control
new file mode 100644 (file)
index 0000000..96e0835
--- /dev/null
@@ -0,0 +1,5 @@
+Package: openser-mod-flatstore
+Depends: openser
+Section: net
+Priority: optional
+Description: flatstore support for OpenSER
diff --git a/openwrt/package/openser/ipkg/openser-mod-gflags.control b/openwrt/package/openser/ipkg/openser-mod-gflags.control
new file mode 100644 (file)
index 0000000..ce99494
--- /dev/null
@@ -0,0 +1,5 @@
+Package: openser-mod-gflags
+Depends: openser
+Section: net
+Priority: optional
+Description: gflags support for OpenSER
diff --git a/openwrt/package/openser/ipkg/openser-mod-group-radius.control b/openwrt/package/openser/ipkg/openser-mod-group-radius.control
new file mode 100644 (file)
index 0000000..bb5fbed
--- /dev/null
@@ -0,0 +1,5 @@
+Package: openser-mod-group-radius
+Depends: openser
+Section: net
+Priority: optional
+Description: group_radius support for OpenSER
diff --git a/openwrt/package/openser/ipkg/openser-mod-group.control b/openwrt/package/openser/ipkg/openser-mod-group.control
new file mode 100644 (file)
index 0000000..b7c1130
--- /dev/null
@@ -0,0 +1,5 @@
+Package: openser-mod-group
+Depends: openser
+Section: net
+Priority: optional
+Description: group support for OpenSER
diff --git a/openwrt/package/openser/ipkg/openser-mod-msilo.control b/openwrt/package/openser/ipkg/openser-mod-msilo.control
new file mode 100644 (file)
index 0000000..215701e
--- /dev/null
@@ -0,0 +1,5 @@
+Package: openser-mod-msilo
+Depends: openser
+Section: net
+Priority: optional
+Description: msilo support for OpenSER
diff --git a/openwrt/package/openser/ipkg/openser-mod-options.control b/openwrt/package/openser/ipkg/openser-mod-options.control
new file mode 100644 (file)
index 0000000..b94da0b
--- /dev/null
@@ -0,0 +1,5 @@
+Package: openser-mod-options
+Depends: openser
+Section: net
+Priority: optional
+Description: options support for OpenSER
diff --git a/openwrt/package/openser/ipkg/openser-mod-pdt.control b/openwrt/package/openser/ipkg/openser-mod-pdt.control
new file mode 100644 (file)
index 0000000..9539291
--- /dev/null
@@ -0,0 +1,5 @@
+Package: openser-mod-pdt
+Depends: openser
+Section: net
+Priority: optional
+Description: pdt support for OpenSER
diff --git a/openwrt/package/openser/ipkg/openser-mod-permissions.control b/openwrt/package/openser/ipkg/openser-mod-permissions.control
new file mode 100644 (file)
index 0000000..302abdb
--- /dev/null
@@ -0,0 +1,5 @@
+Package: openser-mod-permissions
+Depends: openser
+Section: net
+Priority: optional
+Description: permissions support for OpenSER
diff --git a/openwrt/package/openser/ipkg/openser-mod-pike.control b/openwrt/package/openser/ipkg/openser-mod-pike.control
new file mode 100644 (file)
index 0000000..c8a2111
--- /dev/null
@@ -0,0 +1,5 @@
+Package: openser-mod-pike
+Depends: openser
+Section: net
+Priority: optional
+Description: pike support for OpenSER
diff --git a/openwrt/package/openser/ipkg/openser-mod-uac-redirect.control b/openwrt/package/openser/ipkg/openser-mod-uac-redirect.control
new file mode 100644 (file)
index 0000000..9a4785f
--- /dev/null
@@ -0,0 +1,5 @@
+Package: openser-mod-uac-redirect
+Depends: openser
+Section: net
+Priority: optional
+Description: uac_redirect support for OpenSER
diff --git a/openwrt/package/openser/ipkg/openser-mod-uac.control b/openwrt/package/openser/ipkg/openser-mod-uac.control
new file mode 100644 (file)
index 0000000..957bbaa
--- /dev/null
@@ -0,0 +1,5 @@
+Package: openser-mod-uac
+Depends: openser
+Section: net
+Priority: optional
+Description: uac support for OpenSER
diff --git a/openwrt/package/openser/ipkg/openser-mod-uri-db.control b/openwrt/package/openser/ipkg/openser-mod-uri-db.control
new file mode 100644 (file)
index 0000000..a48560b
--- /dev/null
@@ -0,0 +1,5 @@
+Package: openser-mod-uri-db
+Depends: openser
+Section: net
+Priority: optional
+Description: uri_db support for OpenSER
diff --git a/openwrt/package/openser/ipkg/openser-mod-uri-radius.control b/openwrt/package/openser/ipkg/openser-mod-uri-radius.control
new file mode 100644 (file)
index 0000000..55f1b2a
--- /dev/null
@@ -0,0 +1,5 @@
+Package: openser-mod-uri-radius
+Depends: openser
+Section: net
+Priority: optional
+Description: uri_radius support for OpenSER
diff --git a/openwrt/package/openser/ipkg/openser-mod-uri.control b/openwrt/package/openser/ipkg/openser-mod-uri.control
new file mode 100644 (file)
index 0000000..ab9e33d
--- /dev/null
@@ -0,0 +1,5 @@
+Package: openser-mod-uri
+Depends: openser
+Section: net
+Priority: optional
+Description: uri support for OpenSER