proftpd: remove the postinst script for users/groups
authorFelix Fietkau <nbd@openwrt.org>
Sun, 13 Mar 2011 19:12:01 +0000 (19:12 +0000)
committerFelix Fietkau <nbd@openwrt.org>
Sun, 13 Mar 2011 19:12:01 +0000 (19:12 +0000)
SVN-Revision: 26140

net/proftpd/Makefile

index b0aa64f408e4a7898a81b55cecdd72ef85dd39f6..3a076a8379555e74a44f4f6781d80edbcc7a2e76 100644 (file)
@@ -57,41 +57,4 @@ define Package/proftpd/install
        $(CP) $(PKG_INSTALL_DIR)/usr/sbin/in.proftpd $(1)/usr/sbin/
 endef
 
-define Package/proftpd/postinst
-#!/bin/sh
-
-name=ftp
-id=55
-home=/home/$${name}
-shell=/bin/ash
-
-# do not change below
-# # check if we are on real system
-if [ -z "$${IPKG_INSTROOT}" ]; then
-        # create copies of passwd and group, if we use squashfs
-        rootfs=`mount |awk '/root/ { print $$5 }'`
-        if [ "$$rootfs" = "squashfs" ]; then
-                if [ -h /etc/group ]; then
-                        rm /etc/group
-                        cp /rom/etc/group /etc/group
-                fi
-                if [ -h /etc/passwd ]; then
-                        rm /etc/passwd
-                        cp /rom/etc/passwd /etc/passwd
-                fi
-        fi
-fi
-
-echo ""
-if [ -z "$$(grep ^\\$${name}: $${IPKG_INSTROOT}/etc/group)" ]; then
-        echo "adding group $$name to /etc/group"
-        echo "$${name}:x:$${id}:" >> $${IPKG_INSTROOT}/etc/group
-fi
-
-if [ -z "$$(grep ^\\$${name}: $${IPKG_INSTROOT}/etc/passwd)" ]; then
-        echo "adding user $$name to /etc/passwd"
-        echo "$${name}:x:$${id}:$${id}:$${name}:$${home}:$${shell}" >> $${IPKG_INSTROOT}/etc/passwd
-fi
-endef
-
 $(eval $(call BuildPackage,proftpd))