[packages] libshout: fix linking
authorJo-Philipp Wich <jow@openwrt.org>
Sun, 2 Jan 2011 00:09:11 +0000 (00:09 +0000)
committerJo-Philipp Wich <jow@openwrt.org>
Sun, 2 Jan 2011 00:09:11 +0000 (00:09 +0000)
SVN-Revision: 24874

libs/libshout/Makefile

index 1072e918c2e1f48160bff239588b9f3ee093f495..b7ef92ec88ea8242eba8d864ebee991075d0e960 100644 (file)
@@ -20,7 +20,7 @@ PKG_INSTALL:=1
 
 include $(INCLUDE_DIR)/package.mk
 
-TARGET_CFLAGS += $(FPIC)
+TARGET_CFLAGS += $(FPIC) -Wl,-rpath-link=$(STAGING_DIR)/usr/lib
 
 define Package/libshout
   SECTION:=libs
@@ -40,7 +40,7 @@ endef
 
 define Build/Configure
        $(call Build/Configure/Default, \
-               VORBIS_CFLAGS="-I$(STAGING_DIR)/usr/include/tremor/"\
+               VORBIS_CFLAGS="-I$(STAGING_DIR)/usr/include/tremor/" \
                VORBIS_LIBS="$(TARGET_LDFLAGS) -lvorbis -lvorbisidec" \
                --enable-shared \
                --enable-static \