micrond: show stdout and stderr in log 11922/head
authorAdrian Schmutzler <freifunk@adrianschmutzler.de>
Wed, 22 Apr 2020 14:57:34 +0000 (16:57 +0200)
committerAdrian Schmutzler <freifunk@adrianschmutzler.de>
Wed, 22 Apr 2020 14:57:34 +0000 (16:57 +0200)
So far, all output created by scripts run with micrond has been
discarded. Since there is no reason for that and it also does not
match the expected behavior, this enables both stdout and stderr
output for the service.

If not desired, a user can still use >/dev/null or similar in his/her
micrond jobs to disable output easily and similar to what it would be
on other systems.

Signed-off-by: Adrian Schmutzler <freifunk@adrianschmutzler.de>
utils/micrond/Makefile
utils/micrond/files/etc/init.d/micrond

index ba063b6749d2074a3f994abefc0eba7ae595de5f..c979025bba3d3c4fd81d1104090f285876897c4c 100644 (file)
@@ -2,7 +2,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=micrond
 PKG_VERSION:=1
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 PKG_LICENSE:=BSD-2-clause
 
 include $(INCLUDE_DIR)/package.mk
index 1eef2ef5215b593a3a7b9327296cf388ffae9483..35a3b9e70f6dd12740fa22a90694328e90f3521f 100755 (executable)
@@ -9,5 +9,7 @@ start_service() {
        procd_open_instance
        procd_set_param command /usr/sbin/micrond "$CRONDIR"
        procd_set_param respawn
+       procd_set_param stdout 1
+       procd_set_param stderr 1
        procd_close_instance
 }