libsml: update to 0.2
authorFlorian Fainelli <florian@openwrt.org>
Wed, 5 Dec 2012 18:04:18 +0000 (18:04 +0000)
committerFlorian Fainelli <florian@openwrt.org>
Wed, 5 Dec 2012 18:04:18 +0000 (18:04 +0000)
This patch updates the libsml package to the latest revision.

The current revision of the libsml package is outdated for 7 months.
Meanwhile, the developers of libsml provided various bug fixes,
notably to support big-endian machines correctly.

[florian: pass UNAME directly from the Makefiel]

Signed-off-by: Daniel Pauli <paulid@student.ethz.ch>
Signed-off-by: Florian Fainelli <florian@openwrt.org>
SVN-Revision: 34529

libs/libsml/Makefile
libs/libsml/patches/030-cross-compile.patch [deleted file]
libs/libsml/patches/030-cross_compile.patch [new file with mode: 0644]

index 32ff60f07f01f12a578d42cee297213ab4f042ae..b1649f7ca9a12538c7dd5419967ae06fc7695527 100644 (file)
@@ -8,9 +8,9 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=libsml
-PKG_VERSION:=0.1
+PKG_VERSION:=0.2
 PKG_RELEASE:=1
-PKG_REV:=4e546fb0db0bd4c0a2c3c2f3d29ac0a0ba6651a3
+PKG_REV:=550aa8216295ff76076f35ce2eb00872dfd83f8f
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=git://github.com/dailab/libsml.git
@@ -28,6 +28,9 @@ define Package/libsml
   DEPENDS:=+libuuid
 endef
 
+MAKE_FLAGS += \
+             UNAME="Linux"
+
 define Package/libsml/description
   libSML is a library which implements the Smart Messaging Language (SML) protocol specified by
   VDE's Forum Netztechnik/Netzbetrieb (FNN). It can be utilized to communicate to FNN specified
diff --git a/libs/libsml/patches/030-cross-compile.patch b/libs/libsml/patches/030-cross-compile.patch
deleted file mode 100644 (file)
index c7dcc22..0000000
+++ /dev/null
@@ -1,8 +0,0 @@
---- a/sml/Makefile
-+++ b/sml/Makefile
-@@ -1,4 +1,4 @@
--UNAME := $(shell uname)
-+UNAME := Linux
- CFLAGS += -I./include/ -fPIC -g -Wall
- # Available Flags:
diff --git a/libs/libsml/patches/030-cross_compile.patch b/libs/libsml/patches/030-cross_compile.patch
new file mode 100644 (file)
index 0000000..6e33014
--- /dev/null
@@ -0,0 +1,8 @@
+--- a/sml/Makefile     2012-12-05 18:54:49.000000000 +0100
++++ b/sml/Makefile     2012-12-05 19:01:26.347952235 +0100
+@@ -1,4 +1,4 @@
+-UNAME := $(shell uname)
++UNAME ?= $(shell uname)
+ CFLAGS += -I./include/ -fPIC -fno-stack-protector -g -Wall
+ # Available Flags: