ffmpeg: include/disable swresample where appropriate
authorLuka Perkov <luka@openwrt.org>
Thu, 28 Feb 2013 11:40:21 +0000 (11:40 +0000)
committerLuka Perkov <luka@openwrt.org>
Thu, 28 Feb 2013 11:40:21 +0000 (11:40 +0000)
libswresample is an audio resampling library within ffmpeg.

This patch disables swresample in libffmpeg-custom and libffmpeg-mini and adds
it to libffmpeg-full. Should correct build issue reported in #13089.

Signed-off-by: Ian Leonard <antonlacon@gmail.com>
SVN-Revision: 35832

multimedia/ffmpeg/Makefile

index d8ba2c44778339decd1d4191e275e9256c4cb3d3..bd4b4225cf5f4d601c189ef29c609bb5b6186ed8 100644 (file)
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=ffmpeg
 PKG_VERSION:=0.11.2
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
 PKG_SOURCE_URL:=http://ffmpeg.org/releases/
@@ -311,6 +311,7 @@ ifeq ($(BUILD_VARIANT),custom)
        --disable-ffserver \
        --disable-avfilter \
        --disable-postproc \
+       --disable-swresample \
        --disable-swscale \
        --disable-everything \
        $(call FFMPEG_ENABLE,encoder,$(FFMPEG_CUSTOM_ENCODERS),CONFIG_FFMPEG_CUSTOM_ENCODER) \
@@ -336,6 +337,7 @@ ifeq ($(BUILD_VARIANT),mini)
        --disable-ffserver \
        --disable-avfilter \
        --disable-postproc \
+       --disable-swresample \
        --disable-swscale \
        --disable-everything \
        $(call FFMPEG_ENABLE,encoder,$(FFMPEG_MINI_ENCODERS)) \
@@ -372,11 +374,11 @@ endef
 
 define Build/InstallDev/full
        $(INSTALL_DIR) $(1)/usr/include
-       $(CP) $(PKG_INSTALL_DIR)/usr/include/lib{avcodec,avdevice,avfilter,avformat,avutil,postproc,swscale} $(1)/usr/include/
+       $(CP) $(PKG_INSTALL_DIR)/usr/include/lib{avcodec,avdevice,avfilter,avformat,avutil,postproc,swresample,swscale} $(1)/usr/include/
        $(INSTALL_DIR) $(1)/usr/lib
-       $(CP) $(PKG_INSTALL_DIR)/usr/lib/lib{avcodec,avdevice,avfilter,avformat,avutil,postproc,swscale}.{a,so*} $(1)/usr/lib/
+       $(CP) $(PKG_INSTALL_DIR)/usr/lib/lib{avcodec,avdevice,avfilter,avformat,avutil,postproc,swresample,swscale}.{a,so*} $(1)/usr/lib/
        $(INSTALL_DIR) $(1)/usr/lib/pkgconfig
-       $(CP) $(PKG_INSTALL_DIR)/usr/lib/pkgconfig/lib{avcodec,avdevice,avfilter,avformat,avutil,postproc,swscale}.pc $(1)/usr/lib/pkgconfig/
+       $(CP) $(PKG_INSTALL_DIR)/usr/lib/pkgconfig/lib{avcodec,avdevice,avfilter,avformat,avutil,postproc,swresample,swscale}.pc $(1)/usr/lib/pkgconfig/
 endef
 
 Build/InstallDev/mini = $(Build/InstallDev/custom)
@@ -421,7 +423,7 @@ endef
 
 define Package/libffmpeg-full/install
        $(INSTALL_DIR) $(1)/usr/lib
-       $(CP) $(PKG_INSTALL_DIR)/usr/lib/lib{avcodec,avdevice,avfilter,avformat,avutil,postproc,swscale}.so.* $(1)/usr/lib/
+       $(CP) $(PKG_INSTALL_DIR)/usr/lib/lib{avcodec,avdevice,avfilter,avformat,avutil,postproc,swresample,swscale}.so.* $(1)/usr/lib/
 endef
 
 Package/libffmpeg-mini/install = $(Package/libffmpeg-custom/install)