lcd4linux: Possibility added that the config can also be loaded from /tmp
authorFlorian Eckert <fe@dev.tdt.de>
Thu, 10 Jun 2021 08:11:25 +0000 (10:11 +0200)
committerFlorian Eckert <fe@dev.tdt.de>
Wed, 28 Sep 2022 08:19:12 +0000 (10:19 +0200)
Until now, the configuration must be stored under '/etc/lcd4linux.conf'.
So that the configuration can also be changed dynamically, it makes
sense to store this under /tmp and load them from this directory.
The init script first checks whether there is a configuration under
'/etc/lcd4linux.conf' and only then does it try to find it under
'/tmp/lcd4linux.conf'. If there is no configuration, an error message
is shown.

Signed-off-by: Florian Eckert <fe@dev.tdt.de>
utils/lcd4linux/Makefile
utils/lcd4linux/files/lcd4linux.init

index 20eac0748af9db77f5fe429ec6d32cc96b3a3253..4f42576dab88e50ed004f16ad53c90a2b1432e93 100644 (file)
@@ -8,7 +8,7 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=lcd4linux
-PKG_RELEASE:=7
+PKG_RELEASE:=8
 
 PKG_SOURCE_PROTO:=git
 PKG_SOURCE_URL:=https://github.com/feckert/lcd4linux
index a5e6a9db45340bcaa82fc90ae437fc02f27c5722..3c743b04750a6547c8084f66d1b62fb0e4fe08b6 100644 (file)
@@ -5,10 +5,19 @@ START=98
 USE_PROCD=1
 
 PROG="/usr/bin/lcd4linux"
-CONFIGFILE="/etc/lcd4linux.conf"
+STATIC_CONFIG="/etc/lcd4linux.conf"
+DYNAMIC_CONFIG="/tmp/lcd4linux.conf"
 
 start_service() {
-       [ -f /etc/lcd4linux.conf ] || return 1
+       if [ -f "$DYNAMIC_CONFIG" ]; then
+               CONFIGFILE="$DYNAMIC_CONFIG"
+       elif [ -f "$STATIC_CONFIG" ]; then
+               CONFIGFILE="$STATIC_CONFIG"
+       else
+               echo "No config found"
+               return 1
+       fi
+
        procd_open_instance
        procd_set_param command "$PROG"
        procd_append_param command -F