Lua-cURLv3: add package 16106/head
authorRainer Poisel <rainer.poisel@gmail.com>
Sat, 10 Jul 2021 21:53:41 +0000 (23:53 +0200)
committerRainer Poisel <rainer.poisel@gmail.com>
Fri, 16 Jul 2021 17:03:02 +0000 (19:03 +0200)
Signed-off-by: Rainer Poisel <rainer.poisel@gmail.com>
lang/lua-curl-v3/Makefile [new file with mode: 0644]

diff --git a/lang/lua-curl-v3/Makefile b/lang/lua-curl-v3/Makefile
new file mode 100644 (file)
index 0000000..5855b61
--- /dev/null
@@ -0,0 +1,43 @@
+#
+# Copyright (C) 2021 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=lua-curl-v3
+PKG_VERSION:=0.3.13-snapshot
+PKG_RELEASE:=1
+PKG_LICENSE:=MIT
+PKG_LICENSE_FILES:=LICENSE
+
+PKG_SOURCE_URL:=https://github.com/Lua-cURL/Lua-cURLv3.git
+PKG_MIRROR_HASH:=84a12b287cafc984df3e58b438b2b2d1092054e002144f225dee1c2efb18c8d3
+PKG_SOURCE_PROTO:=git
+PKG_SOURCE_VERSION:=9f8b6dba8b5ef1b26309a571ae75cda4034279e5
+
+include $(INCLUDE_DIR)/package.mk
+
+define Package/lua-curl-v3
+    SUBMENU:=Lua
+    SECTION:=lang
+    CATEGORY:=Languages
+    TITLE:=Lua-curl
+    DEPENDS:=+libcurl +lua
+    MAINTAINER:=Rainer Poisel <rainer.poisel@gmail.com>
+endef
+
+define Package/lua-curl-v3/description
+       Lua bindings to libcurl (Lua-cURLv3)
+endef
+
+define Package/lua-curl-v3/install
+       $(INSTALL_DIR) $(1)/usr/lib/lua
+       $(INSTALL_BIN) $(PKG_BUILD_DIR)/lcurl.so $(1)/usr/lib/lua
+       $(CP) $(PKG_BUILD_DIR)/src/lua/* $(1)/usr/lib/lua
+endef
+
+$(eval $(call BuildPackage,lua-curl-v3))
+