sunxi: generalize top-level BOARDNAME and update suported SoCs
authorSebastian Pflieger <sebastian@pflieger.email>
Mon, 18 Sep 2023 12:04:09 +0000 (14:04 +0200)
committerHauke Mehrtens <hauke@hauke-m.de>
Sun, 24 Sep 2023 16:16:40 +0000 (18:16 +0200)
Allwinner created to may SoC variants to list them all at top-level.

Signed-off-by: Sebastian Pflieger <sebastian@pflieger.email>
target/linux/sunxi/Makefile
target/linux/sunxi/cortexa53/target.mk

index acca20f123305e254a1d8ca3218755819086e847..74caebd7b1b3af74770566d0dd0d60cf5ad3a8fb 100644 (file)
@@ -6,7 +6,7 @@ include $(TOPDIR)/rules.mk
 
 ARCH:=arm
 BOARD:=sunxi
-BOARDNAME:=Allwinner A1x/A20/A3x/H3/H5/R40
+BOARDNAME:=Allwinner ARM SoCs
 FEATURES:=fpu usb ext4 display rootfs-part rtc squashfs
 SUBTARGETS:=cortexa8 cortexa7 cortexa53
 
@@ -21,6 +21,7 @@ KERNELNAME:=zImage dtbs
 # A80: octa Cortex-A15/A7
 # H3: quad Cortex-A7
 # R40: quad Cortex-A7
+# A64/H5/H6/H616: quad Cortex-A53
 
 include $(INCLUDE_DIR)/target.mk
 
index 9e3a4064be8dd497c92ce1bded69e292517cb738..771e07d29fcc0b9d41a57245b630976978d07a12 100644 (file)
@@ -5,6 +5,6 @@
 include $(TOPDIR)/rules.mk
 
 ARCH:=aarch64
-BOARDNAME:=Allwinner A64/H5
+BOARDNAME:=Allwinner A64/H5/H6/H616
 CPU_TYPE:=cortex-a53
 KERNELNAME:=Image dtbs