mpd: Update to 0.19.17, refresh patches
authorTed Hess <thess@kitschensync.net>
Wed, 20 Jul 2016 14:54:46 +0000 (10:54 -0400)
committerTed Hess <thess@kitschensync.net>
Wed, 20 Jul 2016 14:54:46 +0000 (10:54 -0400)
Signed-off-by: Ted Hess <thess@kitschensync.net>
sound/mpd/Makefile
sound/mpd/patches/100-musl_gcc5_fixes.patch [deleted file]
sound/mpd/patches/210-support_raw_pcm_streams.patch
sound/mpd/patches/220-handle_slow_server_stream_startup.patch

index ae444a81bc9053221685364bb7eea009cb26fc9a..a6c50a3aad0181f8894703d9977a186d46148181 100644 (file)
@@ -8,12 +8,12 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=mpd
-PKG_VERSION:=0.19.14
+PKG_VERSION:=0.19.17
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
 PKG_SOURCE_URL:=http://www.musicpd.org/download/mpd/0.19/
-PKG_MD5SUM:=9f99340ec6b77bea4ba3729e3b76fd7c
+PKG_MD5SUM:=47e13f3f160bf94e7a897c5a48990f3d
 PKG_MAINTAINER:=Ted Hess <thess@kitschensync.net>
 
 PKG_LICENSE:=GPL-2.0
diff --git a/sound/mpd/patches/100-musl_gcc5_fixes.patch b/sound/mpd/patches/100-musl_gcc5_fixes.patch
deleted file mode 100644 (file)
index 924cc40..0000000
+++ /dev/null
@@ -1,28 +0,0 @@
-Add a patch from the Alpine Linux project to fix a musl build issue with gcc 5: 
-
-Problem has been reported upstream and closed with WONTFIX:
-http://bugs.musicpd.org/view.php?id=4387
-http://bugs.musicpd.org/view.php?id=4110
-
-however...
-
-POSIX does not permit using PTHREAD_COND_INITIALIZER except for static
-initialization, and certainly does not permit using it as a value
-
-POSIX does not specify the type of the object (it's opaque) so if
-there are any types for which their code would be invalid C++, then their
-code is invalid
-
-Volatile in the type is necessary. without that, LTO can break the code.
-
---- a/src/notify.hxx
-+++ b/src/notify.hxx
-@@ -28,7 +28,7 @@ struct notify {
-       Cond cond;
-       bool pending;
--#if !defined(WIN32) && !defined(__NetBSD__) && !defined(__BIONIC__)
-+#if defined(__GLIBC__)
-       constexpr
- #endif
-       notify():pending(false) {}
index 69dac9f3da46abd11d84683a56b7765fc1d04093..275657061f79a457294448fcb4c9c0c03ac35a4f 100644 (file)
@@ -1,6 +1,6 @@
 --- a/src/decoder/plugins/FfmpegDecoderPlugin.cxx
 +++ b/src/decoder/plugins/FfmpegDecoderPlugin.cxx
-@@ -774,6 +774,7 @@ static const char *const ffmpeg_mime_typ
+@@ -777,6 +777,7 @@ static const char *const ffmpeg_mime_typ
        "audio/qcelp",
        "audio/vorbis",
        "audio/vorbis+ogg",
index 62a4e59f73ea8d9eeab09b5c9ec0d2d3864a33c9..2ebb91cc0dd2c8d381ea6c1ea50ac17023bcd8be 100644 (file)
@@ -1,6 +1,6 @@
 --- a/src/decoder/plugins/FfmpegDecoderPlugin.cxx
 +++ b/src/decoder/plugins/FfmpegDecoderPlugin.cxx
-@@ -467,6 +467,13 @@ ffmpeg_probe(Decoder *decoder, InputStre
+@@ -465,6 +465,13 @@ ffmpeg_probe(Decoder *decoder, InputStre
  
        unsigned char buffer[BUFFER_SIZE];
        size_t nbytes = decoder_read(decoder, is, buffer, BUFFER_SIZE);