add ethernet bonding driver, closes #171
authorWaldemar Brodkorb <mail@waldemar-brodkorb.de>
Sun, 8 Jan 2006 03:02:12 +0000 (03:02 +0000)
committerWaldemar Brodkorb <mail@waldemar-brodkorb.de>
Sun, 8 Jan 2006 03:02:12 +0000 (03:02 +0000)
SVN-Revision: 2861

openwrt/target/linux/Config.in
openwrt/target/linux/control/kmod-bonding.control [new file with mode: 0644]
openwrt/target/linux/linux-2.4/Makefile
openwrt/target/linux/linux-2.4/config/brcm

index e337ad02beb53e0d727f80c1fcc7a23faaa5e43d..ff48d89604fc22dafbabdbb404ca22aef7bd0286 100644 (file)
@@ -361,5 +361,11 @@ config BR2_PACKAGE_KMOD_SOFTDOG
        help
          Kernel modules for software watchdog driver
 
+config BR2_PACKAGE_KMOD_BONDING
+       tristate "Kernel driver for ethernet bonding"
+       default m
+       help
+         Kernel modules for ethernet bonding
+
 
 source "target/linux/package/Config.in"
diff --git a/openwrt/target/linux/control/kmod-bonding.control b/openwrt/target/linux/control/kmod-bonding.control
new file mode 100644 (file)
index 0000000..0b4f45d
--- /dev/null
@@ -0,0 +1,6 @@
+Package: kmod-bonding
+Priority: optional
+Section: sys
+Maintainer: OpenWrt Developers Team <openwrt-devel@openwrt.org>
+Source: buildroot internal
+Description: Kernel ethernet bonding driver
index ff426fdaffb795ebb35dc39e80dabbc3d2eb7c62..4e586869b08a73ac05cee4899004e42bf33bd9f0 100644 (file)
@@ -201,6 +201,10 @@ $(eval $(call KMOD_template,SOFTDOG,softdog,\
        $(MODULES_DIR)/kernel/drivers/char/softdog.o \
 ))
 
+$(eval $(call KMOD_template,BONDING,bonding,\
+       $(MODULES_DIR)/kernel/drivers/net/bonding/bonding.o \
+))
+
 $(TARGETS): $(PACKAGE_DIR)
 
 $(PACKAGE_DIR):
index 292f30fc7283d91c354c560599aa4ef4318f0a97..250e12e8aea8f619be72e47773013b5bc84cb26b 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Automatically generated make config: don't edit
+# Automatically generated by make menuconfig: don't edit
 #
 CONFIG_MIPS=y
 CONFIG_MIPS32=y
@@ -182,10 +182,6 @@ CONFIG_MTD_PARTITIONS=y
 # CONFIG_MTD_CONCAT is not set
 # CONFIG_MTD_REDBOOT_PARTS is not set
 # CONFIG_MTD_CMDLINE_PARTS is not set
-
-#
-# User Modules And Translation Layers
-#
 CONFIG_MTD_CHAR=y
 CONFIG_MTD_BLOCK=y
 # CONFIG_FTL is not set
@@ -250,10 +246,6 @@ CONFIG_MTD_BCM947XX=y
 # CONFIG_MTD_SLRAM is not set
 # CONFIG_MTD_MTDRAM is not set
 # CONFIG_MTD_BLKMTD is not set
-
-#
-# Disk-On-Chip Device Drivers
-#
 # CONFIG_MTD_DOC1000 is not set
 # CONFIG_MTD_DOC2000 is not set
 # CONFIG_MTD_DOC2001 is not set
@@ -447,10 +439,6 @@ CONFIG_IP6_NF_TARGET_IMQ=m
 # CONFIG_IP_SCTP is not set
 # CONFIG_ATM is not set
 CONFIG_VLAN_8021Q=y
-
-#
-#  
-#
 # CONFIG_IPX is not set
 # CONFIG_ATALK is not set
 # CONFIG_DECNET is not set
@@ -535,10 +523,6 @@ CONFIG_IDE=m
 # IDE, ATA and ATAPI Block devices
 #
 CONFIG_BLK_DEV_IDE=m
-
-#
-# Please see Documentation/ide.txt for help/info on IDE drives
-#
 # CONFIG_BLK_DEV_HD_IDE is not set
 # CONFIG_BLK_DEV_HD is not set
 # CONFIG_BLK_DEV_IDE_SATA is not set
@@ -552,10 +536,6 @@ CONFIG_IDEDISK_STROKE=y
 # CONFIG_BLK_DEV_IDEFLOPPY is not set
 # CONFIG_BLK_DEV_IDESCSI is not set
 # CONFIG_IDE_TASK_IOCTL is not set
-
-#
-# IDE chipset support/bugfixes
-#
 # CONFIG_BLK_DEV_CMD640 is not set
 # CONFIG_BLK_DEV_CMD640_ENHANCED is not set
 # CONFIG_BLK_DEV_ISAPNP is not set
@@ -613,20 +593,12 @@ CONFIG_BLK_DEV_PDC202XX=y
 # SCSI support
 #
 CONFIG_SCSI=m
-
-#
-# SCSI support type (disk, tape, CD-ROM)
-#
 CONFIG_BLK_DEV_SD=m
 CONFIG_SD_EXTRA_DEVS=5
 # CONFIG_CHR_DEV_ST is not set
 # CONFIG_CHR_DEV_OSST is not set
 # CONFIG_BLK_DEV_SR is not set
 CONFIG_CHR_DEV_SG=m
-
-#
-# Some SCSI devices (e.g. CD jukebox) support multiple LUNs
-#
 # CONFIG_SCSI_DEBUG_QUEUES is not set
 CONFIG_SCSI_MULTI_LUN=y
 # CONFIG_SCSI_CONSTANTS is not set
@@ -734,7 +706,7 @@ CONFIG_HND=y
 #
 # CONFIG_ARCNET is not set
 # CONFIG_DUMMY is not set
-# CONFIG_BONDING is not set
+CONFIG_BONDING=m
 # CONFIG_EQUALIZER is not set
 CONFIG_IMQ=m
 CONFIG_TUN=m
@@ -838,10 +810,6 @@ CONFIG_WL=m
 # CONFIG_PLX_HERMES is not set
 # CONFIG_TMD_HERMES is not set
 # CONFIG_PCI_HERMES is not set
-
-#
-# Prism54 PCI/PCMCIA GT/Duette Driver - 802.11(a/b/g)
-#
 # CONFIG_PRISM54 is not set
 CONFIG_NET_WIRELESS=y
 
@@ -913,14 +881,6 @@ CONFIG_PPDEV=m
 # Joysticks
 #
 # CONFIG_INPUT_GAMEPORT is not set
-
-#
-# Input core support is needed for gameports
-#
-
-#
-# Input core support is needed for joysticks
-#
 # CONFIG_QIC02_TAPE is not set
 # CONFIG_IPMI_HANDLER is not set
 # CONFIG_IPMI_PANIC_EVENT is not set
@@ -1145,10 +1105,6 @@ CONFIG_VIDEO_DEV=m
 #
 CONFIG_VIDEO_PROC_FS=y
 # CONFIG_I2C_PARPORT is not set
-
-#
-# Video Adapters
-#
 # CONFIG_VIDEO_BT848 is not set
 # CONFIG_VIDEO_PMS is not set
 # CONFIG_VIDEO_BWQCAM is not set
@@ -1182,24 +1138,12 @@ CONFIG_VIDEO_PROC_FS=y
 #
 CONFIG_USB=m
 # CONFIG_USB_DEBUG is not set
-
-#
-# Miscellaneous USB options
-#
 CONFIG_USB_DEVICEFS=y
 # CONFIG_USB_BANDWIDTH is not set
-
-#
-# USB Host Controller Drivers
-#
 CONFIG_USB_EHCI_HCD=m
 # CONFIG_USB_UHCI is not set
 CONFIG_USB_UHCI_ALT=m
 CONFIG_USB_OHCI=m
-
-#
-# USB Device Class drivers
-#
 # CONFIG_USB_AUDIO is not set
 # CONFIG_USB_EMI26 is not set
 # CONFIG_USB_BLUETOOTH is not set
@@ -1216,15 +1160,7 @@ CONFIG_USB_STORAGE_SDDR55=y
 CONFIG_USB_STORAGE_JUMPSHOT=y
 CONFIG_USB_ACM=m
 CONFIG_USB_PRINTER=m
-
-#
-# USB Human Interface Devices (HID)
-#
 # CONFIG_USB_HID is not set
-
-#
-#     Input core support is needed for USB HID input layer or HIDBP support
-#
 # CONFIG_USB_HIDINPUT is not set
 # CONFIG_USB_HIDDEV is not set
 # CONFIG_USB_KBD is not set
@@ -1233,19 +1169,11 @@ CONFIG_USB_PRINTER=m
 # CONFIG_USB_WACOM is not set
 # CONFIG_USB_KBTAB is not set
 # CONFIG_USB_POWERMATE is not set
-
-#
-# USB Imaging devices
-#
 # CONFIG_USB_DC2XX is not set
 # CONFIG_USB_MDC800 is not set
 # CONFIG_USB_SCANNER is not set
 # CONFIG_USB_MICROTEK is not set
 # CONFIG_USB_HPUSBSCSI is not set
-
-#
-# USB Multimedia devices
-#
 # CONFIG_USB_IBMCAM is not set
 # CONFIG_USB_KONICAWC is not set
 # CONFIG_USB_OV511 is not set
@@ -1256,30 +1184,18 @@ CONFIG_USB_PWC=m
 # CONFIG_USB_VICAM is not set
 # CONFIG_USB_DSBR is not set
 # CONFIG_USB_DABUSB is not set
-
-#
-# USB Network adaptors
-#
 # CONFIG_USB_PEGASUS is not set
 # CONFIG_USB_RTL8150 is not set
 # CONFIG_USB_KAWETH is not set
 # CONFIG_USB_CATC is not set
 # CONFIG_USB_CDCETHER is not set
 # CONFIG_USB_USBNET is not set
-
-#
-# USB port drivers
-#
 # CONFIG_USB_USS720 is not set
 
 #
 # USB Serial Converter support
 #
 # CONFIG_USB_SERIAL is not set
-
-#
-# USB Miscellaneous drivers
-#
 # CONFIG_USB_RIO500 is not set
 # CONFIG_USB_AUERSWALD is not set
 # CONFIG_USB_TIGL is not set