ddns-scripts: remove gzip timestamp 5214/head
authorAlexander Couzens <lynxis@fe80.eu>
Sun, 3 Dec 2017 05:14:47 +0000 (06:14 +0100)
committerAlexander Couzens <lynxis@fe80.eu>
Sun, 3 Dec 2017 05:24:21 +0000 (06:24 +0100)
gzip create a header by default containing the filename
and the timestamp of the file.
This timestamp will break reproducible builds [0].

[0] https://reproducible-builds.org/docs/timestamps/

Signed-off-by: Alexander Couzens <lynxis@fe80.eu>
net/ddns-scripts/Makefile

index d20956a3e7623ed805423284e1dceb45fb066057..d4023c01fa88bd8ffe3d5b9196c10462af1f3c96 100755 (executable)
@@ -12,7 +12,7 @@ PKG_NAME:=ddns-scripts
 PKG_VERSION:=2.7.6
 # Release == build
 # increase on changes of services files or tld_names.dat
-PKG_RELEASE:=20
+PKG_RELEASE:=21
 
 PKG_LICENSE:=GPL-2.0
 PKG_MAINTAINER:=Christian Schoenebeck <christian.schoenebeck@gmail.com>
@@ -129,7 +129,7 @@ define Build/Compile
                -e '/^[[:space:]]*$$$$/d'       $$$$FILE; \
        done
        # compress public_suffix_list.dat
-       gzip -f9 $(PKG_BUILD_DIR)/files/public_suffix_list.dat
+       gzip -nf9 $(PKG_BUILD_DIR)/files/public_suffix_list.dat
 endef
 
 define Package/ddns-scripts/conffiles