kernel: robustify dependencies in kmod-sound-hda-core
authorTony Ambardar <itugrok@yahoo.com>
Sun, 21 Mar 2021 06:30:44 +0000 (23:30 -0700)
committerPaul Spooren <mail@aparcar.org>
Sun, 21 Mar 2021 09:57:58 +0000 (23:57 -1000)
Dependency tracking for kmod-sound-hda-core is fragile. Enabling some sound
codecs (Realtek, Conexant, Sigmatel) implicitly adds a kmod-ledtrig-audio
dependency, while an enabled kmod-ledtrig-audio can be picked up through
enabling others (e.g. kmod-sound-hda-intel), and the behaviour can change
across kernel versions.

As kmod-ledtrig-audio is under 2KB, make it an unconditional dependency.

Fixes: a374b8f19051 ("kernel: 5.10: update sound modules")
Signed-off-by: Tony Ambardar <itugrok@yahoo.com>
package/kernel/linux/modules/sound.mk

index 2c11d078e16bb815dcb1058480bdfcf545202af3..e43be25bc67143f4f5fa4c0f2eefdc1840f763e5 100644 (file)
@@ -304,10 +304,7 @@ $(eval $(call KernelPackage,sound-dummy))
 define KernelPackage/sound-hda-core
   SUBMENU:=$(SOUND_MENU)
   TITLE:=HD Audio Sound Core Support
-  DEPENDS:= \
-       +LINUX_5_10&&PACKAGE_kmod-sound-hda-codec-realtek:kmod-ledtrig-audio \
-       +LINUX_5_10&&PACKAGE_kmod-sound-hda-codec-conexant:kmod-ledtrig-audio \
-       +LINUX_5_10&&PACKAGE_kmod-sound-hda-codec-idt:kmod-ledtrig-audio
+  DEPENDS:=+kmod-ledtrig-audio
   KCONFIG:= \
        CONFIG_SND_HDA_CORE \
        CONFIG_SND_HDA_HWDEP=y \