Merge pull request #10467 from srchack/open-vm-tools-bump-11.0.1
authorRosen Penev <rosenp@gmail.com>
Wed, 6 Nov 2019 16:52:23 +0000 (08:52 -0800)
committerGitHub <noreply@github.com>
Wed, 6 Nov 2019 16:52:23 +0000 (08:52 -0800)
open-vm-tools: bump to version 11.0.1

20 files changed:
.circleci/config.yml
libs/redis/Makefile
multimedia/youtube-dl/Makefile
net/frr/Config.in [new file with mode: 0644]
net/frr/Makefile
net/frr/patches/001-vti_interface_fix.patch [new file with mode: 0644]
net/frr/patches/002-bgp_clippy_typo.patch [new file with mode: 0644]
net/frr/patches/003-corss_cares_fix.patch [new file with mode: 0644]
net/frr/patches/004-cross_libcap_fix.patch [new file with mode: 0644]
net/frr/patches/005-fix_OSPF_BFD.patch [new file with mode: 0644]
net/keepalived/Makefile
net/shadowsocks-libev/README.md
utils/btrfs-progs/Makefile
utils/collectd/Makefile
utils/collectd/patches/320-reaction-to-ntp-time-change-at-boot.patch [new file with mode: 0644]
utils/containerd/Makefile
utils/docker-ce/Makefile
utils/docker-ce/patches/002-imporve-hardcoded-CC-on-cross-compile.patch [new file with mode: 0644]
utils/libnetwork/Makefile
utils/runc/Makefile

index 8b28976f9ff48808f03df1c3c7c2c9041db4083a..014c09b04766a1bad51a85229250f1f53e82b5d8 100644 (file)
@@ -148,7 +148,16 @@ jobs:
                  echo_green "=> Package check OK"
              done
 
+             make \
+                 -f .config \
+                 -f tmp/.packagedeps \
+                 -f <(echo '$(info $(sort $(package-y) $(package-m)))'; echo -en 'a:\n\t@:') \
+              | tr ' ' '\n' >enabled-package-subdirs.txt
              for PKG in $PKGS ; do
+                 if ! grep -m1 -qE "(^|/)$PKG$" enabled-package-subdirs.txt; then
+                        echo_red "===+ Building: $PKG skipped. It cannot be enabled with $SDK_FILE"
+                        continue
+                 fi
                  echo_blue "===+ Building: $PKG"
                  make "package/$PKG/compile" -j3 V=s || {
                         RET=$?
index c8f93be91da30a2eec59b83be18784689fb17c51..d6ccb6c29f7c4a2b98fbb890c1e3dc024350e3ef 100644 (file)
@@ -1,12 +1,12 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=redis
-PKG_VERSION:=5.0.5
-PKG_RELEASE:=2
+PKG_VERSION:=5.0.6
+PKG_RELEASE:=1
 
 PKG_SOURCE_URL:=http://download.redis.io/releases/
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
-PKG_HASH:=2139009799d21d8ff94fc40b7f36ac46699b9e1254086299f8d3b223ca54a375
+PKG_HASH:=6624841267e142c5d5d5be292d705f8fb6070677687c5aad1645421a936d22b3
 
 PKG_MAINTAINER:=Jan Pavlinec <jan.pavlinec@nic.cz>
 PKG_LICENSE:=BSD-3-Clause
index 6a36dc5f9572633d918f37c8265d20ad2fdf0f69..52b465e93f42b35967f57066f02b169ac4981184 100644 (file)
@@ -8,11 +8,11 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=youtube-dl
-PKG_VERSION:=2019.10.29
+PKG_VERSION:=2019.11.5
 PKG_RELEASE:=1
 
 PYPI_NAME:=youtube_dl
-PKG_HASH:=0b6611807b0bb978a0384ddebf215ea1f974ecf73d80d04e9f614ff30b1443f0
+PKG_HASH:=25324aab78df9a09b2ee34f642f116933134bc66ea629a778c1fffe05b66f733
 
 PKG_MAINTAINER:=Adrian Panella <ianchi74@outlook.com>, Josef Schlehofer <pepe.schlehofer@gmail.com>
 PKG_LICENSE:=Unlicense
diff --git a/net/frr/Config.in b/net/frr/Config.in
new file mode 100644 (file)
index 0000000..2c4169a
--- /dev/null
@@ -0,0 +1,18 @@
+
+if PACKAGE_frr
+comment "SSL support"
+
+choice
+        prompt "Selected SSL MD5 library"
+        default FRR_INTERNAL
+
+        config FRR_OPENSSL
+                bool "OpenSSL"
+
+        config FRR_INTERNAL
+                bool "internal SSL support"
+endchoice
+
+comment Packages
+
+endif
index c507eaad8c6ab023a71646c843c7052630d01884..d9d2b3115a7537e86de9750e2f9322b14eb9800f 100644 (file)
@@ -7,35 +7,42 @@
 
 include $(TOPDIR)/rules.mk
 PKG_NAME:=frr
-PKG_VERSION:=7.1
-PKG_RELEASE:=2
+PKG_VERSION:=7.2
+PKG_RELEASE:=1
 
 PKG_SOURCE_URL:=https://github.com/FRRouting/frr/releases/download/$(PKG_NAME)-$(PKG_VERSION)/
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
-PKG_HASH:=2a4210565e7b41d366f7b9f5f745917d67a0b159f3b6bd49d75f9e730557db2f
+PKG_HASH:=6cd5bfb6975133ccf23cc3f3a1c1c9a3f6d6a6c792c763b3ea010db75b3de5b3
 PKG_MAINTAINER:=Lucian Cristian <lucian.cristian@gmail.com>
 
+PKG_DAEMON_AVAILABLE:= \
+       babeld \
+       bfdd \
+       bgpd \
+       eigrpd \
+       fabricd \
+       isisd \
+       ldpd \
+       nhrpd \
+       ospfd \
+       ospf6d \
+       pbrd \
+       pimd \
+       ripd \
+       ripngd \
+       staticd \
+       vrrpd
+
+
 PKG_CONFIG_DEPENDS:= \
        CONFIG_IPV6 \
-       CONFIG_PACKAGE_frr-babeld \
-       CONFIG_PACKAGE_frr-bfdd \
-       CONFIG_PACKAGE_frr-bgpd \
-       CONFIG_PACKAGE_frr-eigrpd \
-       CONFIG_PACKAGE_frr-fabricd \
-       CONFIG_PACKAGE_frr-isisd \
-       CONFIG_PACKAGE_frr-ldpd \
+       CONFIG_FRR_OPENSSL \
+       CONFIG_FRR_INTERNAL \
        CONFIG_PACKAGE_frr-libfrr \
-       CONFIG_PACKAGE_frr-nhrpd \
-       CONFIG_PACKAGE_frr-ospfd \
-       CONFIG_PACKAGE_frr-ospf6d \
-       CONFIG_PACKAGE_frr-pbrd \
-       CONFIG_PACKAGE_frr-pimd \
-       CONFIG_PACKAGE_frr-ripd \
-       CONFIG_PACKAGE_frr-ripngd \
-       CONFIG_PACKAGE_frr-staticd \
        CONFIG_PACKAGE_frr-vtysh \
        CONFIG_PACKAGE_frr-watchfrr \
-       CONFIG_PACKAGE_frr-zebra
+       CONFIG_PACKAGE_frr-zebra \
+       $(patsubst %,CONFIG_PACKAGE_frr-%,$(PKG_DAEMON_AVAILABLE)) \
 
 PKG_BUILD_PARALLEL:=1
 PKG_BUILD_DEPENDS:=python3/host
@@ -45,18 +52,22 @@ PKG_LICENSE:=GPL-2.0
 include $(INCLUDE_DIR)/package.mk
 include $(INCLUDE_DIR)/host-build.mk
 
+define Package/frr-libfrr/config
+  source "$(SOURCE)/Config.in"
+endef
+
 define Package/frr/Default
   SECTION:=net
   CATEGORY:=Network
   SUBMENU:=Routing and Redirection
-  DEPENDS:=frr
-  TITLE:=The FRRouting (FRR) Software Routing Suite
   URL:=https://www.frrouting.org/
+  DEPENDS:=frr
 endef
 
 define Package/frr
   $(call Package/frr/Default)
   DEPENDS:=+librt
+  TITLE:=The FRRouting (FRR) Software Routing Suite
   MENU:=1
 endef
 
@@ -65,117 +76,20 @@ define Package/frr/description
   routing protocols.
 
   Currently FRRouting supports BGP4, BGP4+, OSPFv2, OSPFv3, RIPv1, RIPv2, RIPng,
-  IS-IS, PIM-SM/MSDP, LDP and Babel as well as very early support for EIGRP and
+  IS-IS, PIM-SM/MSDP, LDP, VRRP and Babel as well as very early support for EIGRP and
   NHRP.
 endef
 
-define Package/frr-babeld
-  $(call Package/frr/Default)
-  DEPENDS+=+frr-libfrr
-  TITLE:=BABEL routing engine
-endef
-
-define Package/frr-bfdd
-  $(call Package/frr/Default)
-  DEPENDS+=+frr-libfrr
-  TITLE:=BFD routing engine
-  CONFLICTS:=bfdd
-endef
-
-define Package/frr-bgpd
-  $(call Package/frr/Default)
-  DEPENDS+=+frr-libfrr
-  TITLE:=BGPv4, BGPv4+, BGPv4- routing engine
-  CONFLICTS:=quagga-bgpd
-endef
-
-define Package/frr-eigrpd
-  $(call Package/frr/Default)
-  DEPENDS+=+frr-libfrr
-  TITLE:=EIGRPD routing engine
-endef
-
-define Package/frr-fabricd
-  $(call Package/frr/Default)
-  DEPENDS+=+frr-libfrr
-  TITLE:=OpenFabric routing engine
-endef
-
-define Package/frr-isisd
-  $(call Package/frr/Default)
-  DEPENDS+=+frr-libfrr
-  TITLE:=IS-IS routing engine
-  CONFLICTS:=quagga-isisd
-endef
-
-define Package/frr-ldpd
-  $(call Package/frr/Default)
-  DEPENDS+=+frr-libfrr
-  TITLE:=LDP routing engine
-endef
-
 define Package/frr-libfrr
   $(call Package/frr/Default)
   TITLE:=zebra library
-  DEPENDS+=+libjson-c +libyang
+  DEPENDS+=+librt +libjson-c +libyang +FRR_OPENSSL:libopenssl
   CONFLICTS:=quagga-libzebra
 endef
 
-define Package/frr-nhrpd
-  $(call Package/frr/Default)
-  DEPENDS+=+frr-libfrr +libcares
-  TITLE:=NHRP routing engine
-endef
-
-define Package/frr-ospfd
-  $(call Package/frr/Default)
-  DEPENDS+=+frr-libfrr
-  TITLE:=OSPFv2 routing engine
-  CONFLICTS:=quagga-ospfd
-endef
-
-define Package/frr-ospf6d
-  $(call Package/frr/Default)
-  DEPENDS+=+frr-libfrr @IPV6
-  TITLE:=OSPFv3 routing engine
-  CONFLICTS:=quagga-ospf6d
-endef
-
-define Package/frr-pbrd
-  $(call Package/frr/Default)
-  DEPENDS+=+frr-libfrr
-  TITLE:=PBRD routing daemon
-endef
-
-define Package/frr-pimd
-  $(call Package/frr/Default)
-  DEPENDS+=+frr-libfrr
-  TITLE:=PIM routing engine
-endef
-
-define Package/frr-ripd
-  $(call Package/frr/Default)
-  DEPENDS+=+frr-libfrr
-  TITLE:=RIP routing engine
-  CONFLICTS:=quagga-ripd
-endef
-
-define Package/frr-ripngd
-  $(call Package/frr/Default)
-  DEPENDS+=+frr-libfrr @IPV6
-  TITLE:=RIPNG routing engine
-  CONFLICTS:=quagga-ripngd
-endef
-
-define Package/frr-staticd
-  $(call Package/frr/Default)
-  DEPENDS+=+frr-libfrr
-  TITLE:=STATICD routing engine
-endef
-
 define Package/frr-vtysh
   $(call Package/frr/Default)
-  DEPENDS+=+frr-libfrr +libreadline +libncurses
+  DEPENDS+=+frr-libfrr +libreadline +libncurses +more
   TITLE:=integrated shell for frr routing software
   CONFLICTS:=quagga-vtysh
 endef
@@ -195,19 +109,49 @@ define Package/frr-zebra
   CONFLICTS:=quagga-zebra
 endef
 
+##Migrate from quagga
+##should test file exists and link in frr folder
+#define Package/frr/postinst
+##!/bin/sh
+#if [ -f /etc/quagga/ospfd.conf ]; then
+#    ls to /etc/frr
+#    sed enable ospfd daemon
+#fi
+#exit 0
+#endef
+
+define BuildDaemon
+    define Package/frr-$(1)
+       $$(call Package/frr/Default)
+       TITLE:= $(1) routing engine
+       DEPENDS+=frr-libfrr $(2)
+    endef
+
+    define Package/frr-$(1)/install
+       $(INSTALL_DIR) $$(1)/usr/sbin
+       if [ "$(1)" != "fabricd" ]; then \
+       $(INSTALL_BIN) $(PKG_BUILD_DIR)/build/$(1)/.libs/$(1) $$(1)/usr/sbin/; \
+       else \
+       $(INSTALL_BIN) $(PKG_BUILD_DIR)/build/isisd/.libs/$(1) $$(1)/usr/sbin/; fi
+       if [ "$(1)" == "nhrpd" ]; then \
+       $(INSTALL_DIR) $$(1)/usr/lib; \
+       $(CP) $(PKG_BUILD_DIR)/build/lib/.libs/libfrrcares.so* $$(1)/usr/lib/; fi
+    endef
+
+    $$(eval $$(call BuildPackage,frr-$(1)))
+endef
+
 define Package/frr-libfrr/conffiles
 /etc/frr/
 endef
 
 define Build/Prepare
        $(Build/Prepare/Default)
-       mkdir -p $(PKG_BUILD_DIR)/build/lib
-       $(CP) $(PKG_BUILD_DIR)/lib/command.h $(PKG_BUILD_DIR)/build/lib/
+       mkdir -p $(PKG_BUILD_DIR)/build
 endef
 
 define Build/Configure
     ( cd $(PKG_BUILD_DIR)/build/ ; \
-    cd build ; \
     ../configure \
        --host="$(GNU_TARGET_NAME)" \
        --build="$(GNU_HOST_NAME)" \
@@ -229,26 +173,11 @@ define Build/Configure
        --disable-ospfclient \
        --disable-doc \
        --disable-backtrace \
-       --with-vtysh-pager=cat \
        --localstatedir=/var/run/frr \
        --sysconfdir=/etc/frr/ \
-       $(call autoconf_bool,CONFIG_PACKAGE_frr-babeld,babeld) \
-       $(call autoconf_bool,CONFIG_PACKAGE_frr-bfdd,bfdd) \
-       $(call autoconf_bool,CONFIG_PACKAGE_frr-bgpd,bgpd) \
-       $(call autoconf_bool,CONFIG_PACKAGE_frr-eigrpd,eigrpd) \
-       $(call autoconf_bool,CONFIG_PACKAGE_frr-fabricd,fabricd) \
-       $(call autoconf_bool,CONFIG_PACKAGE_frr-isisd,isisd) \
-       $(call autoconf_bool,CONFIG_PACKAGE_frr-ldpd,ldpd) \
-       $(call autoconf_bool,CONFIG_PACKAGE_frr-nhrpd,nhrpd) \
-       $(call autoconf_bool,CONFIG_PACKAGE_frr-ospfd,ospfd) \
-       $(call autoconf_bool,CONFIG_PACKAGE_frr-ospf6d,ospf6d) \
-       $(call autoconf_bool,CONFIG_PACKAGE_frr-pbrd,pbrd) \
-       $(call autoconf_bool,CONFIG_PACKAGE_frr-pimd,pimd) \
-       $(call autoconf_bool,CONFIG_PACKAGE_frr-staticd,staticd) \
-       $(call autoconf_bool,CONFIG_PACKAGE_frr-ripd,ripd) \
-       $(call autoconf_bool,CONFIG_PACKAGE_frr-ripngd,ripngd) \
-       $(call autoconf_bool,CONFIG_PACKAGE_frr-vtysh,vtysh) \
-       $(call autoconf_bool,CONFIG_PACKAGE_frr-libfrr,zebra) \
+       $(if $(CONFIG_FRR_OPENSSL),--with-crypto=openssl,) \
+       $(foreach m,$(PKG_DAEMON_AVAILABLE), \
+       $(if $(CONFIG_PACKAGE_frr-$(m)),--enable-$(m),--disable-$(m)) ) \
 )
 endef
 
@@ -277,91 +206,6 @@ define Package/frr-zebra/install
        $(INSTALL_BIN) $(PKG_BUILD_DIR)/build/zebra/.libs/zebra $(1)/usr/sbin/
 endef
 
-define Package/frr-babeld/install
-       $(INSTALL_DIR) $(1)/usr/sbin
-       $(INSTALL_BIN) $(PKG_BUILD_DIR)/build/babeld/.libs/babeld $(1)/usr/sbin/
-endef
-
-define Package/frr-bfdd/install
-       $(INSTALL_DIR) $(1)/usr/sbin
-       $(INSTALL_BIN) $(PKG_BUILD_DIR)/build/bfdd/.libs/bfdd $(1)/usr/sbin/
-endef
-
-define Package/frr-bgpd/install
-       $(INSTALL_DIR) $(1)/usr/sbin
-       $(INSTALL_BIN) $(PKG_BUILD_DIR)/build/bgpd/.libs/bgpd $(1)/usr/sbin/
-endef
-
-define Package/frr-eigrpd/install
-       $(INSTALL_DIR) $(1)/usr/sbin
-       $(INSTALL_BIN) $(PKG_BUILD_DIR)/build/eigrpd/.libs/eigrpd $(1)/usr/sbin/
-endef
-
-define Package/frr-fabricd/install
-       $(INSTALL_DIR) $(1)/usr/sbin
-       $(INSTALL_BIN) $(PKG_BUILD_DIR)/build/isisd/.libs/fabricd $(1)/usr/sbin/
-endef
-
-define Package/frr-isisd/install
-       $(INSTALL_DIR) $(1)/usr/sbin
-       $(INSTALL_BIN) $(PKG_BUILD_DIR)/build/isisd/.libs/isisd $(1)/usr/sbin/
-endef
-
-define Package/frr-ldpd/install
-       $(INSTALL_DIR) $(1)/usr/sbin
-       $(INSTALL_BIN) $(PKG_BUILD_DIR)/build/ldpd/.libs/ldpd $(1)/usr/sbin/
-endef
-
-define Package/frr-nhrpd/install
-       $(INSTALL_DIR) $(1)/usr/sbin
-       $(INSTALL_BIN) $(PKG_BUILD_DIR)/build/nhrpd/.libs/nhrpd $(1)/usr/sbin/
-endef
-
-define Package/frr-ospfd/install
-       $(INSTALL_DIR) $(1)/usr/sbin
-       $(INSTALL_BIN) $(PKG_BUILD_DIR)/build/ospfd/.libs/ospfd $(1)/usr/sbin/
-endef
-
-define Package/frr-ospf6d/install
-       $(INSTALL_DIR) $(1)/usr/sbin
-       $(INSTALL_BIN) $(PKG_BUILD_DIR)/build/ospf6d/.libs/ospf6d $(1)/usr/sbin/
-endef
-
-define Package/frr-pbrd/install
-       $(INSTALL_DIR) $(1)/usr/sbin
-       $(INSTALL_BIN) $(PKG_BUILD_DIR)/build/pbrd/.libs/pbrd $(1)/usr/sbin/
-endef
-
-define Package/frr-pimd/install
-       $(INSTALL_DIR) $(1)/usr/sbin
-       $(INSTALL_BIN) $(PKG_BUILD_DIR)/build/pimd/.libs/pimd $(1)/usr/sbin/
-endef
-
-define Package/frr-ripd/install
-       $(INSTALL_DIR) $(1)/usr/sbin
-       $(INSTALL_BIN) $(PKG_BUILD_DIR)/build/ripd/.libs/ripd $(1)/usr/sbin/
-endef
-
-define Package/frr-ripngd/install
-       $(INSTALL_DIR) $(1)/usr/sbin
-       $(INSTALL_BIN) $(PKG_BUILD_DIR)/build/ripngd/.libs/ripngd $(1)/usr/sbin/
-endef
-
-define Package/frr-staticd/install
-       $(INSTALL_DIR) $(1)/usr/sbin
-       $(INSTALL_BIN) $(PKG_BUILD_DIR)/build/staticd/.libs/staticd $(1)/usr/sbin/
-endef
-
-define Package/frr-vrrpd/install
-       $(INSTALL_DIR) $(1)/usr/sbin
-       $(INSTALL_BIN) $(PKG_BUILD_DIR)/build/vrrpd/.libs/vrrpd $(1)/usr/sbin/
-endef
-
-define Package/frr-vtysh/install
-       $(INSTALL_DIR) $(1)/usr/bin
-       $(INSTALL_BIN) $(PKG_BUILD_DIR)/build/vtysh/.libs/vtysh $(1)/usr/bin/
-endef
-
 define Package/frr-libfrr/install
        $(INSTALL_DIR) $(1)/usr/lib
        $(CP) $(PKG_BUILD_DIR)/build/lib/.libs/libfrr.so* $(1)/usr/lib/
@@ -372,22 +216,23 @@ endef
 
 $(eval $(call HostBuild))
 $(eval $(call BuildPackage,frr))
-$(eval $(call BuildPackage,frr-babeld))
-$(eval $(call BuildPackage,frr-bfdd))
-$(eval $(call BuildPackage,frr-bgpd))
-$(eval $(call BuildPackage,frr-eigrpd))
-$(eval $(call BuildPackage,frr-fabricd))
-$(eval $(call BuildPackage,frr-isisd))
-$(eval $(call BuildPackage,frr-ldpd))
 $(eval $(call BuildPackage,frr-libfrr))
-$(eval $(call BuildPackage,frr-nhrpd))
-$(eval $(call BuildPackage,frr-ospfd))
-$(eval $(call BuildPackage,frr-ospf6d))
-$(eval $(call BuildPackage,frr-pbrd))
-$(eval $(call BuildPackage,frr-pimd))
-$(eval $(call BuildPackage,frr-ripd))
-$(eval $(call BuildPackage,frr-ripngd))
-$(eval $(call BuildPackage,frr-staticd))
-$(eval $(call BuildPackage,frr-vtysh))
 $(eval $(call BuildPackage,frr-watchfrr))
 $(eval $(call BuildPackage,frr-zebra))
+$(eval $(call BuildPackage,frr-vtysh))
+$(eval $(call BuildDaemon,babeld,))
+$(eval $(call BuildDaemon,bfdd,))
+$(eval $(call BuildDaemon,bgpd,))
+$(eval $(call BuildDaemon,eigrpd,))
+$(eval $(call BuildDaemon,fabricd,))
+$(eval $(call BuildDaemon,isisd,))
+$(eval $(call BuildDaemon,ldpd,))
+$(eval $(call BuildDaemon,nhrpd,+libcares))
+$(eval $(call BuildDaemon,ospfd,))
+$(eval $(call BuildDaemon,ospf6d,@IPV6))
+$(eval $(call BuildDaemon,pbrd,))
+$(eval $(call BuildDaemon,pimd,))
+$(eval $(call BuildDaemon,ripd,))
+$(eval $(call BuildDaemon,ripngd,@IPV6))
+$(eval $(call BuildDaemon,staticd,))
+$(eval $(call BuildDaemon,vrrpd,))
diff --git a/net/frr/patches/001-vti_interface_fix.patch b/net/frr/patches/001-vti_interface_fix.patch
new file mode 100644 (file)
index 0000000..e7b124b
--- /dev/null
@@ -0,0 +1,26 @@
+--- a/zebra/zebra_nhg.c        2019-10-18 01:59:17.582282539 +0300
++++ b/zebra/zebra_nhg.c        2019-10-18 02:00:17.501997253 +0300
+@@ -253,20 +253,9 @@
+       while (rn) {
+               route_unlock_node(rn);
+-              /* Lookup should halt if we've matched against ourselves ('top',
+-               * if specified) - i.e., we cannot have a nexthop NH1 is
+-               * resolved by a route NH1. The exception is if the route is a
+-               * host route.
+-               */
+-              if (top && rn == top)
+-                      if (((afi == AFI_IP) && (rn->p.prefixlen != 32))
+-                          || ((afi == AFI_IP6) && (rn->p.prefixlen != 128))) {
+-                              if (IS_ZEBRA_DEBUG_RIB_DETAILED)
+-                                      zlog_debug(
+-                                              "\t%s: Matched against ourself and prefix length is not max bit length",
+-                                              __PRETTY_FUNCTION__);
+-                              return 0;
+-                      }
++              /* If lookup self prefix return immediately. */
++              if (rn == top)
++                  return 0;
+               /* Pick up selected route. */
+               /* However, do not resolve over default route unless explicitly
diff --git a/net/frr/patches/002-bgp_clippy_typo.patch b/net/frr/patches/002-bgp_clippy_typo.patch
new file mode 100644 (file)
index 0000000..d581a5e
--- /dev/null
@@ -0,0 +1,11 @@
+--- a/bgpd/bgp_bmp.c   2019-10-19 00:10:05.038017045 +0300
++++ b/bgpd/bgp_bmp.c   2019-10-19 00:10:46.661847536 +0300
+@@ -1762,7 +1762,7 @@
+ #define BMP_STR "BGP Monitoring Protocol\n"
+ #ifndef VTYSH_EXTRACT_PL
+-#include "bgp_bmp_clippy.c"
++#include "bgpd/bgp_bmp_clippy.c"
+ #endif
+ DEFPY_NOSH(bmp_targets_main,
diff --git a/net/frr/patches/003-corss_cares_fix.patch b/net/frr/patches/003-corss_cares_fix.patch
new file mode 100644 (file)
index 0000000..4beb70f
--- /dev/null
@@ -0,0 +1,53 @@
+From 2163a630eb737b9afe3277dccf44070ef55dea12 Mon Sep 17 00:00:00 2001
+From: Lucian Cristian <lucian.cristian@gmail.com>
+Date: Fri, 13 Sep 2019 07:12:34 +0300
+Subject: [PATCH] clippy: CARES fail only if !enable_clippy_only test for CARES
+ otherwise config will fail with conditional "CARES" not defined
+
+Signed-off-by: Lucian Cristian <lucian.cristian@gmail.com>
+---
+ configure.ac | 14 ++++++++------
+ 1 file changed, 8 insertions(+), 6 deletions(-)
+
+diff --git a/configure.ac b/configure.ac
+index 6c1b35b5f2..9f37b3e9a9 100755
+--- a/configure.ac
++++ b/configure.ac
+@@ -1452,6 +1452,12 @@ if test "x$enable_pcreposix" = "xyes"; then
+ fi
+ AC_SUBST([HAVE_LIBPCREPOSIX])
++dnl ##########################################################################
++dnl test "${enable_clippy_only}" != "yes"
++fi
++dnl END OF LARGE if block
++dnl ##########################################################################
++
+ dnl ------------------
+ dnl check C-Ares library
+ dnl ------------------
+@@ -1462,12 +1468,6 @@ PKG_CHECK_MODULES([CARES], [libcares], [
+ ])
+ AM_CONDITIONAL([CARES], [$c_ares_found])
+-dnl ##########################################################################
+-dnl test "${enable_clippy_only}" != "yes"
+-fi
+-dnl END OF LARGE if block
+-dnl ##########################################################################
+-
+ dnl ----------------------------------------------------------------------------
+ dnl figure out if domainname is available in the utsname struct (GNU extension).
+@@ -1535,9 +1535,11 @@ case "$host_os" in
+       no)
+         ;;
+       yes)
++      if test "${enable_clippy_only}" != "yes"; then
+         if test "$c_ares_found" != "true" ; then
+           AC_MSG_ERROR([nhrpd requires libcares.  Please install c-ares and its -dev headers.])
+         fi
++      fi
+         NHRPD="nhrpd"
+         ;;
+       *)
diff --git a/net/frr/patches/004-cross_libcap_fix.patch b/net/frr/patches/004-cross_libcap_fix.patch
new file mode 100644 (file)
index 0000000..58e6bc8
--- /dev/null
@@ -0,0 +1,27 @@
+From 2cd3abe419dab2ee32227c0870f96f805d870fe6 Mon Sep 17 00:00:00 2001
+From: Lucian Cristian <lucian.cristian@gmail.com>
+Date: Fri, 13 Sep 2019 07:16:18 +0300
+Subject: [PATCH] clippy: fail libcap test only when !enable_clippy_only when
+ building native clippy we don't need libcap
+
+Signed-off-by: Lucian Cristian <lucian.cristian@gmail.com>
+---
+ configure.ac | 2 ++
+ 1 file changed, 2 insertions(+)
+
+diff --git a/configure.ac b/configure.ac
+index 9f37b3e9a9..be3a9c763d 100755
+--- a/configure.ac
++++ b/configure.ac
+@@ -2043,9 +2043,11 @@ if test "${enable_capabilities}" != "no"; then
+   case "$host_os" in
+   linux*)
++    if test "${enable_clippy_only}" != "yes"; then
+     if test "$frr_ac_lcaps" != "yes"; then
+       AC_MSG_ERROR([libcap and/or its headers were not found.  Running FRR without libcap support built in causes a huge performance penalty.])
+     fi
++    fi
+     ;;
+   esac
+ else
diff --git a/net/frr/patches/005-fix_OSPF_BFD.patch b/net/frr/patches/005-fix_OSPF_BFD.patch
new file mode 100644 (file)
index 0000000..fb19bec
--- /dev/null
@@ -0,0 +1,71 @@
+From eb3e472904e30f35825f08319608217082d4af21 Mon Sep 17 00:00:00 2001
+From: Radhika Mahankali <radhika@cumulusnetworks.com>
+Date: Mon, 9 Apr 2018 15:30:32 -0700
+Subject: [PATCH] ospf: BFD down not tearing down OSPF adjacency for
+ point-to-point network
+MIME-Version: 1.0
+Content-Type: text/plain; charset=UTF-8
+Content-Transfer-Encoding: 8bit
+
+Root Cause:
+Lookup for the point-to-point neighbor was failing because the neighbor
+lookup was based on neighbor interface IP address. But, for point-to-point
+neighbor the key is router-id for lookup. Lookup failure was causing the
+BFD updates from PTM to get dropped.
+
+Fix:
+Added walk of the neighbor list if the network type is point-to-point to
+find the appropriate neighbor. The match is based on source IP address of
+the neighbor since that’s the address registered with BFD for monitoring.
+
+Ticket: CM-20411
+Signed-off-by: Radhika Mahankali <radhika@cumulusnetworks.com>
+---
+ ospfd/ospf_bfd.c | 26 ++++++++++++++++++++++++--
+ 1 file changed, 24 insertions(+), 2 deletions(-)
+
+diff --git a/ospfd/ospf_bfd.c b/ospfd/ospf_bfd.c
+index a17975270a..05ec4991e5 100644
+--- a/ospfd/ospf_bfd.c
++++ b/ospfd/ospf_bfd.c
+@@ -202,8 +202,9 @@ static int ospf_bfd_interface_dest_update(ZAPI_CALLBACK_ARGS)
+       struct interface *ifp;
+       struct ospf_interface *oi;
+       struct ospf_if_params *params;
+-      struct ospf_neighbor *nbr;
++      struct ospf_neighbor *nbr = NULL;
+       struct route_node *node;
++      struct route_node *n_node;
+       struct prefix p;
+       int status;
+       int old_status;
+@@ -231,7 +232,28 @@ static int ospf_bfd_interface_dest_update(ZAPI_CALLBACK_ARGS)
+               if ((oi = node->info) == NULL)
+                       continue;
+-              nbr = ospf_nbr_lookup_by_addr(oi->nbrs, &p.u.prefix4);
++              /* walk the neighbor list for point-to-point network */
++              if (oi->type == OSPF_IFTYPE_POINTOPOINT) {
++                      for (n_node = route_top(oi->nbrs); n_node;
++                              n_node = route_next(n_node)) {
++                              nbr = n_node->info;
++                              if (nbr) {
++                                      /* skip myself */
++                                      if (nbr == oi->nbr_self) {
++                                              nbr = NULL;
++                                              continue;
++                                      }
++
++                                      /* Found the matching neighbor */
++                                      if (nbr->src.s_addr ==
++                                              p.u.prefix4.s_addr)
++                                              break;
++                              }
++                      }
++              } else {
++                      nbr = ospf_nbr_lookup_by_addr(oi->nbrs, &p.u.prefix4);
++              }
++
+               if (!nbr || !nbr->bfd_info)
+                       continue;
index 86dca46a027a7f3f549a2884f1afa5232cea2a9c..bac2c594399b03e4f8db8d2f0341e71a6941d1ee 100644 (file)
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=keepalived
 PKG_VERSION:=2.0.19
-PKG_RELEASE:=1
+PKG_RELEASE:=3
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=https://www.keepalived.org/software
@@ -86,7 +86,9 @@ endef
 
 CONFIGURE_ARGS+= \
        --with-init=SYSV \
-       --disable-nftables
+       --disable-nftables \
+       --disable-track-process \
+       --with-run-dir="/var/run"
 
 ifeq ($(CONFIG_KEEPALIVED_VRRP),)
 CONFIGURE_ARGS += \
index 8ac08713d144dbc8f9c93357566c0ade9c122071..20cbd50a794849dbc9963f0f371998c26e570d6c 100644 (file)
@@ -165,11 +165,15 @@ Check if things are in place
        netstat -lntp | grep -E '8053|1100'
        ps ww | grep ss-
 
-Edit `/etc/config/dhcp`, add a line to the first dnsmasq section like the following to let it use local tunnel endpoint for upstream dns query
+Edit `/etc/config/dhcp`, making sure options are present in the first dnsmasq section like the following to let it use local tunnel endpoint for upstream dns query.
+Option `noresolv` instructs dnsmasq to not use other dns servers like advertised by local isp.
+Option `localuse` intends to make sure the device you are configuring also uses this dnsmasq instance as the resolver, not the ones from other sources.
 
        config dnsmasq
                ...
                list server '127.0.0.1#8053'
+               option noresolv 1
+               option localuse 1
 
 Restart dnsmasq
 
index 2bd05c9d122890cd9a0131b8270921440c090b1a..3846bbc00c0733f782d402ffbcfbb021a7092a80 100644 (file)
@@ -6,12 +6,12 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=btrfs-progs
-PKG_VERSION:=5.3
+PKG_VERSION:=5.3.1
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-v$(PKG_VERSION).tar.xz
 PKG_SOURCE_URL:=@KERNEL/linux/kernel/people/kdave/btrfs-progs
-PKG_HASH:=1763ec7d102632663ac497739bfbab332bebb9fac70bd8718c131f6156583b8e
+PKG_HASH:=bfa31ae60e54a068fd24e075a90b72f89b8e9006659273fbcecc2e1c790cda38
 PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-v$(PKG_VERSION)
 
 PKG_MAINTAINER:=Karel Kočí <karel.koci@nic.cz>
index fc3695c78bc3b6dfc2b20e9bbd8acacdeebc0985..94e591996ca7493437b7e86a5998318fb06f0391 100644 (file)
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=collectd
 PKG_VERSION:=5.9.2
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
 PKG_SOURCE_URL:=https://collectd.org/files/ \
diff --git a/utils/collectd/patches/320-reaction-to-ntp-time-change-at-boot.patch b/utils/collectd/patches/320-reaction-to-ntp-time-change-at-boot.patch
new file mode 100644 (file)
index 0000000..6440a13
--- /dev/null
@@ -0,0 +1,61 @@
+Adjust the reaction to a polling interval timestamp that references
+to a past time.
+
+Past timestamps can happen when ntpd adjusts router's time after network
+connectivity is obtained after boot. Collectd shows warnings for each plugin
+as it tries to enter new values with the same timestamp as the previous one.
+
+This patch adjusts the next polling time to be now+2 seconds for the main
+loop and for the plugin-specific read loops. That avoids the warnings, but
+does not overreact in case there are shorter polling intervals or the time
+gets adjusted for other reasons.
+
+Additionally some debug statements are added, but they are visible only
+when --enable-debug configure option is used in Makefile.
+
+
+--- a/src/daemon/collectd.c
++++ b/src/daemon/collectd.c
+@@ -274,20 +274,23 @@ static int do_loop(void) {
+     update_kstat();
+ #endif
++    DEBUG("do_loop before plugin_read_all: now = %.3f", CDTIME_T_TO_DOUBLE(cdtime()));
+     /* Issue all plugins */
+     plugin_read_all();
+     cdtime_t now = cdtime();
++    DEBUG("do_loop after plugin_read_all: now = %.3f, wait_until= %.3f", CDTIME_T_TO_DOUBLE(now), CDTIME_T_TO_DOUBLE(wait_until));
+     if (now >= wait_until) {
+-      WARNING("Not sleeping because the next interval is "
++      WARNING("Sleeping only 2s because the next interval is "
+               "%.3f seconds in the past!",
+               CDTIME_T_TO_DOUBLE(now - wait_until));
+-      wait_until = now + interval;
+-      continue;
++      wait_until = now + DOUBLE_TO_CDTIME_T(2);
++      DEBUG("do_loop: wait_until adjusted to now+2 = %.3f", CDTIME_T_TO_DOUBLE(wait_until));
+     }
+     struct timespec ts_wait = CDTIME_T_TO_TIMESPEC(wait_until - now);
+     wait_until = wait_until + interval;
++    DEBUG("do_loop ends: wait_until set to %.3f", CDTIME_T_TO_DOUBLE(wait_until));
+     while ((loop == 0) && (nanosleep(&ts_wait, &ts_wait) != 0)) {
+       if (errno != EINTR) {
+--- a/src/daemon/plugin.c
++++ a/src/daemon/plugin.c
+@@ -578,10 +578,11 @@
+     /* Check, if `rf_next_read' is in the past. */
+     if (rf->rf_next_read < now) {
+-      /* `rf_next_read' is in the past. Insert `now'
++      /* `rf_next_read' is in the past. Insert `now'+2s
+        * so this value doesn't trail off into the
+        * past too much. */
+-      rf->rf_next_read = now;
++      rf->rf_next_read = now + DOUBLE_TO_CDTIME_T(2);
++      DEBUG("plugin_read_thread: Next read is in the past. Adjusted to now+2s");
+     }
+     DEBUG("plugin_read_thread: Next read of the `%s' plugin at %.3f.",
index 956ae304f67b8efd08a40fa2917a15894e3ca774..b8cc09b8e47bf2b2ab905041aee592eff885c164 100644 (file)
@@ -2,7 +2,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=containerd
 PKG_VERSION:=1.2.10
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 PKG_LICENSE:=Apache-2.0
 PKG_LICENSE_FILES:=LICENSE
 
@@ -39,7 +39,7 @@ define Package/containerd
   CATEGORY:=Utilities
   TITLE:=containerd container runtime
   URL:=https://containerd.io/
-  DEPENDS:=$(GO_ARCH_DEPENDS) @TARGET_x86_64 +btrfs-progs +runc +CONTAINERD_SECCOMP:libseccomp
+  DEPENDS:=$(GO_ARCH_DEPENDS) @(aarch64||arm||x86_64) +btrfs-progs +runc +CONTAINERD_SECCOMP:libseccomp
   MENU:=1
 endef
 
index 6fbb4434a6c6fb396547e1cf543befd1f05a7ef9..bd90b22061cc6016881248b55896b9a12bd0d3e3 100644 (file)
@@ -2,7 +2,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=docker-ce
 PKG_VERSION:=19.03.4
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 PKG_LICENSE:=Apache-2.0
 PKG_LICENSE_FILES:=components/cli/LICENSE components/engine/LICENSE
 
@@ -44,7 +44,7 @@ define Package/docker-ce
   CATEGORY:=Utilities
   TITLE:=Docker Community Edition
   URL:=https://www.docker.com/
-  DEPENDS:=$(GO_ARCH_DEPENDS) @TARGET_x86_64 +btrfs-progs +ca-certificates +cgroupfs-mount +containerd +libdevmapper +libnetwork +tini \
+  DEPENDS:=$(GO_ARCH_DEPENDS) @(aarch64||arm||x86_64) +btrfs-progs +ca-certificates +cgroupfs-mount +containerd +libdevmapper +libnetwork +tini \
            +DOCKER_SECCOMP:libseccomp +iptables-mod-extra +kmod-br-netfilter +kmod-ikconfig +kmod-nf-conntrack-netlink +kmod-nf-ipvs +kmod-veth
   USERID:=docker:docker
   MENU:=1
diff --git a/utils/docker-ce/patches/002-imporve-hardcoded-CC-on-cross-compile.patch b/utils/docker-ce/patches/002-imporve-hardcoded-CC-on-cross-compile.patch
new file mode 100644 (file)
index 0000000..b134cdf
--- /dev/null
@@ -0,0 +1,58 @@
+From 2fdfb4404ab811cb00227a3de111437b829e55cf Mon Sep 17 00:00:00 2001
+From: Hongxu Jia <hongxu.jia@windriver.com>
+Date: Wed, 17 Jul 2019 17:34:04 +0800
+Subject: [PATCH] imporve hardcoded CC on cross compile
+
+Since commit applied in moby [61a3285 Support cross-compile for arm]
+it hardcoded var-CC to support cross-compile for arm
+
+Correct it with "${parameter:-word}" format, it is helpful for user
+define toolchains
+
+(Use Default Values.  If parameter is unset or null, the expansion of
+word is substituted.  Otherwise, the value of parameter is substituted.)
+
+Signed-off-by: Hongxu Jia <hongxu.jia@windriver.com>
+Upstream-commit: 3c701e4db1b8646c2324ae524b4e7ca1b1147a07
+Component: engine
+---
+ components/engine/hack/make/.binary | 10 +++++-----
+ 1 file changed, 5 insertions(+), 5 deletions(-)
+
+diff --git a/components/engine/hack/make/.binary b/components/engine/hack/make/.binary
+index 53de6749e5..66f4ca05f3 100644
+--- a/components/engine/hack/make/.binary
++++ b/components/engine/hack/make/.binary
+@@ -44,27 +44,27 @@ if [ "$(go env GOOS)/$(go env GOARCH)" != "$(go env GOHOSTOS)/$(go env GOHOSTARC
+       # must be cross-compiling!
+       case "$(go env GOOS)/$(go env GOARCH)" in
+               windows/amd64)
+-                      export CC=x86_64-w64-mingw32-gcc
++                      export CC="${CC:-x86_64-w64-mingw32-gcc}"
+                       export CGO_ENABLED=1
+                       ;;
+               linux/arm)
+                       case "${GOARM}" in
+                       5|"")
+-                              export CC=arm-linux-gnueabi-gcc
++                              export CC="${CC:-arm-linux-gnueabi-gcc}"
+                               export CGO_ENABLED=1
+                               ;;
+                       7)
+-                              export CC=arm-linux-gnueabihf-gcc
++                              export CC="${CC:-arm-linux-gnueabihf-gcc}"
+                               export CGO_ENABLED=1
+                               ;;
+                       esac
+                       ;;
+               linux/arm64)
+-                      export CC=aarch64-linux-gnu-gcc
++                      export CC="${CC:-aarch64-linux-gnu-gcc}"
+                       export CGO_ENABLED=1
+                       ;;
+               linux/amd64)
+-                      export CC=x86_64-linux-gnu-gcc
++                      export CC="${CC:-x86_64-linux-gnu-gcc}"
+                       export CGO_ENABLED=1
+                       ;;
+       esac
index bc938ccdc32049172b74f62583aa3ca6ac27f73f..ba583f25c6d4d64eb1119891a03baf202023389c 100644 (file)
@@ -1,7 +1,7 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=libnetwork
-PKG_RELEASE:=2
+PKG_RELEASE:=3
 PKG_LICENSE:=Apache-2.0
 PKG_LICENSE_FILES:=LICENSE
 
@@ -29,7 +29,7 @@ define Package/libnetwork
   CATEGORY:=Utilities
   TITLE:=networking for containers
   URL:=https://github.com/docker/libnetwork
-  DEPENDS:=$(GO_ARCH_DEPENDS) @TARGET_x86_64
+  DEPENDS:=$(GO_ARCH_DEPENDS) @(aarch64||arm||x86_64)
 endef
 
 define Package/libnetwork/description
index afccba3e0f25f2a7e59d61acd159a6183f4f9343..43fb533558bda36772f6aba02a2435f4443f2cd1 100644 (file)
@@ -2,14 +2,13 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=runc
 PKG_VERSION:=1.0.0-rc8+91-3e425f80
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 PKG_LICENSE:=Apache-2.0
 PKG_LICENSE_FILES:=LICENSE
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=https://github.com/opencontainers/runc
-PKG_MIRROR_HASH:=361658b3c61b9c727091aa10ba693f234a64aae592bb683005244a22e2778cfc
-PKG_HASH:=efe4ff9bbe49b19074346d65c914d809c0a3e90d062ea9619fe240f931f0b700
+PKG_MIRROR_HASH:=11dce499b6fbdb159d2ef64b0e9b719ccdf6c59ca1cc7ac0026b1d58547fc187
 PKG_SOURCE_VERSION:=3e425f80a8c931f88e6d94a8c831b9d5aa481657
 PKG_SOURCE_PROTO:=git
 PKG_SOURCE_DATE:=2019-10-15
@@ -42,7 +41,7 @@ define Package/runc
   CATEGORY:=Utilities
   TITLE:=runc container runtime
   URL:=https://www.opencontainers.org/
-  DEPENDS:=$(GO_ARCH_DEPENDS) @TARGET_x86_64 +RUNC_SECCOMP:libseccomp
+  DEPENDS:=$(GO_ARCH_DEPENDS) @(aarch64||arm||x86_64) +RUNC_SECCOMP:libseccomp
   MENU:=1
 endef