adblock: update 3.8.9 10482/head
authorDirk Brenken <dev@brenken.org>
Wed, 6 Nov 2019 19:29:48 +0000 (20:29 +0100)
committerDirk Brenken <dev@brenken.org>
Wed, 6 Nov 2019 19:29:48 +0000 (20:29 +0100)
* more startup tweaks
* re-use f_log function in helper scripts
* small fixes / polish up for forthcoming 19.07 release

Signed-off-by: Dirk Brenken <dev@brenken.org>
net/adblock/Makefile
net/adblock/files/adblock.init
net/adblock/files/adblock.mail
net/adblock/files/adblock.service
net/adblock/files/adblock.sh

index 24c5777d1005ae00e29407927603ee153e207b8b..77be3f50e40a0a15f4ec083ffbacf46c9c443ddf 100644 (file)
@@ -6,7 +6,7 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=adblock
-PKG_VERSION:=3.8.8
+PKG_VERSION:=3.8.9
 PKG_RELEASE:=1
 PKG_LICENSE:=GPL-3.0-or-later
 PKG_MAINTAINER:=Dirk Brenken <dev@brenken.org>
index 3397f83fce2801a3b1766296b31262d6c088654b..7d0f29d1a8d76094e2131b3cf9520d18bf4c2994 100755 (executable)
@@ -15,14 +15,15 @@ adb_init="/etc/init.d/adblock"
 adb_script="/usr/bin/adblock.sh"
 adb_pidfile="/var/run/adblock.pid"
 
-if [ -s "${adb_pidfile}" ] && [ "${action}" != "help" ] && [ "${action}" != "status" ]
+if [ -s "${adb_pidfile}" ] && \
+       [ "${action}" != "help" ] && [ "${action}" != "status" ] && [ "${action}" != "boot" ]
 then
        exit 1
 fi
 
 boot()
 {
-       adb_boot=1
+       [ -s "${adb_pidfile}" ] && > "${adb_pidfile}"
        rc_procd start_service
 }
 
@@ -30,19 +31,17 @@ start_service()
 {
        if [ "$("${adb_init}" enabled; printf "%u" ${?})" -eq 0 ]
        then
-               if [ -n "${adb_boot}" ]
+               if [ "${action}" = "boot" ]
                then
-                       local trigger="$(uci_get adblock global adb_trigger)"
-                       if [ "${trigger}" != "timed" ]
+                       if [ "$(uci_get adblock global adb_trigger)" != "timed" ]
                        then
                                return 0
                        fi
                fi
-               local nice="$(uci_get adblock extra adb_nice "0")"
                procd_open_instance "adblock"
                procd_set_param command "${adb_script}" "${@}"
                procd_set_param pidfile "${adb_pidfile}"
-               procd_set_param nice "${nice}"
+               procd_set_param nice "$(uci_get adblock extra adb_nice "0")"
                procd_set_param stdout 1
                procd_set_param stderr 1
                procd_close_instance
index a0b8c3f0b014416b0dcd3c7ffd84d575ec231384..4db5966bcf8f16644ba5ecdc59995c4a47a61575 100755 (executable)
@@ -25,6 +25,24 @@ adb_logger="$(command -v logger)"
 adb_logread="$(command -v logread)"
 adb_rc=1
 
+f_log()
+{
+       local class="${1}" log_msg="${2}"
+
+       if [ -x "${adb_logger}" ]
+       then
+               "${adb_logger}" -p "${class}" -t "adblock-${adb_ver}[${$}]" "${log_msg}"
+       else
+               printf "%s %s %s\\n" "${class}" "adblock-${adb_ver}[${$}]" "${log_msg}"
+       fi
+}
+
+if [ -z "${adb_mreceiver}" ]
+then
+       f_log "err" "please set the mail receiver with the 'adb_mreceiver' option"
+       exit ${adb_rc}
+fi
+
 if [ "${adb_debug}" -eq 1 ]
 then
        debug="--debug"
@@ -58,20 +76,8 @@ if [ -x "${adb_mail}" ] && [ -n "${adb_mreceiver}" ]
 then
        printf "%b" "${adb_mhead}${adb_mtext}" 2>/dev/null | "${adb_mail}" ${debug} -a "${adb_mprofile}" "${adb_mreceiver}" >/dev/null 2>&1
        adb_rc=${?}
-       class="info"
-       log_msg="mail sent to '${adb_mreceiver}' with rc '${adb_rc}'"
-elif [ -z "${adb_mreceiver}" ]
-then
-       class="err"
-       log_msg="please set the mail receiver with the 'adb_mreceiver' option"
-else
-       class="err"
-       log_msg="msmtp mail daemon not found"
-fi
-if [ -x "${adb_logger}" ]
-then
-       "${adb_logger}" -p "${class}" -t "adblock-${adb_ver}[${$}]" "${log_msg}"
+       f_log "info" "mail sent to '${adb_mreceiver}' with rc '${adb_rc}'"
 else
-       printf "%s %s %s\\n" "${class}" "adblock-${adb_ver}[${$}]" "${log_msg}"
+       f_log "err" "msmtp mail daemon not found"
 fi
 exit ${adb_rc}
index 0a9c9ce27ead55e4b58a0e88820062bffea1f738..02397c2983c9429dc7d359a41bce0cb8aed768a6 100755 (executable)
@@ -18,20 +18,23 @@ adb_ver="${1}"
 adb_ubus="$(command -v ubus)"
 adb_logger="$(command -v logger)"
 
+f_log()
+{
+       local class="${1}" log_msg="${2}"
+
+       if [ -x "${adb_logger}" ]
+       then
+               "${adb_logger}" -p "${class}" -t "adblock-${adb_ver}[${$}]" "${log_msg}"
+       else
+               printf "%s %s %s\\n" "${class}" "adblock-${adb_ver}[${$}]" "${log_msg}"
+       fi
+}
+
 if [ -x "${adb_ubus}" ] && [ -n "${adb_dns}" ]
 then
+       f_log "info" "ubus/adblock service started"
        "${adb_ubus}" -S -M r -m invoke monitor | \
                { grep -qE "\"method\":\"(set|signal)\",\"data\":\{\"name\":\"${adb_dns}\""; [ $? -eq 0 ] && /etc/init.d/adblock start; }
-       class="info"
-       log_msg="ubus/adblock service started"
-else
-       class="err"
-       log_msg="can't start ubus/adblock service"
-fi
-if [ -x "${adb_logger}" ]
-then
-       "${adb_logger}" -p "${class}" -t "adblock-${adb_ver}[${$}]" "${log_msg}"
 else
-       printf "%s %s %s\\n" "${class}" "adblock-${adb_ver}[${$}]" "${log_msg}"
+       f_log "err" "can't start ubus/adblock service"
 fi
-
index 2b724f260e53d5fced453e2c486d232879eb778e..acf88815af8f10cb9a902a881b5e341c8be7b6ec 100755 (executable)
@@ -13,7 +13,7 @@
 #
 LC_ALL=C
 PATH="/usr/sbin:/usr/bin:/sbin:/bin"
-adb_ver="3.8.8"
+adb_ver="3.8.9"
 adb_basever=""
 adb_enabled=0
 adb_debug=0
@@ -283,13 +283,12 @@ f_temp()
        if [ -d "/tmp" ] && [ -z "${adb_tmpdir}" ]
        then
                adb_tmpdir="$(mktemp -p /tmp -d)"
-               adb_tmpload="$(mktemp -p "${adb_tmpdir}" -tu)"
                adb_tmpfile="$(mktemp -p "${adb_tmpdir}" -tu)"
        elif [ ! -d "/tmp" ]
        then
                f_log "err" "the temp directory '/tmp' does not exist/is not mounted yet, please create the directory or raise the 'adb_triggerdelay' to defer the adblock start"
        fi
-       if [ ! -s "${adb_pidfile}" ]
+       if [ ! -f "${adb_pidfile}" ] || [ ! -s "${adb_pidfile}" ]
        then
                printf "%s" "${$}" > "${adb_pidfile}"
        fi
@@ -929,13 +928,6 @@ f_log()
                        f_rmdns
                        f_bgserv "stop"
                        f_jsnup "error"
-                       log_msg="Please also check 'https://github.com/openwrt/packages/blob/master/net/adblock/files/README.md'"
-                       if [ -x "${adb_logger}" ]
-                       then
-                               "${adb_logger}" -p "${class}" -t "adblock-${adb_ver}[${$}]" "${log_msg}"
-                       else
-                               printf "%s %s %s\\n" "${class}" "adblock-${adb_ver}[${$}]" "${log_msg}"
-                       fi
                        exit 1
                fi
        fi
@@ -979,8 +971,8 @@ f_main()
                src_url="$(eval printf "%s" \"\$\{adb_src_${src_name}\}\")"
                src_rset="$(eval printf "%s" \"\$\{adb_src_rset_${src_name}\}\")"
                src_cat="$(eval printf "%s" \"\$\{adb_src_cat_${src_name}\}\")"
-               src_tmpload="${adb_tmpload}.${src_name}"
-               src_tmpfile="${adb_tmpfile}.${src_name}"
+               src_tmpload="${adb_tmpfile}.${src_name}.load"
+               src_tmpfile="${adb_tmpfile}.${src_name}.file"
                src_rc=4
 
                # basic pre-checks