vsftpd: Pass TARGET_CPPFLAGS
authorFlorian Fainelli <f.fainelli@gmail.com>
Sun, 2 Apr 2017 18:36:20 +0000 (11:36 -0700)
committerFlorian Fainelli <f.fainelli@gmail.com>
Sun, 2 Apr 2017 18:36:20 +0000 (11:36 -0700)
Fixes build errors with external toolchains that don't have STAGING_DIR
in their default search path for headers:

mipsel-linux-gnu-gcc -c ssl.c -Os -pipe -mno-branch-likely -mips32r2
-mtune=24kc -fno-caller-saves -Wno-unused-result  -D_FORTIFY_SOURCE=1
-Wl,-z,now -Wl,-z,relro -D_GNU_SOURCE -include fcntl.h -idirafter
dummyinc
ssl.c:28:25: fatal error: openssl/err.h: No such file or directory
 #include <openssl/err.h>
                         ^
compilation terminated.
Makefile:28: recipe for target 'ssl.o' failed
make[3]: *** [ssl.o] Error 1

Signed-off-by: Florian Fainelli <f.fainelli@gmail.com>
net/vsftpd/Makefile

index d85dc70e40067e6eda11d2efa0da1198ec9ea215..fa504d1b4881c577959bb15521fe09fe36d2df56 100644 (file)
@@ -62,7 +62,7 @@ ifeq ($(BUILD_VARIANT),notls)
        $(SED) 's/-lcrypt -lnsl/$(NLSSTRING)/' $(PKG_BUILD_DIR)/Makefile
        $(MAKE) -C $(PKG_BUILD_DIR) \
                CC="$(TARGET_CC)" \
-               CFLAGS="$(TARGET_CFLAGS)" \
+               CFLAGS="$(TARGET_CFLAGS) $(TARGET_CPPFLAGS)" \
                LDFLAGS="$(TARGET_LDFLAGS)" \
                vsftpd
  endef
@@ -75,7 +75,7 @@ ifeq ($(BUILD_VARIANT),tls)
        $(SED) 's/-lcrypt -lnsl/$(NLSSTRING)/' $(PKG_BUILD_DIR)/Makefile
        $(MAKE) -C $(PKG_BUILD_DIR) \
                CC="$(TARGET_CC)" \
-               CFLAGS="$(TARGET_CFLAGS)" \
+               CFLAGS="$(TARGET_CFLAGS) $(TARGET_CPPFLAGS)" \
                LDFLAGS="$(TARGET_LDFLAGS)" \
                vsftpd
  endef