[packages] cups: reenable libusb support, refresh patches (#11768)
authorJo-Philipp Wich <jow@openwrt.org>
Thu, 28 Jun 2012 14:47:02 +0000 (14:47 +0000)
committerJo-Philipp Wich <jow@openwrt.org>
Thu, 28 Jun 2012 14:47:02 +0000 (14:47 +0000)
SVN-Revision: 32519

net/cups/Makefile
net/cups/patches/100-makefile-targets.patch
net/cups/patches/140-uname.patch
net/cups/patches/150-64bit_host_fix.patch
net/cups/patches/160-ppdc.patch

index b35fe79f8e0acf0e77e0f5935717440465b2f5a0..63f2bae4b3168a329ace60f898ac4c7870266357 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2006-2011 OpenWrt.org
+# Copyright (C) 2006-2012 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=cups
 PKG_VERSION:=1.4.4
-PKG_RELEASE:=2
+PKG_RELEASE:=3
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION)-source.tar.bz2
 PKG_SOURCE_URL:= \
@@ -25,7 +25,7 @@ include $(INCLUDE_DIR)/package.mk
 define Package/cups
   SECTION:=net
   CATEGORY:=Network
-  DEPENDS:=+zlib +libpthread +libpng +libjpeg +libstdcpp
+  DEPENDS:=+zlib +libpthread +libpng +libjpeg +libstdcpp +libusb
   TITLE:=Common UNIX Printing System
   URL:=http://www.cups.org/
 endef
@@ -50,7 +50,7 @@ define Build/Configure
                --without-php \
                --enable-shared \
                --enable-image \
-               --disable-libusb \
+               --enable-libusb \
                --disable-dbus \
                --disable-dnssd \
                --disable-launchd \
index 5d80aaace53b4fddcae56873830ae2bd1e215e64..f72532d3c7a6d0278c4e133609ffe4d2c2e1494f 100644 (file)
@@ -1,6 +1,6 @@
 --- a/Makefile
 +++ b/Makefile
-@@ -19,8 +19,8 @@ include Makedefs
+@@ -20,8 +20,8 @@ include Makedefs
  # Directories to make...
  #
  
index dca3fcb47541f5afcade8b9f3dd78433074c80ab..3261de6187587447f231f8f35fb8cf6e98c98240 100644 (file)
@@ -1,6 +1,6 @@
 --- a/configure
 +++ b/configure
-@@ -1926,7 +1926,7 @@ ac_compiler_gnu=$ac_cv_c_compiler_gnu
+@@ -1966,7 +1966,7 @@ ac_compiler_gnu=$ac_cv_c_compiler_gnu
  
  
  
index bd6db199017c04c36f7a9af837ee6f82798b7c52..5cfdba56955033ecaf853d9f1ad5e3327198b3ae 100644 (file)
@@ -1,6 +1,6 @@
 --- a/cups-config.in
 +++ b/cups-config.in
-@@ -53,7 +53,7 @@ else
+@@ -54,7 +54,7 @@ else
        CFLAGS="$CFLAGS -I$includedir"
      fi
  
@@ -33,7 +33,7 @@
                HP-UX*)
 --- a/configure
 +++ b/configure
-@@ -9254,7 +9254,7 @@ if test "$libdir" = "\${exec_prefix}/lib
+@@ -10003,7 +10003,7 @@ if test "$libdir" = "\${exec_prefix}/lib
                        ;;
                Linux*)
                        if test -d /usr/lib64; then
@@ -42,7 +42,7 @@
                        fi
                        ;;
                HP-UX*)
-@@ -9792,9 +9792,6 @@ case "$uname" in
+@@ -10626,9 +10626,6 @@ case "$uname" in
                        LIB32CUPS="32bit/libcups.so.2"
                        LIB32CUPSIMAGE="32bit/libcupsimage.so.2"
                        LIB32DIR="$exec_prefix/lib"
@@ -52,7 +52,7 @@
                        UNINSTALL32="uninstall32bit"
                fi
  
-@@ -9804,9 +9801,6 @@ case "$uname" in
+@@ -10638,9 +10635,6 @@ case "$uname" in
                        LIB64CUPS="64bit/libcups.so.2"
                        LIB64CUPSIMAGE="64bit/libcupsimage.so.2"
                        LIB64DIR="$exec_prefix/lib"
index 54efbe9c146da8384940bdd9b01823fa871827fb..e4da1f48e2b006ae3faa8a1cb570391b11d383d3 100644 (file)
@@ -1,6 +1,6 @@
---- cups-1.4.2.orig/ppdc/Makefile      2010-01-28 18:06:41.000000000 +0100
-+++ cups-1.4.2/ppdc/Makefile   2010-01-28 20:25:09.000000000 +0100
-@@ -239,12 +239,7 @@
+--- a/ppdc/Makefile
++++ b/ppdc/Makefile
+@@ -239,12 +239,7 @@ framedhelp:
  
  genstrings:           genstrings.o libcupsppdc.a ../cups/libcups.a \
                        sample.drv ../data/media.defs