python3: Remove --without-pymalloc
authorJeffery To <jeffery.to@gmail.com>
Mon, 8 May 2023 15:42:37 +0000 (23:42 +0800)
committerRosen Penev <rosenp@gmail.com>
Wed, 24 May 2023 03:04:33 +0000 (06:04 +0300)
--without-pymalloc was added in 7bf1ae65a89e380ce20ef5ab13b1a7276d6f7047
because leaving it enabled added an "m" flag/suffix to file names.

This flag/suffix was removed in Python 3.8[1], so disabling pymalloc is
no longer necessary.

[1]: https://docs.python.org/3.8/whatsnew/3.8.html#build-and-c-api-changes

Signed-off-by: Jeffery To <jeffery.to@gmail.com>
lang/python/python3/Makefile

index 1fd8f43d1f54bc14047255552239856679a3d916..328a5c920b29e8630e72953b46156aa5ee7ab7f4 100644 (file)
@@ -11,7 +11,7 @@ include $(TOPDIR)/rules.mk
 include ../python3-version.mk
 
 PKG_NAME:=python3
-PKG_RELEASE:=4
+PKG_RELEASE:=5
 PKG_VERSION:=$(PYTHON3_VERSION).$(PYTHON3_VERSION_MICRO)
 
 PKG_SOURCE:=Python-$(PKG_VERSION).tar.xz
@@ -160,7 +160,6 @@ CONFIGURE_ARGS+= \
        --with-system-ffi \
        --without-cxx-main \
        --without-ensurepip \
-       --without-pymalloc \
        --disable-test-modules \
        $(if $(CONFIG_IPV6),--enable-ipv6) \
        $(if $(findstring mips,$(CONFIG_ARCH)),,--with-lto) \
@@ -335,7 +334,6 @@ HOST_CONFIGURE_ARGS+= \
        --with-system-expat=$(STAGING_DIR_HOST) \
        --with-ssl-default-suites=openssl \
        --without-cxx-main \
-       --without-pymalloc \
        --disable-test-modules \
        CONFIG_SITE=