ddns-scripts: get public_suffix_list.dat without using secure connection 3698/head
authorChristian Schoenebeck <christian.schoenebeck@gmail.com>
Sat, 24 Dec 2016 14:52:19 +0000 (15:52 +0100)
committerChristian Schoenebeck <christian.schoenebeck@gmail.com>
Sat, 24 Dec 2016 14:52:19 +0000 (15:52 +0100)
Get public_suffix_list.dat without using secure connection. #3678

File generated during build, because it's the only option to have an
actual version packaged.
Long term Cloudflare_v1 package will be changed to no longer need
public_suffix_list.dat

Signed-off-by: Christian Schoenebeck <christian.schoenebeck@gmail.com>
net/ddns-scripts/Makefile
net/ddns-scripts/tools/public_suffix_list.sh

index 2056dd776ebbffc2c69bcd8505b3b0bca274f4f4..8d5590a43df5f9cceae20a9edf5c1e51eedf89f9 100755 (executable)
@@ -12,7 +12,7 @@ PKG_NAME:=ddns-scripts
 PKG_VERSION:=2.7.6
 # Release == build
 # increase on changes of services files or tld_names.dat
-PKG_RELEASE:=7
+PKG_RELEASE:=8
 
 PKG_LICENSE:=GPL-2.0
 PKG_MAINTAINER:=Christian Schoenebeck <christian.schoenebeck@gmail.com>
index 486847107ce4edb75d632cd79a12b3fe15130c38..af0acb22794d370ed923656306e23d850215bab0 100755 (executable)
@@ -1,6 +1,6 @@
 #!/bin/sh
 
-URL="https://publicsuffix.org/list/public_suffix_list.dat"
+URL="http://publicsuffix.org/list/public_suffix_list.dat"
 TMPFILE=$(dirname $0)/public_suffix_list.tmp
 DATFILE=$(dirname $0)/public_suffix_list.dat