make the iptables package robust to kernel config changes
authorFelix Fietkau <nbd@openwrt.org>
Thu, 1 Mar 2007 11:59:42 +0000 (11:59 +0000)
committerFelix Fietkau <nbd@openwrt.org>
Thu, 1 Mar 2007 11:59:42 +0000 (11:59 +0000)
SVN-Revision: 6447

package/iptables/Makefile

index 1b6bfc0b1f98eae46e6ba5f9eaea33b2ad3d98e8..f29aad3f909bccbd9bb255b4c24d54f168a7e0e4 100644 (file)
@@ -163,7 +163,11 @@ define Package/ip6tables
   TITLE:=IPv6 firewall administration tool
 endef
 
+$(PKG_BUILD_DIR)/.configured: $(LINUX_DIR)/.config
+
 define Build/Configure
+       $(MAKE) -C $(PKG_BUILD_DIR) \
+               clean
 endef
 
 define Build/Compile