uboot-fritz4040: Add host flags for host compiler
authorHauke Mehrtens <hauke@hauke-m.de>
Fri, 17 May 2019 19:32:50 +0000 (21:32 +0200)
committerHauke Mehrtens <hauke@hauke-m.de>
Fri, 17 May 2019 20:03:25 +0000 (22:03 +0200)
This adds the host staging directory to the include path to make it use
the zlib.h files from the staging include directory and also link
against the zlib version from the staging directory.

This fixes a compile problem when the zlib header were not installed on
the build host.

Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de>
package/boot/uboot-fritz4040/Makefile

index 659bd0d084203861dd69ab18ead1dc4bcc48a4e0..4f920485c4d7b22447ec9aa5b886401b80c4169b 100644 (file)
@@ -35,8 +35,8 @@ export DTC
 
 define Build/Configure
        $(Build/Configure/U-Boot)
-       $(HOSTCC) -o $(PKG_BUILD_DIR)/fritz/lzma2eva $(PKG_BUILD_DIR)/fritz/src/lzma2eva.c -lz
-       $(HOSTCC) -o $(PKG_BUILD_DIR)/fritz/tichksum $(PKG_BUILD_DIR)/fritz/src/tichksum.c
+       $(HOSTCC) $(HOST_CFLAGS) $(HOST_LDFLAGS) -o $(PKG_BUILD_DIR)/fritz/lzma2eva $(PKG_BUILD_DIR)/fritz/src/lzma2eva.c -lz
+       $(HOSTCC) $(HOST_CFLAGS) $(HOST_LDFLAGS) -o $(PKG_BUILD_DIR)/fritz/tichksum $(PKG_BUILD_DIR)/fritz/src/tichksum.c
        ln -sf $(STAGING_DIR_HOST)/bin/lzma $(PKG_BUILD_DIR)/fritz
        ln -sf compiler-gcc5.h $(PKG_BUILD_DIR)/include/linux/compiler-gcc7.h
 endef