ffmpeg: fix compilation with glibc 12224/head
authorRosen Penev <rosenp@gmail.com>
Tue, 19 May 2020 21:24:00 +0000 (14:24 -0700)
committerRosen Penev <rosenp@gmail.com>
Tue, 19 May 2020 21:24:00 +0000 (14:24 -0700)
No idea why.

Patch submitted upstream:
https://patchwork.ffmpeg.org/project/ffmpeg/patch/20200503090023.29418-1-rosenp@gmail.com/

Signed-off-by: Rosen Penev <rosenp@gmail.com>
multimedia/ffmpeg/Makefile
multimedia/ffmpeg/patches/050-glibc.patch [new file with mode: 0644]

index 6e1b3770f73b7757eccf94b85369b30efbd96cb5..2933151d4a50911f57e48f9ba9171ac9a067aa5a 100644 (file)
@@ -10,7 +10,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=ffmpeg
 PKG_VERSION:=4.2.2
-PKG_RELEASE:=3
+PKG_RELEASE:=4
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
 PKG_SOURCE_URL:=https://ffmpeg.org/releases/
diff --git a/multimedia/ffmpeg/patches/050-glibc.patch b/multimedia/ffmpeg/patches/050-glibc.patch
new file mode 100644 (file)
index 0000000..870a87a
--- /dev/null
@@ -0,0 +1,10 @@
+--- a/libavcodec/wmv2dsp.c
++++ b/libavcodec/wmv2dsp.c
+@@ -263,6 +263,6 @@ av_cold void ff_wmv2dsp_init(WMV2DSPContext *c)
+     c->put_mspel_pixels_tab[6] = put_mspel8_mc22_c;
+     c->put_mspel_pixels_tab[7] = put_mspel8_mc32_c;
+
+-    if (ARCH_MIPS)
++    if (ARCH_MIPS64)
+         ff_wmv2dsp_init_mips(c);
+ }