Merge pull request #18312 from lowjoel/strongswan-wolfssl
authorPhilip Prindeville <philipp@redfish-solutions.com>
Fri, 6 May 2022 20:31:10 +0000 (14:31 -0600)
committerGitHub <noreply@github.com>
Fri, 6 May 2022 20:31:10 +0000 (14:31 -0600)
strongswan: add wolfssl plugin

net/strongswan/Makefile

index 035421485bab6e085055679967f148ab00b80c92..9e5fc0f5e1be5578d6ea37b8e3d2656736dd455f 100644 (file)
@@ -95,6 +95,7 @@ PKG_MOD_AVAILABLE:= \
        updown \
        vici \
        whitelist \
+       wolfssl \
        x509 \
        xauth-eap \
        xauth-generic \
@@ -223,6 +224,7 @@ $(call Package/strongswan/Default)
        +strongswan-mod-updown \
        +strongswan-mod-vici \
        +strongswan-mod-whitelist \
+       +strongswan-mod-wolfssl \
        +strongswan-mod-x509 \
        +strongswan-mod-xauth-eap \
        +strongswan-mod-xauth-generic \
@@ -735,6 +737,7 @@ $(eval $(call BuildPlugin,unity,Cisco Unity extension,))
 $(eval $(call BuildPlugin,updown,updown firewall,+iptables +IPV6:ip6tables +iptables-mod-ipsec +kmod-ipt-ipsec))
 $(eval $(call BuildPlugin,vici,Versatile IKE Configuration Interface,))
 $(eval $(call BuildPlugin,whitelist,peer identity whitelisting,))
+$(eval $(call BuildPlugin,wolfssl,WolfSSL crypto,+PACKAGE_strongswan-mod-wolfssl:libwolfssl))
 $(eval $(call BuildPlugin,x509,x509 certificate,))
 $(eval $(call BuildPlugin,xauth-eap,EAP XAuth backend,))
 $(eval $(call BuildPlugin,xauth-generic,generic XAuth backend,))