gpsd: fix compilation with x86 glibc 15777/head
authorNick Hainke <vincent@systemli.org>
Fri, 4 Jun 2021 13:30:02 +0000 (15:30 +0200)
committerNick Hainke <vincent@systemli.org>
Fri, 4 Jun 2021 16:21:43 +0000 (18:21 +0200)
The sysroot has to point to the toolchain directory. The directory
includes libraries like libm. However, the STAGING_DIR needs to be
added to the CFLAGS.

Fixes #15773

[As suggested by jow]

Signed-off-by: Nick Hainke <vincent@systemli.org>
utils/gpsd/Makefile

index c51dfcf4114eeb4eefda12f43132eacadbddc7cd..ae24b8e901bf172c22abc3add20e6761cb0d6c73 100644 (file)
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=gpsd
 PKG_VERSION:=3.21
-PKG_RELEASE:=3
+PKG_RELEASE:=4
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
 PKG_SOURCE_URL:=@SAVANNAH/$(PKG_NAME)
@@ -95,6 +95,7 @@ define Package/libgps/description
 endef
 
 SCONS_VARS += \
+       CFLAGS="$(TARGET_CFLAGS) $(EXTRA_CFLAGS) -L$(STAGING_DIR)/usr/lib" \
        LINKFLAGS="$(TARGET_LDFLAGS)"
 
 SCONS_OPTIONS += \
@@ -116,7 +117,7 @@ SCONS_OPTIONS += \
        implicit_link=no \
        chrpath=no \
        manbuild=no \
-       sysroot="$(STAGING_DIR)" \
+       sysroot="$(TOOLCHAIN_DIR)" \
        target="$(TARGET_CROSS:-=)"
 
 define Build/InstallDev