kernel: bump 4.14 to 4.14.96
authorKoen Vandeputte <koen.vandeputte@ncentric.com>
Mon, 28 Jan 2019 10:03:25 +0000 (11:03 +0100)
committerKoen Vandeputte <koen.vandeputte@ncentric.com>
Mon, 28 Jan 2019 17:17:32 +0000 (18:17 +0100)
Refreshed all patches.

Remove upstreamed patches:
- 142-jffs2-Fix-use-of-uninitialized-delayed_work-lockdep-.patch

Compile-tested on: ar71xx, cns3xxx, imx6, x86_64
Runtime-tested on: ar71xx, cns3xxx, imx6

Signed-off-by: Koen Vandeputte <koen.vandeputte@ncentric.com>
20 files changed:
include/kernel-version.mk
target/linux/ar71xx/patches-4.14/500-MIPS-fw-myloader.patch
target/linux/generic/backport-4.14/025-tcp-allow-drivers-to-tweak-TSQ-logic.patch
target/linux/generic/backport-4.14/336-v4.15-netfilter-exit_net-cleanup-check-added.patch
target/linux/generic/backport-4.14/420-enable-CONFIG_MMC_SDHCI_IO_ACCESSORS.patch
target/linux/generic/hack-4.14/301-mips_image_cmdline_hack.patch
target/linux/generic/hack-4.14/901-debloat_sock_diag.patch
target/linux/generic/hack-4.14/902-debloat_proc.patch
target/linux/generic/pending-4.14/142-jffs2-Fix-use-of-uninitialized-delayed_work-lockdep-.patch [deleted file]
target/linux/generic/pending-4.14/300-mips_expose_boot_raw.patch
target/linux/generic/pending-4.14/304-mips_disable_fpu.patch
target/linux/generic/pending-4.14/341-MIPS-mm-remove-no-op-dma_map_ops-where-possible.patch
target/linux/lantiq/patches-4.14/0152-lantiq-VPE.patch
target/linux/mpc85xx/patches-4.14/106-powerpc-85xx-panda-support.patch
target/linux/ramips/patches-4.14/0046-mmc-MIPS-ralink-add-sdhci-for-mt7620a-SoC.patch
target/linux/ramips/patches-4.14/0051-serial-add-ugly-custom-baud-rate-hack.patch
target/linux/sunxi/patches-4.14/040-arm64-dts-allwinner-a64-Add-watchdog.patch
target/linux/sunxi/patches-4.14/080-arm64-allwinner-a64-add-SPI-nodes.patch
target/linux/sunxi/patches-4.14/081-arm64-dts-allwinner-sun50i-a64-Add-spi-flash-node-fo.patch
target/linux/sunxi/patches-4.14/400-arm64-allwinner-a64-sopine-Add-Sopine-flash-partitio.patch

index 6fdf6b3c612f4fc05a51404682bdbf4467877c52..8816cb12992bff475004dc73ee1503e348c3614f 100644 (file)
@@ -4,12 +4,12 @@ LINUX_RELEASE?=1
 
 LINUX_VERSION-3.18 = .133
 LINUX_VERSION-4.9 = .153
-LINUX_VERSION-4.14 = .95
+LINUX_VERSION-4.14 = .96
 LINUX_VERSION-4.19 = .16
 
 LINUX_KERNEL_HASH-3.18.133 = 3ec7f47365a8a050e629a5016e90e38a800e840c844901c979e9e796f8dc6711
 LINUX_KERNEL_HASH-4.9.153 = 9066929ec2550794ae107350a5f3c5b648438aa915cfc62bac5b7a54b9d7731a
-LINUX_KERNEL_HASH-4.14.95 = ce6729e3fca312520e3cb4f27993852dbb019d94c59c0b35cedab571f9cb58e4
+LINUX_KERNEL_HASH-4.14.96 = 110daeae1a416b7e0ec8dce5e86d67552deeb4567f696c3869389be239f0ecb5
 LINUX_KERNEL_HASH-4.19.16 = d8a088381fe3e7e5484c060dabcdda4b053ef7114f91cfd56db003a89bb11bdf
 
 remove_uri_prefix=$(subst git://,,$(subst http://,,$(subst https://,,$(1))))
index 5c526794fde6cbfae98a5f42bd65c2ff23298317..0797bf7ba23b34e1da2f948ffa18fed2e6680902 100644 (file)
@@ -10,7 +10,7 @@
  
 --- a/arch/mips/Kconfig
 +++ b/arch/mips/Kconfig
-@@ -1152,6 +1152,9 @@ config MIPS_MSC
+@@ -1155,6 +1155,9 @@ config MIPS_MSC
  config MIPS_NILE4
        bool
  
index 5639497926cb0d8e558a95527a3f481fd05d8d01..915a7f05d16315610eb7fc0fddad58e5c73c20c4 100644 (file)
@@ -55,7 +55,7 @@ Cc: Kir Kolyshkin <kir@openvz.org>
        rwlock_t                sk_callback_lock;
 --- a/net/core/sock.c
 +++ b/net/core/sock.c
-@@ -2742,6 +2742,7 @@ void sock_init_data(struct socket *sock,
+@@ -2743,6 +2743,7 @@ void sock_init_data(struct socket *sock,
  
        sk->sk_max_pacing_rate = ~0U;
        sk->sk_pacing_rate = ~0U;
index e20ddc2917a61330dda6498a58bffcc298a81427..844ba450d7455c87e72ca7e7346eb15ad658e988 100644 (file)
@@ -11,7 +11,7 @@ Signed-off-by: Pablo Neira Ayuso <pablo@netfilter.org>
 
 --- a/net/ipv4/netfilter/ipt_CLUSTERIP.c
 +++ b/net/ipv4/netfilter/ipt_CLUSTERIP.c
-@@ -834,6 +834,7 @@ static void clusterip_net_exit(struct ne
+@@ -835,6 +835,7 @@ static void clusterip_net_exit(struct ne
        cn->procdir = NULL;
  #endif
        nf_unregister_net_hook(net, &cip_arp_ops);
index 994ecd7ed4197c2d7bf93a621ba6807d56c43cb3..744cf4cff26bbaf77b427bf178c4de1a89dc63be 100644 (file)
@@ -13,7 +13,7 @@ Acked-by: Adrian Hunter <adrian.hunter@intel.com>
 
 --- a/drivers/mmc/host/Kconfig
 +++ b/drivers/mmc/host/Kconfig
-@@ -420,6 +420,7 @@ config MMC_SDHCI_MSM
+@@ -429,6 +429,7 @@ config MMC_SDHCI_MSM
        tristate "Qualcomm SDHCI Controller Support"
        depends on ARCH_QCOM || (ARM && COMPILE_TEST)
        depends on MMC_SDHCI_PLTFM
index eb6011e813da60183877379b5c08c622c5cf5fa6..bc49e5b40e3829ae13a391ddd0a0ea9af5495ed7 100644 (file)
@@ -10,7 +10,7 @@ Signed-off-by: Gabor Juhos <juhosg@openwrt.org>
 
 --- a/arch/mips/Kconfig
 +++ b/arch/mips/Kconfig
-@@ -1158,6 +1158,10 @@ config SYNC_R4K
+@@ -1161,6 +1161,10 @@ config SYNC_R4K
  config MIPS_MACHINE
        def_bool n
  
index d250843a6a26397bde4d44dfc3f6c008e5c65df2..36d69c1dfde9e1d703369e2ff5f690de29f719eb 100644 (file)
@@ -61,7 +61,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
  struct dst_entry *__sk_dst_check(struct sock *sk, u32 cookie)
  {
        struct dst_entry *dst = __sk_dst_get(sk);
-@@ -1595,9 +1607,11 @@ void sk_destruct(struct sock *sk)
+@@ -1596,9 +1608,11 @@ void sk_destruct(struct sock *sk)
  
  static void __sk_free(struct sock *sk)
  {
index 092f0aa81bcf349e51e0b8a1fbb0d14be1c951b2..3475a570146df947cd20b321c7153ca8981fb83d 100644 (file)
@@ -327,7 +327,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
  
 --- a/net/core/sock.c
 +++ b/net/core/sock.c
-@@ -3381,6 +3381,8 @@ static __net_initdata struct pernet_oper
+@@ -3382,6 +3382,8 @@ static __net_initdata struct pernet_oper
  
  static int __init proto_init(void)
  {
diff --git a/target/linux/generic/pending-4.14/142-jffs2-Fix-use-of-uninitialized-delayed_work-lockdep-.patch b/target/linux/generic/pending-4.14/142-jffs2-Fix-use-of-uninitialized-delayed_work-lockdep-.patch
deleted file mode 100644 (file)
index 05f83cc..0000000
+++ /dev/null
@@ -1,62 +0,0 @@
-From a788c5272769ddbcdbab297cf386413eeac04463 Mon Sep 17 00:00:00 2001
-From: Daniel Santos <daniel.santos@pobox.com>
-Date: Fri, 19 Oct 2018 03:30:20 -0500
-Subject: [PATCH] jffs2: Fix use of uninitialized delayed_work, lockdep
- breakage
-
-jffs2_sync_fs makes the assumption that if CONFIG_JFFS2_FS_WRITEBUFFER
-is defined then a write buffer is available and has been initialized.
-However, this does is not the case when the mtd device has no
-out-of-band buffer:
-
-int jffs2_nand_flash_setup(struct jffs2_sb_info *c)
-{
-        if (!c->mtd->oobsize)
-                return 0;
-...
-
-The resulting call to cancel_delayed_work_sync passing a uninitialized
-(but zeroed) delayed_work struct forces lockdep to become disabled.
-
-[   90.050639] overlayfs: upper fs does not support tmpfile.
-[   90.652264] INFO: trying to register non-static key.
-[   90.662171] the code is fine but needs lockdep annotation.
-[   90.673090] turning off the locking correctness validator.
-[   90.684021] CPU: 0 PID: 1762 Comm: mount_root Not tainted 4.14.63 #0
-[   90.696672] Stack : 00000000 00000000 80d8f6a2 00000038 805f0000 80444600 8fe364f4 805dfbe7
-[   90.713349]         80563a30 000006e2 8068370c 00000001 00000000 00000001 8e2fdc48 ffffffff
-[   90.730020]         00000000 00000000 80d90000 00000000 00000106 00000000 6465746e 312e3420
-[   90.746690]         6b636f6c 03bf0000 f8000000 20676e69 00000000 80000000 00000000 8e2c2a90
-[   90.763362]         80d90000 00000001 00000000 8e2c2a90 00000003 80260dc0 08052098 80680000
-[   90.780033]         ...
-[   90.784902] Call Trace:
-[   90.789793] [<8000f0d8>] show_stack+0xb8/0x148
-[   90.798659] [<8005a000>] register_lock_class+0x270/0x55c
-[   90.809247] [<8005cb64>] __lock_acquire+0x13c/0xf7c
-[   90.818964] [<8005e314>] lock_acquire+0x194/0x1dc
-[   90.828345] [<8003f27c>] flush_work+0x200/0x24c
-[   90.837374] [<80041dfc>] __cancel_work_timer+0x158/0x210
-[   90.847958] [<801a8770>] jffs2_sync_fs+0x20/0x54
-[   90.857173] [<80125cf4>] iterate_supers+0xf4/0x120
-[   90.866729] [<80158fc4>] sys_sync+0x44/0x9c
-[   90.875067] [<80014424>] syscall_common+0x34/0x58
-
-Signed-off-by: Daniel Santos <daniel.santos@pobox.com>
-Reviewed-by: Hou Tao <houtao1@huawei.com>
-Signed-off-by: Boris Brezillon <boris.brezillon@bootlin.com>
----
- fs/jffs2/super.c | 3 ++-
- 1 file changed, 2 insertions(+), 1 deletion(-)
-
---- a/fs/jffs2/super.c
-+++ b/fs/jffs2/super.c
-@@ -101,7 +101,8 @@ static int jffs2_sync_fs(struct super_bl
-       struct jffs2_sb_info *c = JFFS2_SB_INFO(sb);
- #ifdef CONFIG_JFFS2_FS_WRITEBUFFER
--      cancel_delayed_work_sync(&c->wbuf_dwork);
-+      if (jffs2_is_writebuffered(c))
-+              cancel_delayed_work_sync(&c->wbuf_dwork);
- #endif
-       mutex_lock(&c->alloc_sem);
index 5384be15ca02e4c77c2f762d00626c2454b8d613..35854f323ca3ae7012d680580985f2e9bf98a11c 100644 (file)
@@ -9,7 +9,7 @@ Acked-by: Rob Landley <rob@landley.net>
 ---
 --- a/arch/mips/Kconfig
 +++ b/arch/mips/Kconfig
-@@ -1067,9 +1067,6 @@ config FW_ARC
+@@ -1070,9 +1070,6 @@ config FW_ARC
  config ARCH_MAY_HAVE_PC_FDC
        bool
  
@@ -19,7 +19,7 @@ Acked-by: Rob Landley <rob@landley.net>
  config CEVT_BCM1480
        bool
  
-@@ -2967,6 +2964,18 @@ choice
+@@ -2970,6 +2967,18 @@ choice
                bool "Extend builtin kernel arguments with bootloader arguments"
  endchoice
  
index 22e2e86206c191275c38ccba6dd922a1f75779aa..57827d5aa51be566208d820aa75078a1e988a2fc 100644 (file)
@@ -24,7 +24,7 @@ v2: incorporated changes suggested by Jonas Gorski
 
 --- a/arch/mips/Kconfig
 +++ b/arch/mips/Kconfig
-@@ -2891,6 +2891,20 @@ config MIPS_O32_FP64_SUPPORT
+@@ -2894,6 +2894,20 @@ config MIPS_O32_FP64_SUPPORT
  
          If unsure, say N.
  
index de2dd65b1795c7f74021fe5eac61363d51755ec5..2c78b91c57bc1a072c0bfd903ed79a0865f2f030 100644 (file)
@@ -30,7 +30,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
        select HAVE_PCSPKR_PLATFORM
        select IRQ_MIPS_CPU
        select I8253
-@@ -1128,6 +1130,9 @@ config DMA_NONCOHERENT
+@@ -1131,6 +1133,9 @@ config DMA_NONCOHERENT
        bool
        select NEED_DMA_MAP_STATE
  
@@ -40,7 +40,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
  config NEED_DMA_MAP_STATE
        bool
  
-@@ -1652,6 +1657,7 @@ config CPU_R10000
+@@ -1655,6 +1660,7 @@ config CPU_R10000
        select CPU_SUPPORTS_64BIT_KERNEL
        select CPU_SUPPORTS_HIGHMEM
        select CPU_SUPPORTS_HUGEPAGES
@@ -48,7 +48,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
        help
          MIPS Technologies R10000-series processors.
  
-@@ -1900,9 +1906,11 @@ config SYS_HAS_CPU_MIPS32_R3_5
+@@ -1903,9 +1909,11 @@ config SYS_HAS_CPU_MIPS32_R3_5
        bool
  
  config SYS_HAS_CPU_MIPS32_R5
@@ -60,7 +60,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
        bool
  
  config SYS_HAS_CPU_MIPS64_R1
-@@ -1912,6 +1920,7 @@ config SYS_HAS_CPU_MIPS64_R2
+@@ -1915,6 +1923,7 @@ config SYS_HAS_CPU_MIPS64_R2
        bool
  
  config SYS_HAS_CPU_MIPS64_R6
index fc4e414df5aea1bb57c2e810bd9a0491c8a4aae2..b0b5bd3a57e30d6bfbdb91a71629db561636f5fc 100644 (file)
@@ -1,6 +1,6 @@
 --- a/arch/mips/Kconfig
 +++ b/arch/mips/Kconfig
-@@ -2324,6 +2324,12 @@ config MIPS_VPE_LOADER
+@@ -2327,6 +2327,12 @@ config MIPS_VPE_LOADER
          Includes a loader for loading an elf relocatable object
          onto another VPE and running it.
  
index 5844b80f42e4733f4507b5018726eb43e592f0c2..a08bc302f21139fcdedba9d6ef15dfcaed450e61 100644 (file)
@@ -1,7 +1,5 @@
-Index: linux-4.14.82/arch/powerpc/platforms/85xx/Kconfig
-===================================================================
---- linux-4.14.82.orig/arch/powerpc/platforms/85xx/Kconfig
-+++ linux-4.14.82/arch/powerpc/platforms/85xx/Kconfig
+--- a/arch/powerpc/platforms/85xx/Kconfig
++++ b/arch/powerpc/platforms/85xx/Kconfig
 @@ -60,6 +60,17 @@ config HIVEAP_330
        This board is a Concurrent Dual-Band wireless access point with a
        Freescale P1020 SoC.
@@ -20,10 +18,8 @@ Index: linux-4.14.82/arch/powerpc/platforms/85xx/Kconfig
  config MPC8540_ADS
        bool "Freescale MPC8540 ADS"
        select DEFAULT_UIMAGE
-Index: linux-4.14.82/arch/powerpc/platforms/85xx/Makefile
-===================================================================
---- linux-4.14.82.orig/arch/powerpc/platforms/85xx/Makefile
-+++ linux-4.14.82/arch/powerpc/platforms/85xx/Makefile
+--- a/arch/powerpc/platforms/85xx/Makefile
++++ b/arch/powerpc/platforms/85xx/Makefile
 @@ -22,6 +22,7 @@ obj-$(CONFIG_P1010_RDB)   += p1010rdb.o
  obj-$(CONFIG_P1022_DS)    += p1022_ds.o
  obj-$(CONFIG_P1022_RDK)   += p1022_rdk.o
index 353b6836af48cc2311c52f8a01fe3eccf29d0c90..4c4147ef52fcbc8fc0194b11d9e85db16c16b002 100644 (file)
@@ -25,7 +25,7 @@ Signed-off-by: John Crispin <blogic@openwrt.org>
 
 --- a/drivers/mmc/host/Kconfig
 +++ b/drivers/mmc/host/Kconfig
-@@ -899,3 +899,5 @@ config MMC_SDHCI_XENON
+@@ -900,3 +900,5 @@ config MMC_SDHCI_XENON
          This selects Marvell Xenon eMMC/SD/SDIO SDHCI.
          If you have a controller with this interface, say Y or M here.
          If unsure, say N.
index 634033d18d3fe5862d94037dca524a5d75e68b06..2ad1f6f9f8c5c022226b12afd4e752a0fad8908e 100644 (file)
@@ -10,7 +10,7 @@ Signed-off-by: John Crispin <blogic@openwrt.org>
 
 --- a/drivers/tty/serial/serial_core.c
 +++ b/drivers/tty/serial/serial_core.c
-@@ -418,6 +418,9 @@ uart_get_baud_rate(struct uart_port *por
+@@ -428,6 +428,9 @@ uart_get_baud_rate(struct uart_port *por
                break;
        }
  
index 5aadaa7b0b734bb3e747ca2b7bc9c4169f98b7a0..0503b88823357f3f6d53a060939868635e3d4a05 100644 (file)
@@ -15,8 +15,6 @@ Signed-off-by: Maxime Ripard <maxime.ripard@bootlin.com>
  arch/arm64/boot/dts/allwinner/sun50i-a64.dtsi            | 7 +++++++
  2 files changed, 11 insertions(+), 2 deletions(-)
 
-diff --git a/Documentation/devicetree/bindings/watchdog/sunxi-wdt.txt b/Documentation/devicetree/bindings/watchdog/sunxi-wdt.txt
-index 62dd5baad70e..04fc368d828f 100644
 --- a/Documentation/devicetree/bindings/watchdog/sunxi-wdt.txt
 +++ b/Documentation/devicetree/bindings/watchdog/sunxi-wdt.txt
 @@ -2,8 +2,10 @@ Allwinner SoCs Watchdog timer
@@ -32,11 +30,9 @@ index 62dd5baad70e..04fc368d828f 100644
  - reg : Specifies base physical address and size of the registers.
  
  Example:
-diff --git a/arch/arm64/boot/dts/allwinner/sun50i-a64.dtsi b/arch/arm64/boot/dts/allwinner/sun50i-a64.dtsi
-index 64e452a758fa..8401e7f887ff 100644
 --- a/arch/arm64/boot/dts/allwinner/sun50i-a64.dtsi
 +++ b/arch/arm64/boot/dts/allwinner/sun50i-a64.dtsi
-@@ -665,5 +665,12 @@
+@@ -537,5 +537,12 @@
                        #address-cells = <1>;
                        #size-cells = <0>;
                };
@@ -49,6 +45,3 @@ index 64e452a758fa..8401e7f887ff 100644
 +              };
        };
  };
--- 
-2.17.1
-
index 0608f13629250fcb114afef32668386264b716f9..5374547e92b02e290400c5cbb5dbddb4f6972b35 100644 (file)
@@ -19,8 +19,6 @@ Signed-off-by: Maxime Ripard <maxime.ripard@free-electrons.com>
  arch/arm64/boot/dts/allwinner/sun50i-a64.dtsi | 41 +++++++++++++++++++
  1 file changed, 41 insertions(+)
 
-diff --git a/arch/arm64/boot/dts/allwinner/sun50i-a64.dtsi b/arch/arm64/boot/dts/allwinner/sun50i-a64.dtsi
-index 8c8db1b057df..20aba7b186aa 100644
 --- a/arch/arm64/boot/dts/allwinner/sun50i-a64.dtsi
 +++ b/arch/arm64/boot/dts/allwinner/sun50i-a64.dtsi
 @@ -325,6 +325,16 @@
@@ -40,8 +38,8 @@ index 8c8db1b057df..20aba7b186aa 100644
                        uart0_pins_a: uart0@0 {
                                pins = "PB8", "PB9";
                                function = "uart0";
-@@ -449,6 +459,37 @@
-                       #size-cells = <0>;
+@@ -470,6 +480,37 @@
+                       };
                };
  
 +
@@ -78,6 +76,3 @@ index 8c8db1b057df..20aba7b186aa 100644
                gic: interrupt-controller@1c81000 {
                        compatible = "arm,gic-400";
                        reg = <0x01c81000 0x1000>,
--- 
-2.17.1
-
index c975823447208db0fda6631e8f7fc473e37f4608..3a6e1c3bfa2f2a39bd5a5e6c03446b24c65bd7bf 100644 (file)
@@ -13,11 +13,9 @@ Signed-off-by: Maxime Ripard <maxime.ripard@bootlin.com>
  arch/arm64/boot/dts/allwinner/sun50i-a64-sopine.dtsi | 12 ++++++++++++
  1 file changed, 12 insertions(+)
 
-diff --git a/arch/arm64/boot/dts/allwinner/sun50i-a64-sopine.dtsi b/arch/arm64/boot/dts/allwinner/sun50i-a64-sopine.dtsi
-index 43418bd881d8..b94f93c04acb 100644
 --- a/arch/arm64/boot/dts/allwinner/sun50i-a64-sopine.dtsi
 +++ b/arch/arm64/boot/dts/allwinner/sun50i-a64-sopine.dtsi
-@@ -66,6 +66,18 @@
+@@ -75,6 +75,18 @@
        };
  };
  
@@ -36,6 +34,3 @@ index 43418bd881d8..b94f93c04acb 100644
  #include "axp803.dtsi"
  
  &reg_aldo2 {
--- 
-2.17.1
-
index 200cf9555e34762112935e4d91d4096d7d5ba999..0d8ec4cec0e228c2a150d165648389d94c39e361 100644 (file)
@@ -13,11 +13,9 @@ Signed-off-by: Oskari Lemmela <oskari@lemmela.net>
  .../boot/dts/allwinner/sun50i-a64-sopine.dtsi | 22 +++++++++++++++++++
  1 file changed, 22 insertions(+)
 
-diff --git a/arch/arm64/boot/dts/allwinner/sun50i-a64-sopine.dtsi b/arch/arm64/boot/dts/allwinner/sun50i-a64-sopine.dtsi
-index 6723b8695e0b..3e879fefe3d5 100644
 --- a/arch/arm64/boot/dts/allwinner/sun50i-a64-sopine.dtsi
 +++ b/arch/arm64/boot/dts/allwinner/sun50i-a64-sopine.dtsi
-@@ -78,6 +78,28 @@
+@@ -84,6 +84,28 @@
                compatible = "jedec,spi-nor";
                reg = <0>;
                spi-max-frequency = <40000000>;
@@ -46,6 +44,3 @@ index 6723b8695e0b..3e879fefe3d5 100644
        };
  };
  
--- 
-2.17.1
-