kernel: bump 4.14 to 4.14.91
authorKoen Vandeputte <koen.vandeputte@ncentric.com>
Mon, 7 Jan 2019 10:12:09 +0000 (11:12 +0100)
committerKoen Vandeputte <koen.vandeputte@ncentric.com>
Tue, 8 Jan 2019 12:13:16 +0000 (13:13 +0100)
Refreshed all patches.

Altered patches:
- 902-debloat_proc.patch

Removed upstreamed:
- 500-ubifs-Handle-re-linking-of-inodes-correctly-while-re.patch

Compile-tested on: cns3xxx, imx6
Runtime-tested on: cns3xxx, imx6

Signed-off-by: Koen Vandeputte <koen.vandeputte@ncentric.com>
include/kernel-version.mk
target/linux/apm821xx/patches-4.14/802-usb-xhci-force-msi-renesas-xhci.patch
target/linux/cns3xxx/patches-4.14/060-pcie_abort.patch
target/linux/generic/backport-4.14/030-USB-serial-option-fix-dwm-158-3g-modem-interface.patch
target/linux/generic/backport-4.14/100-arm-cns3xxx-fix-writing-to-wrong-PCI-registers-after.patch
target/linux/generic/backport-4.14/500-ubifs-Handle-re-linking-of-inodes-correctly-while-re.patch [deleted file]
target/linux/generic/hack-4.14/902-debloat_proc.patch
target/linux/generic/pending-4.14/834-ledtrig-libata.patch
target/linux/oxnas/patches-4.14/999-libata-hacks.patch

index af36f408e3574ffccae9fcf12ed8ed987393d397..66d11fc0c5c140ef2dab3a4e558b976345e85554 100644 (file)
@@ -3,10 +3,10 @@
 LINUX_RELEASE?=1
 
 LINUX_VERSION-4.9 = .148
-LINUX_VERSION-4.14 = .89
+LINUX_VERSION-4.14 = .91
 
 LINUX_KERNEL_HASH-4.9.148 = 6067151b0225a8de1ab79abc9be7bae237eaca0cd838eb26684169560d88a994
-LINUX_KERNEL_HASH-4.14.89 = ce6e16ac44dddd0d6a232bf2ce03e8bf8beca19f9b84503684466d140a1a0b25
+LINUX_KERNEL_HASH-4.14.91 = 6a587c8b4160918efa082b0c2eda8c2db0f50d8814ad1d1ac94be1edf66ca6a9
 
 remove_uri_prefix=$(subst git://,,$(subst http://,,$(subst https://,,$(1))))
 sanitize_uri=$(call qstrip,$(subst @,_,$(subst :,_,$(subst .,_,$(subst -,_,$(subst /,_,$(1)))))))
index 71b90f2db2122bae5077fd383ed9ff9cc73986ab..ed14505e183227539b762ea79cbe45f5f87d9b42 100644 (file)
@@ -50,5 +50,5 @@ produce a noisy warning.
        /* support xHCI 1.0 spec USB2 hardware LPM */
 +#define XHCI_FORCE_MSI                (1 << 24)
        unsigned                hw_lpm_support:1;
-       /* cached usb2 extened protocol capabilites */
-       u32                     *ext_caps;
+       /* Broken Suspend flag for SNPS Suspend resume issue */
+       unsigned                broken_suspend:1;
index 7a3a8e4c250c9ced74b32a14ad0aff37e7515976..b5f0350571cfb7cade7a7fbe02119382e24b34b9 100644 (file)
@@ -1,7 +1,7 @@
 --- a/arch/arm/mach-cns3xxx/pcie.c
 +++ b/arch/arm/mach-cns3xxx/pcie.c
 @@ -86,6 +86,79 @@ static void __iomem *cns3xxx_pci_map_bus
-       return base + (where & 0xffc) + (devfn << 12);
+       return base + where + (devfn << 12);
  }
  
 +static inline int check_master_abort(struct pci_bus *bus, unsigned int devfn, int where)
index 4201ab17442c5f12f2c05353a236c4709fdb1e16..93ca8331e3b7956b15d7fb56de8ed5bc99709659 100644 (file)
@@ -30,7 +30,7 @@ Signed-off-by: Johan Hovold <johan@kernel.org>
 
 --- a/drivers/usb/serial/option.c
 +++ b/drivers/usb/serial/option.c
-@@ -1927,7 +1927,8 @@ static const struct usb_device_id option
+@@ -1934,7 +1934,8 @@ static const struct usb_device_id option
        { USB_DEVICE_INTERFACE_CLASS(0x2001, 0x7d01, 0xff) },                   /* D-Link DWM-156 (variant) */
        { USB_DEVICE_INTERFACE_CLASS(0x2001, 0x7d02, 0xff) },
        { USB_DEVICE_INTERFACE_CLASS(0x2001, 0x7d03, 0xff) },
index 458515a0b59f4e6c37e161bf19bd60dca4a5d738..faeb3e417006bce6e166bc5a8426d40e81160bdd 100644 (file)
@@ -61,11 +61,9 @@ CC: stable@vger.kernel.org # v4.0+
  arch/arm/mach-cns3xxx/pcie.c | 2 +-
  1 file changed, 1 insertion(+), 1 deletion(-)
 
-diff --git a/arch/arm/mach-cns3xxx/pcie.c b/arch/arm/mach-cns3xxx/pcie.c
-index 318394ed5c7a..5e11ad3164e0 100644
 --- a/arch/arm/mach-cns3xxx/pcie.c
 +++ b/arch/arm/mach-cns3xxx/pcie.c
-@@ -83,7 +83,7 @@ static void __iomem *cns3xxx_pci_map_bus(struct pci_bus *bus,
+@@ -83,7 +83,7 @@ static void __iomem *cns3xxx_pci_map_bus
        } else /* remote PCI bus */
                base = cnspci->cfg1_regs + ((busno & 0xf) << 20);
  
@@ -74,6 +72,3 @@ index 318394ed5c7a..5e11ad3164e0 100644
  }
  
  static int cns3xxx_pci_read_config(struct pci_bus *bus, unsigned int devfn,
--- 
-2.17.1
-
diff --git a/target/linux/generic/backport-4.14/500-ubifs-Handle-re-linking-of-inodes-correctly-while-re.patch b/target/linux/generic/backport-4.14/500-ubifs-Handle-re-linking-of-inodes-correctly-while-re.patch
deleted file mode 100644 (file)
index 71e036c..0000000
+++ /dev/null
@@ -1,89 +0,0 @@
-From: Richard Weinberger <richard@nod.at>
-Date: Wed, 7 Nov 2018 23:04:43 +0100
-Subject: [PATCH] ubifs: Handle re-linking of inodes correctly while recovery
-MIME-Version: 1.0
-Content-Type: text/plain; charset=UTF-8
-Content-Transfer-Encoding: 8bit
-
-UBIFS's recovery code strictly assumes that a deleted inode will never
-come back, therefore it removes all data which belongs to that inode
-as soon it faces an inode with link count 0 in the replay list.
-Before O_TMPFILE this assumption was perfectly fine. With O_TMPFILE
-it can lead to data loss upon a power-cut.
-
-Consider a journal with entries like:
-0: inode X (nlink = 0) /* O_TMPFILE was created */
-1: data for inode X /* Someone writes to the temp file */
-2: inode X (nlink = 0) /* inode was changed, xattr, chmod, … */
-3: inode X (nlink = 1) /* inode was re-linked via linkat() */
-
-Upon replay of entry #2 UBIFS will drop all data that belongs to inode X,
-this will lead to an empty file after mounting.
-
-As solution for this problem, scan the replay list for a re-link entry
-before dropping data.
-
-Fixes: 474b93704f32 ("ubifs: Implement O_TMPFILE")
-Cc: stable@vger.kernel.org
-Cc: Russell Senior <russell@personaltelco.net>
-Cc: Rafał Miłecki <zajec5@gmail.com>
-Reported-by: Russell Senior <russell@personaltelco.net>
-Reported-by: Rafał Miłecki <zajec5@gmail.com>
-Signed-off-by: Richard Weinberger <richard@nod.at>
----
- fs/ubifs/replay.c | 37 +++++++++++++++++++++++++++++++++++++
- 1 file changed, 37 insertions(+)
-
---- a/fs/ubifs/replay.c
-+++ b/fs/ubifs/replay.c
-@@ -210,6 +210,38 @@ static int trun_remove_range(struct ubif
- }
- /**
-+ * inode_still_linked - check whether inode in question will be re-linked.
-+ * @c: UBIFS file-system description object
-+ * @rino: replay entry to test
-+ *
-+ * O_TMPFILE files can be re-linked, this means link count goes from 0 to 1.
-+ * This case needs special care, otherwise all references to the inode will
-+ * be removed upon the first replay entry of an inode with link count 0
-+ * is found.
-+ */
-+static bool inode_still_linked(struct ubifs_info *c, struct replay_entry *rino)
-+{
-+      struct replay_entry *r;
-+
-+      ubifs_assert(rino->deletion);
-+      ubifs_assert(key_type(c, &rino->key) == UBIFS_INO_KEY);
-+
-+      /*
-+       * Find the most recent entry for the inode behind @rino and check
-+       * whether it is a deletion.
-+       */
-+      list_for_each_entry_reverse(r, &c->replay_list, list) {
-+              ubifs_assert(r->sqnum >= rino->sqnum);
-+              if (key_inum(c, &r->key) == key_inum(c, &rino->key))
-+                      return r->deletion == 0;
-+
-+      }
-+
-+      ubifs_assert(0);
-+      return false;
-+}
-+
-+/**
-  * apply_replay_entry - apply a replay entry to the TNC.
-  * @c: UBIFS file-system description object
-  * @r: replay entry to apply
-@@ -239,6 +271,11 @@ static int apply_replay_entry(struct ubi
-                       {
-                               ino_t inum = key_inum(c, &r->key);
-+                              if (inode_still_linked(c, r)) {
-+                                      err = 0;
-+                                      break;
-+                              }
-+
-                               err = ubifs_tnc_remove_ino(c, inum);
-                               break;
-                       }
index cae6d66e7df4c64eceeb04122f5cd9b8b0abc74f..d9963361868fac96e33190b7008f66775d279db5 100644 (file)
@@ -221,13 +221,14 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
        if (!root_irq_dir)
 --- a/kernel/time/timer_list.c
 +++ b/kernel/time/timer_list.c
-@@ -389,6 +389,8 @@ static int __init init_timer_list_procfs
+@@ -389,6 +389,9 @@ static int __init init_timer_list_procfs
  {
        struct proc_dir_entry *pe;
  
 +      if (IS_ENABLED(CONFIG_PROC_STRIPPED))
 +              return 0;
-       pe = proc_create("timer_list", 0444, NULL, &timer_list_fops);
++
+       pe = proc_create("timer_list", 0400, NULL, &timer_list_fops);
        if (!pe)
                return -ENOMEM;
 --- a/mm/vmalloc.c
index 2eec024b725d8e38552f7179f98e053159847fa1..392d41c94f291bab510f6469fbae64c5814b51dd 100644 (file)
@@ -65,7 +65,7 @@ Signed-off-by: Daniel Golle <daniel@makrotopia.org>
  /**
   *    ata_build_rw_tf - Build ATA taskfile for given read/write request
   *    @tf: Target ATA taskfile
-@@ -5120,6 +5133,9 @@ struct ata_queued_cmd *ata_qc_new_init(s
+@@ -5121,6 +5134,9 @@ struct ata_queued_cmd *ata_qc_new_init(s
                if (tag < 0)
                        return NULL;
        }
@@ -75,7 +75,7 @@ Signed-off-by: Daniel Golle <daniel@makrotopia.org>
  
        qc = __ata_qc_from_tag(ap, tag);
        qc->tag = tag;
-@@ -6021,6 +6037,9 @@ struct ata_port *ata_port_alloc(struct a
+@@ -6022,6 +6038,9 @@ struct ata_port *ata_port_alloc(struct a
        ap->stats.unhandled_irq = 1;
        ap->stats.idle_irq = 1;
  #endif
@@ -85,7 +85,7 @@ Signed-off-by: Daniel Golle <daniel@makrotopia.org>
        ata_sff_port_init(ap);
  
        return ap;
-@@ -6042,6 +6061,12 @@ static void ata_host_release(struct devi
+@@ -6043,6 +6062,12 @@ static void ata_host_release(struct devi
  
                kfree(ap->pmp_link);
                kfree(ap->slave_link);
@@ -98,7 +98,7 @@ Signed-off-by: Daniel Golle <daniel@makrotopia.org>
                kfree(ap);
                host->ports[i] = NULL;
        }
-@@ -6488,7 +6513,23 @@ int ata_host_register(struct ata_host *h
+@@ -6489,7 +6514,23 @@ int ata_host_register(struct ata_host *h
                host->ports[i]->print_id = atomic_inc_return(&ata_print_id);
                host->ports[i]->local_port_no = i + 1;
        }
index e490dbf7c177f93cc549390625337ae7724566da..382a16329aae3dff1e16b91abaef6ad5751708f4 100644 (file)
@@ -15,7 +15,7 @@
        /* initialize internal qc */
  
        /* XXX: Tag 0 is used for drivers with legacy EH as some
-@@ -5127,6 +5135,9 @@ struct ata_queued_cmd *ata_qc_new_init(s
+@@ -5128,6 +5136,9 @@ struct ata_queued_cmd *ata_qc_new_init(s
        if (unlikely(ap->pflags & ATA_PFLAG_FROZEN))
                return NULL;
  
@@ -25,7 +25,7 @@
        /* libsas case */
        if (ap->flags & ATA_FLAG_SAS_HOST) {
                tag = ata_sas_allocate_tag(ap);
-@@ -5172,6 +5183,8 @@ void ata_qc_free(struct ata_queued_cmd *
+@@ -5173,6 +5184,8 @@ void ata_qc_free(struct ata_queued_cmd *
                qc->tag = ATA_TAG_POISON;
                if (ap->flags & ATA_FLAG_SAS_HOST)
                        ata_sas_free_tag(tag, ap);