libyaml-cpp: fix compilation with libcxx
authorRosen Penev <rosenp@gmail.com>
Mon, 19 Oct 2020 00:40:05 +0000 (17:40 -0700)
committerRosen Penev <rosenp@gmail.com>
Mon, 19 Oct 2020 06:06:34 +0000 (23:06 -0700)
Added GitHub patch.

Signed-off-by: Rosen Penev <rosenp@gmail.com>
libs/libyaml-cpp/Makefile
libs/libyaml-cpp/patches/010-libcxx.patch [new file with mode: 0644]

index 2355b0a129153681521fc84a65d26306efaa9906..b78a2dd277df097827e9597e64d1b345a43dc9cd 100644 (file)
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=libyaml-cpp
 PKG_VERSION:=0.6.3
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 
 PKG_SOURCE:=yaml-cpp-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=https://codeload.github.com/jbeder/yaml-cpp/tar.gz/yaml-cpp-$(PKG_VERSION)?
diff --git a/libs/libyaml-cpp/patches/010-libcxx.patch b/libs/libyaml-cpp/patches/010-libcxx.patch
new file mode 100644 (file)
index 0000000..c908b1d
--- /dev/null
@@ -0,0 +1,23 @@
+From 78f338e4ee69bb00fb37faf50f448eeedc8b824c Mon Sep 17 00:00:00 2001
+From: Mark Jan van Kampen <mjvk@allseas.com>
+Date: Tue, 13 Oct 2020 11:19:57 +0200
+Subject: [PATCH] Adds assert to enable compilation with libcxx+gcc
+
+Somehow this instantiates a template properly otherwise the build fails
+---
+ include/yaml-cpp/node/iterator.h | 2 ++
+ 1 file changed, 2 insertions(+)
+
+diff --git a/include/yaml-cpp/node/iterator.h b/include/yaml-cpp/node/iterator.h
+index b4472381..080ec76c 100644
+--- a/include/yaml-cpp/node/iterator.h
++++ b/include/yaml-cpp/node/iterator.h
+@@ -15,6 +15,8 @@
+ #include <utility>
+ #include <vector>
++static_assert(std::is_constructible<YAML::Node, const YAML::Node&>::value, "Node must be copy constructable");
++
+ namespace YAML {
+ namespace detail {
+ struct iterator_value : public Node, std::pair<Node, Node> {