refresh generic 2.6.28 patches
authorImre Kaloz <kaloz@openwrt.org>
Mon, 4 May 2009 10:37:48 +0000 (10:37 +0000)
committerImre Kaloz <kaloz@openwrt.org>
Mon, 4 May 2009 10:37:48 +0000 (10:37 +0000)
SVN-Revision: 15578

target/linux/generic-2.6/patches-2.6.28/100-netfilter_layer7_2.21.patch
target/linux/generic-2.6/patches-2.6.28/101-netfilter_layer7_pktmatch.patch
target/linux/generic-2.6/patches-2.6.28/208-rtl8110sb_fix.patch
target/linux/generic-2.6/patches-2.6.28/980-vm_exports.patch

index 59c3f8b47d0b65a9a9b93b891deb78408ea4d86b..57f1b02742e41f4ab17bb448052e5c87bd67a706 100644 (file)
@@ -16,7 +16,7 @@
 +#endif /* _XT_LAYER7_H */
 --- a/include/net/netfilter/nf_conntrack.h
 +++ b/include/net/netfilter/nf_conntrack.h
-@@ -118,6 +118,22 @@
+@@ -118,6 +118,22 @@ struct nf_conn
        u_int32_t secmark;
  #endif
  
@@ -41,7 +41,7 @@
  
 --- a/net/netfilter/Kconfig
 +++ b/net/netfilter/Kconfig
-@@ -795,6 +795,27 @@
+@@ -795,6 +795,27 @@ config NETFILTER_XT_MATCH_STATE
  
          To compile it as a module, choose M here.  If unsure, say N.
  
@@ -71,7 +71,7 @@
        depends on NETFILTER_ADVANCED
 --- a/net/netfilter/Makefile
 +++ b/net/netfilter/Makefile
-@@ -84,6 +84,7 @@
+@@ -84,6 +84,7 @@ obj-$(CONFIG_NETFILTER_XT_MATCH_RECENT) 
  obj-$(CONFIG_NETFILTER_XT_MATCH_SCTP) += xt_sctp.o
  obj-$(CONFIG_NETFILTER_XT_MATCH_SOCKET) += xt_socket.o
  obj-$(CONFIG_NETFILTER_XT_MATCH_STATE) += xt_state.o
@@ -81,7 +81,7 @@
  obj-$(CONFIG_NETFILTER_XT_MATCH_TCPMSS) += xt_tcpmss.o
 --- a/net/netfilter/nf_conntrack_core.c
 +++ b/net/netfilter/nf_conntrack_core.c
-@@ -201,6 +201,14 @@
+@@ -201,6 +201,14 @@ destroy_conntrack(struct nf_conntrack *n
         * too. */
        nf_ct_remove_expectations(ct);
  
@@ -98,7 +98,7 @@
                BUG_ON(hlist_unhashed(&ct->tuplehash[IP_CT_DIR_ORIGINAL].hnode));
 --- a/net/netfilter/nf_conntrack_standalone.c
 +++ b/net/netfilter/nf_conntrack_standalone.c
-@@ -165,6 +165,12 @@
+@@ -165,6 +165,12 @@ static int ct_seq_show(struct seq_file *
                return -ENOSPC;
  #endif
  
index 4931b1bdb735ea02d83c9d77a08df0785a3b49a9..f65e301fd1fd36d5ab2ab2cc592daeaa08b67be5 100644 (file)
@@ -1,6 +1,6 @@
 --- a/include/linux/netfilter/xt_layer7.h
 +++ b/include/linux/netfilter/xt_layer7.h
-@@ -8,6 +8,7 @@
+@@ -8,6 +8,7 @@ struct xt_layer7_info {
      char protocol[MAX_PROTOCOL_LEN];
      char pattern[MAX_PATTERN_LEN];
      u_int8_t invert;
@@ -10,7 +10,7 @@
  #endif /* _XT_LAYER7_H */
 --- a/net/netfilter/xt_layer7.c
 +++ b/net/netfilter/xt_layer7.c
-@@ -314,33 +314,35 @@
+@@ -314,33 +314,35 @@ static int match_no_append(struct nf_con
  }
  
  /* add the new app data to the conntrack.  Return number of bytes added. */
@@ -60,7 +60,7 @@
  
        return length;
  }
-@@ -438,7 +440,7 @@
+@@ -438,7 +440,7 @@ match(const struct sk_buff *skbin,
  
        enum ip_conntrack_info master_ctinfo, ctinfo;
        struct nf_conn *master_conntrack, *conntrack;
@@ -69,7 +69,7 @@
        unsigned int pattern_result, appdatalen;
        regexp * comppattern;
  
-@@ -466,8 +468,8 @@
+@@ -466,8 +468,8 @@ match(const struct sk_buff *skbin,
                master_conntrack = master_ct(master_conntrack);
  
        /* if we've classified it or seen too many packets */
@@ -80,7 +80,7 @@
  
                pattern_result = match_no_append(conntrack, master_conntrack, 
                                                 ctinfo, master_ctinfo, info);
-@@ -500,6 +502,25 @@
+@@ -500,6 +502,25 @@ match(const struct sk_buff *skbin,
        /* the return value gets checked later, when we're ready to use it */
        comppattern = compile_and_cache(info->pattern, info->protocol);
  
index ca25aeda99033f10e81879c8042574ba5164c890..9d9ae5023e144548a7e6a1ed86bb05d925447fde 100644 (file)
@@ -27,7 +27,7 @@
                                  RxFIFOOver | TxErr | TxOK | RxOK | RxErr,
                .napi_event     = RxFIFOOver | TxErr | TxOK | RxOK | RxOverflow,
                .features       = RTL_FEATURE_MSI
-@@ -3554,10 +3554,12 @@ static irqreturn_t rtl8169_interrupt(int
+@@ -3555,10 +3555,12 @@ static irqreturn_t rtl8169_interrupt(int
                goto out;
        }
  
index 8168742ebafd2a2d3cc46f3642a7633dd66e50ad..023bf295e7a59c8a3339d4047c8237cbb187d3d2 100644 (file)
@@ -67,7 +67,7 @@
   * macro override instead of weak attribute alias, to workaround
 --- a/kernel/sched.c
 +++ b/kernel/sched.c
-@@ -5015,6 +5015,7 @@ int can_nice(const struct task_struct *p
+@@ -5064,6 +5064,7 @@ int can_nice(const struct task_struct *p
        return (nice_rlim <= p->signal->rlim[RLIMIT_NICE].rlim_cur ||
                capable(CAP_SYS_NICE));
  }