rtpengine: fix Module.symvers handling 614/head
authorSebastian Kemper <sebastian_ml@gmx.net>
Sat, 20 Feb 2021 10:45:49 +0000 (11:45 +0100)
committerSebastian Kemper <sebastian_ml@gmx.net>
Sat, 20 Feb 2021 10:45:51 +0000 (11:45 +0100)
This sets PKG_EXTMOD_SUBDIRS so kernel.mk can find the rtpengine
Module.symvers file.

Also, this puts KERNEL_MAKE_FLAGS into the make flags used to compile
the kernel module. This way Module.symvers files of other modules are
made available, plus there is no need anymore to specify ARCH and
CROSS_COMPILE, as KERNEL_MAKE_FLAGS already takes care of that.

While updating make flags this also adds PKG_JOBS for completeness'
sake.

Signed-off-by: Sebastian Kemper <sebastian_ml@gmx.net>
net/rtpengine/Makefile

index 219faba41e2197774cc4f25f2ca5e78addb16578..d794d1b4f7820839f1c65077e8842bbe7e8ecc57 100644 (file)
@@ -10,7 +10,7 @@ include $(INCLUDE_DIR)/kernel.mk
 
 PKG_NAME:=rtpengine
 PKG_VERSION:=8.5.3.2
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 
 PKG_SOURCE:=$(PKG_NAME)-mr$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=https://codeload.github.com/sipwise/rtpengine/tar.gz/mr$(PKG_VERSION)?
@@ -31,6 +31,10 @@ PKG_BUILD_PARALLEL:=0
 
 PKG_BUILD_DEPENDS:=gperf/host
 
+# With below variable set, $(PKG_SYMVERS_DIR)/rtpengine.symvers gets generated
+# from kernel-module/Module.symvers.
+PKG_EXTMOD_SUBDIRS:=kernel-module
+
 include $(INCLUDE_DIR)/package.mk
 include $(INCLUDE_DIR)/nls.mk
 
@@ -239,10 +243,10 @@ define Build/Compile
 
 ifneq ($(CONFIG_PACKAGE_kmod-ipt-rtpengine),)
        RTPENGINE_VERSION=$(PKG_VERSION) $(MAKE) \
+               $(PKG_JOBS) \
                -C $(PKG_BUILD_DIR)/kernel-module \
                KSRC=$(LINUX_DIR) \
-               ARCH=$(LINUX_KARCH) \
-               CROSS_COMPILE=$(TARGET_CROSS)
+               $(KERNEL_MAKE_FLAGS)
 endif
 
 ifneq ($(CONFIG_PACKAGE_iptables-mod-rtpengine),)
@@ -262,8 +266,10 @@ endef
 define Build/InstallDev
 endef
 
-$(eval $(call BuildPackage,rtpengine-no-transcode))
+# KernelPackage calls need to go first, otherwise hooks like
+# collect_module_symvers won't get added.
 $(eval $(call KernelPackage,ipt-rtpengine))
+$(eval $(call BuildPackage,rtpengine-no-transcode))
 $(eval $(call BuildPackage,iptables-mod-rtpengine))
 $(eval $(call BuildPackage,rtpengine))
 $(eval $(call BuildPackage,rtpengine-recording))