simple-adblock: support new OISD dnsmasq config 20050/head
authorStan Grishin <stangri@melmac.ca>
Sat, 10 Dec 2022 01:52:58 +0000 (01:52 +0000)
committerStan Grishin <stangri@melmac.ca>
Sat, 10 Dec 2022 01:57:37 +0000 (01:57 +0000)
* OISD dnsmasq config files switched from using address= to server=

Signed-off-by: Stan Grishin <stangri@melmac.ca>
net/simple-adblock/Makefile
net/simple-adblock/files/simple-adblock.init

index d6fdd316fccfa178063e58e726c00f3c90a04575..ac2854e95beac7b3299154af18cca5acd7551755 100644 (file)
@@ -6,7 +6,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=simple-adblock
 PKG_VERSION:=1.9.3
-PKG_RELEASE:=3
+PKG_RELEASE:=4
 PKG_MAINTAINER:=Stan Grishin <stangri@melmac.ca>
 PKG_LICENSE:=GPL-3.0-or-later
 
index 19a6b1fa274c6f89339919af009d2ee224647933..cdd2dac36af32654caa653fb56f1f699e57f093a 100644 (file)
@@ -62,7 +62,7 @@ readonly sharedMemoryError="/dev/shm/$packageName-error"
 readonly sharedMemoryOutput="/dev/shm/$packageName-output"
 readonly hostsFilter='/localhost/d;/^#/d;/^[^0-9]/d;s/^0\.0\.0\.0.//;s/^127\.0\.0\.1.//;s/[[:space:]]*#.*$//;s/[[:cntrl:]]$//;s/[[:space:]]//g;/[`~!@#\$%\^&\*()=+;:"'\'',<>?/\|[{}]/d;/]/d;/\./!d;/^$/d;/[^[:alnum:]_.-]/d;'
 readonly domainsFilter='/^#/d;s/[[:space:]]*#.*$//;s/[[:space:]]*$//;s/[[:cntrl:]]$//;/[[:space:]]/d;/[`~!@#\$%\^&\*()=+;:"'\'',<>?/\|[{}]/d;/]/d;/\./!d;/^$/d;/[^[:alnum:]_.-]/d;'
-readonly dnsmasqAddressFilter='\|^address=/[[:alnum:]_.-].*/#|!d'
+readonly dnsmasqOISDFilter='\|^server=/[[:alnum:]_.-].*/|!d'
 readonly _OK_='\033[0;32m\xe2\x9c\x93\033[0m'
 readonly _FAIL_='\033[0;31m\xe2\x9c\x97\033[0m'
 readonly __OK__='\033[0;32m[\xe2\x9c\x93]\033[0m'
@@ -658,7 +658,7 @@ process_url() {
        if [ -z "$1" ] || [ -z "$2" ] || [ -z "$3" ]; then return 1; fi
        label="${1##*//}"; label="${label%%/*}";
        case "$2" in
-               dnsmasq) label="Dnsmasq: $label"; filter="$dnsmasqAddressFilter";;
+               dnsmasq) label="Dnsmasq: $label"; filter="$dnsmasqOISDFilter";;
                domains) label="Domains: $label"; filter="$domainsFilter";;
                hosts) label="Hosts:   $label"; filter="$hostsFilter";;
        esac