bcp38: Add note about IPv6 to package description and help text
authorToke Høiland-Jørgensen <toke@toke.dk>
Sun, 8 Jan 2017 18:50:50 +0000 (19:50 +0100)
committerToke Høiland-Jørgensen <toke@toke.dk>
Sun, 8 Jan 2017 18:50:50 +0000 (19:50 +0100)
Fixes #3793.

net/bcp38/Makefile
net/bcp38/files/bcp38.config
net/luci-app-bcp38/Makefile
net/luci-app-bcp38/files/bcp38-cbi.lua

index 9ca19109e1f9ff0a021834d309c668c8a69f1492..4677a29729eae125559fee19bfffbcaeef38a4fb 100644 (file)
@@ -7,7 +7,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=bcp38
 PKG_VERSION:=5
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 PKG_LICENCE:=GPL-3.0+
 
 include $(INCLUDE_DIR)/package.mk
@@ -23,7 +23,11 @@ define Package/bcp38
 endef
 
 define Package/bcp38/description
- bcp38 implements IETF BCP38 for home routers. See https://tools.ietf.org/html/bcp38.
+ bcp38 implements IETF BCP38 for home routers.
+ See https://tools.ietf.org/html/bcp38.
+
+ This package provides BCP38 for IPv4 only - IPv6 uses source 
+ specific default routes, so no firewall configuration is needed.
 endef
 
 define Package/bcp38/conffiles
index 08e8e20b35ac0636c9d09308deaaa5e25e4877f1..fc785ebe71a5f1b12ae75b5778cdd559370159da 100644 (file)
@@ -17,6 +17,10 @@ config bcp38
 #      There is a dhcp trigger to do this for the netmask of a 
 #      double natted connection needed
 
+#       You can only specify IPv4 addresses here - for IPv6, only source
+#       specific default routes will be installed, which achieves the same
+#       without needing any firewall routes.
+
 #      I will argue that this level of indirection doesn't scale
 #      very well - see how to block china as an example
 #      http://www.okean.com/china.txt
index d42916cf062171f27515543c00ee6b1d76ebb915..ecf84fdf1dd7b852cb91a456672155071689aa9b 100644 (file)
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=luci-app-bcp38
 PKG_VERSION:=2
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 PKG_LICENSE:=Apache-2.0
 LUCI_DIR:=/usr/lib/lua/luci
 
index b0b8f38791dcf0df908309f155c8259c42fb2321..632074a56f4805bbe1463d28af336d967c2e2aff 100644 (file)
@@ -19,7 +19,9 @@ local ifaces = net:get_interfaces()
 m = Map("bcp38", translate("BCP38"),
        translate("This function blocks packets with private address destinations " ..
                "from going out onto the internet as per " ..
-               "<a href=\"http://tools.ietf.org/html/bcp38\">BCP 38</a>."))
+               "<a href=\"http://tools.ietf.org/html/bcp38\">BCP 38</a>. " ..
+               "For IPv6, only source specific default routes are installed, so " ..
+               "no BCP38 firewall routes are needed."))
 
 s = m:section(TypedSection, "bcp38", translate("BCP38 config"))
 s.anonymous = true