Merge pull request #261 from micmac1/master
authormicmac1 <sebastian_ml@gmx.net>
Sat, 3 Feb 2018 19:24:40 +0000 (20:24 +0100)
committerGitHub <noreply@github.com>
Sat, 3 Feb 2018 19:24:40 +0000 (20:24 +0100)
New PR: freeswitch-stable

net/freeswitch-stable/Makefile
net/freeswitch-stable/patches/310-use-system-tiff.patch
net/freeswitch-stable/patches/320-workaround-format-truncation-error-in-mod_cdr_mongodb.patch [new file with mode: 0644]

index 7d752e1a40c8548f99c2f4341be7e234431c974e..f0ca8c05cc409ce36f112b044b5835369e064f4c 100644 (file)
@@ -19,9 +19,10 @@ PKG_HASH:=dbb0f73109171bd381772b247b8ef581f6a176964619082a1fe031b004086f6b
 
 PKG_BUILD_DIR:=$(BUILD_DIR)/$(PRG_NAME)-$(PKG_VERSION)
 
-# configure fails without libjpeg, but it's only needed for mod_spandsp
+# configure in libs/spandsp fails without libjpeg and tiff
 PKG_BUILD_DEPENDS:= \
        libjpeg \
+       tiff \
        perl/host \
        python/host
 
@@ -1169,7 +1170,7 @@ $(eval $(call Package/$(PKG_NAME)/Module,fsv,FSV,This module provides dialplan a
 $(eval $(call Package/$(PKG_NAME)/Module,g723_1,G.723.1 passthrough,G.723.1 codec passthrough.,))
 $(eval $(call Package/$(PKG_NAME)/Module,g729,G.729 passthrough,G.729 codec passthrough.,))
 $(eval $(call Package/$(PKG_NAME)/Module,graylog2,Graylog2 logger,GELF logger for Graylog2 and Logstash.,))
-$(eval $(call Package/$(PKG_NAME)/Module,gsmopen,GSM endpoint,GSMopen is a channel driver that allows an SMS to be sent to and from\nFreeSWITCH as well as incoming and outgoing GSM voice calls.,+gsmlib +libctb +libjpeg +liblzma +libtiff))
+$(eval $(call Package/$(PKG_NAME)/Module,gsmopen,GSM endpoint,GSMopen is a channel driver that allows an SMS to be sent to and from\nFreeSWITCH as well as incoming and outgoing GSM voice calls.,+gsmlib +libctb +libjpeg +libtiff))
 $(eval $(call Package/$(PKG_NAME)/Module,h26x,H.26x passthrough,H.26x video codec passthrough.,))
 $(eval $(call Package/$(PKG_NAME)/Module,hash,Hash,This module provides a key-value in-memory datastore. Usable as a\nlimit backend.,))
 $(eval $(call Package/$(PKG_NAME)/Module,hiredis,Redis client,This module provides a mechanism to use Redis as a datastore.,+libhiredis))
index e7e1ac6c8852444980f8d1e88f4646fa42e67d5b..1fcb02959b6d49edfade5b8d575036007402ec80 100644 (file)
@@ -37,7 +37,7 @@ Date:   Tue Mar 14 17:39:05 2017 -0500
        cd libs/spandsp && sh ./configure.gnu $(MY_DEFAULT_ARGS)
 --- a/configure.ac
 +++ b/configure.ac
-@@ -1984,7 +1984,6 @@ AC_CONFIG_SUBDIRS([libs/libdingaling])
+@@ -1969,7 +1969,6 @@ AC_CONFIG_SUBDIRS([libs/libdingaling])
  AC_CONFIG_SUBDIRS([libs/sofia-sip])
  AC_CONFIG_SUBDIRS([libs/freetdm])
  AC_CONFIG_SUBDIRS([libs/unimrcp])
diff --git a/net/freeswitch-stable/patches/320-workaround-format-truncation-error-in-mod_cdr_mongodb.patch b/net/freeswitch-stable/patches/320-workaround-format-truncation-error-in-mod_cdr_mongodb.patch
new file mode 100644 (file)
index 0000000..2a93821
--- /dev/null
@@ -0,0 +1,29 @@
+--- a/configure.ac
++++ b/configure.ac
+@@ -363,6 +363,16 @@ if test "$ax_cv_c_compiler_vendor" = "gn
+         [ac_cv_gcc_supports_w_no_misleading_indentation=no])])
+   CFLAGS="$saved_CFLAGS"
+   AC_MSG_RESULT($ac_cv_gcc_supports_w_no_misleading_indentation)
++
++  saved_CFLAGS="$CFLAGS"
++  AC_CACHE_CHECK([whether compiler supports -Wno-error=format-truncation],
++    [ac_cv_gcc_supports_w_no_err_format_truncation], [
++      CFLAGS="$CFLAGS -Wno-error=format-truncation"
++      AC_TRY_COMPILE([],[return 0;],
++        [ac_cv_gcc_supports_w_no_err_format_truncation=yes],
++        [ac_cv_gcc_supports_w_no_err_format_truncation=no])])
++  CFLAGS="$saved_CFLAGS"
++  AC_MSG_RESULT($ac_cv_gcc_supports_w_no_err_format_truncation)
+ fi
+ # tweak compiler specific flags
+@@ -402,6 +412,9 @@ elif test "x${ax_cv_c_compiler_vendor}"
+     if test "$ac_cv_gcc_supports_w_no_misleading_indentation" = yes; then
+       APR_ADDTO(SWITCH_AM_CFLAGS, -Wno-misleading-indentation)
+     fi
++    if test "$ac_cv_gcc_supports_w_no_err_format_truncation" = yes; then
++      APR_ADDTO(SWITCH_AM_CFLAGS, -Wno-error=format-truncation)
++    fi
+     if test "${enable_64}" = "yes"; then
+       case "$host" in
+              *darwin*)