libseccomp: add seccomp-syscalls.h to InstallDev
authorJosef Schlehofer <pepe.schlehofer@gmail.com>
Thu, 16 Jan 2020 11:45:15 +0000 (12:45 +0100)
committerJosef Schlehofer <pepe.schlehofer@gmail.com>
Fri, 17 Jan 2020 04:16:45 +0000 (05:16 +0100)
In the version 2.4.2, there was introduced a new header file.
Ship it to InstallDev

Signed-off-by: Josef Schlehofer <pepe.schlehofer@gmail.com>
libs/libseccomp/Makefile

index ecc075a8c27a77977e763b234ab4c14bd5d3a189..f391572952942769b03c3cafcb816f54d650aa5c 100644 (file)
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=libseccomp
 PKG_VERSION:=2.4.2
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 PKG_USE_MIPS16:=0
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
@@ -59,15 +59,10 @@ endef
 
 define Build/InstallDev
        $(INSTALL_DIR) $(1)/usr/include $(1)/usr/lib/pkgconfig
-       $(CP) \
-               $(PKG_INSTALL_DIR)/usr/include/seccomp.h \
-               $(1)/usr/include/
-       $(CP) \
-               $(PKG_INSTALL_DIR)/usr/lib/libseccomp.{a,so*} \
-               $(1)/usr/lib/
-       $(CP) \
-               $(PKG_INSTALL_DIR)/usr/lib/pkgconfig/libseccomp.pc \
-               $(1)/usr/lib/pkgconfig/
+       $(CP) $(PKG_INSTALL_DIR)/usr/include/seccomp.h $(1)/usr/include/
+       $(CP) $(PKG_INSTALL_DIR)/usr/include/seccomp-syscalls.h $(1)/usr/include/
+       $(CP) $(PKG_INSTALL_DIR)/usr/lib/libseccomp.{a,so*} $(1)/usr/lib/
+       $(CP) $(PKG_INSTALL_DIR)/usr/lib/pkgconfig/libseccomp.pc $(1)/usr/lib/pkgconfig/
 endef
 
 define Package/libseccomp/install