gawk: disable mpfr detection
authorTianling Shen <cnsztl@immortalwrt.org>
Thu, 1 Jun 2023 08:05:11 +0000 (16:05 +0800)
committerRosen Penev <rosenp@gmail.com>
Tue, 6 Jun 2023 16:51:12 +0000 (19:51 +0300)
Disable mpfr detection to fix a build error due to (unncessary)
missing dependency:

```
Package gawk is missing dependencies for the following libraries:
libgmp.so.10
libmpfr.so.6
```

Signed-off-by: Tianling Shen <cnsztl@immortalwrt.org>
utils/gawk/Makefile

index a8bd99f5d0b629dd550a4352278b396103b2ac05..42deed8e67b5ae3e6aad798466ad4419d6ca738a 100644 (file)
@@ -6,7 +6,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=gawk
 PKG_VERSION:=5.2.1
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
 PKG_SOURCE_URL:=@GNU/gawk
@@ -29,6 +29,8 @@ define Package/gawk
   DEPENDS:=+libncursesw +libreadline
 endef
 
+CONFIGURE_ARGS+= --disable-mpfr
+
 define Package/gawk/install
        $(INSTALL_DIR) $(1)/usr/bin
        $(CP) $(PKG_INSTALL_DIR)/usr/bin/gawk $(1)/usr/bin/