siit: fix kernel 5.16 compile
authorJohn Thomson <git@johnthomson.fastmail.com.au>
Sat, 22 Oct 2022 06:18:49 +0000 (16:18 +1000)
committerRosen Penev <rosenp@gmail.com>
Tue, 15 Nov 2022 15:24:53 +0000 (07:24 -0800)
siit-1.2/siit.c:1379:9: error: implicit declaration of function
'random_ether_addr' [-Werror=implicit-function-declaration]
 1379 |         random_ether_addr(dev->dev_addr);
      |         ^~~~~~~~~~~~~~~~~

Linux 3.6 renamed random_ether_addr to eth_random_addr [0]
Linux 5.16 removed random_ether_addr [1]

[0]: https://git.kernel.org/pub/scm/linux/kernel/git/torvalds/linux.git/commit/?id=0a4dd594982a321699000218715e28664ec49169
[1]: https://git.kernel.org/pub/scm/linux/kernel/git/torvalds/linux.git/commit/?id=ba530fea8ca1b57ee71d4e62f287a5d7ed92f789

Signed-off-by: John Thomson <git@johnthomson.fastmail.com.au>
net/siit/Makefile
net/siit/src/siit.c

index a890a257bfa8699d0cdc397d0ae2996108ec029f..1e95a584a0a7ea283a0833a260c3934be9b927c1 100644 (file)
@@ -10,7 +10,7 @@ include $(INCLUDE_DIR)/kernel.mk
 
 PKG_NAME:=siit
 PKG_VERSION:=1.2
-PKG_RELEASE:=3
+PKG_RELEASE:=4
 PKG_LICENSE:=GPL-2.0-or-later
 
 include $(INCLUDE_DIR)/package.mk
index 55668353a6f8ff02e62eb1f71ba5b32342f6b66b..16bb02492da6ff3aac0b96c4098537544fcd38d3 100644 (file)
@@ -1376,7 +1376,7 @@ static void
 siit_init(struct net_device *dev)
 {
        ether_setup(dev);    /* assign some of the fields */
-       random_ether_addr(dev->dev_addr);
+       eth_hw_addr_random(dev);
 
        /*
         * Assign device function.