Makefile: Prioritize external dtb if defined
authorMichal Simek <michal.simek@xilinx.com>
Mon, 25 Mar 2019 14:55:16 +0000 (15:55 +0100)
committerTom Rini <trini@konsulko.com>
Sat, 18 May 2019 16:31:58 +0000 (12:31 -0400)
Prioritize external dtb if its passed via EXT_DTB
than the dtb that was built in the tree. With this
patch it appends the specified external dtb to
the u-boot image.

Signed-off-by: Michal Simek <michal.simek@xilinx.com>
Signed-off-by: Siva Durga Prasad Paladugu <siva.durga.paladugu@xilinx.com>
Reviewed-by: Simon Glass <sjg@chromium.org>
Makefile

index 059978bfe683ad000b83fc56096f8b71eb8397bf..6eb08a57247e6f23ec25c377d26fa48af7ebc295 100644 (file)
--- a/Makefile
+++ b/Makefile
@@ -1071,7 +1071,7 @@ ifneq ($(EXT_DTB),)
 u-boot-fit-dtb.bin: u-boot-nodtb.bin $(EXT_DTB)
                $(call if_changed,cat)
 else
-u-boot-fit-dtb.bin: u-boot-nodtb.bin $(FINAL_DTB_CONTAINER)
+u-boot-fit-dtb.bin: u-boot-nodtb.bin fit-dtb.blob $(FINAL_DTB_CONTAINER)
        $(call if_changed,cat)
 endif