Merge pull request #576 from micmac1/bsip-1.0.0
authorJiri Slachta <jiri@slachta.eu>
Fri, 30 Oct 2020 00:00:07 +0000 (01:00 +0100)
committerGitHub <noreply@github.com>
Fri, 30 Oct 2020 00:00:07 +0000 (01:00 +0100)
re+baresip: bump to 1.0.0

libs/re/Makefile
libs/re/patches/005-fix-builds-for-mipsel-targets.patch
libs/re/patches/010-openssl-deprecated.patch [deleted file]
net/baresip/Makefile
net/baresip/patches/002-fix-rem-include.patch
net/baresip/patches/010-openssl-deprecated.patch [deleted file]
net/restund/Makefile

index ff5c7c1751d2de8aeb061e7fb2d21813002632a4..b64d5eb18e89d34536a6f6318487c3603ea9bee4 100644 (file)
@@ -9,12 +9,12 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=re
-PKG_VERSION:=0.6.1
-PKG_RELEASE:=2
+PKG_VERSION:=1.0.0
+PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
-PKG_SOURCE_URL:=http://www.creytiv.com/pub
-PKG_HASH:=cd5bfc79640411803b200c7531e4ba8a230da3806746d3bd2de970da2060fe43
+PKG_SOURCE_URL:=https://codeload.github.com/baresip/re/tar.gz/v$(PKG_VERSION)?
+PKG_HASH:=bf0abfc511b7278462e7d54aaae39e7231b9f35423d5026c8210a322c7c8ef2f
 
 PKG_LICENSE:=BSD-3-Clause
 PKG_LICENSE_FILES:=docs/COPYING
@@ -31,7 +31,7 @@ define Package/libre
   CATEGORY:=Libraries
   DEPENDS:=+libopenssl +zlib
   TITLE:=Generic library for real-time communications with async IO support
-  URL:=http://www.creytiv.com
+  URL:=https://github.com/baresip/re
 endef
 
 # re.mk is used for this and all related packages (rem, restund and baresip).
index 29a03ee9591e755c3c05115feaa0139217032945..d59f85e5f39e2c6262b73d4e4d2fe553f879bbfc 100644 (file)
@@ -1,6 +1,6 @@
 --- a/mk/re.mk
 +++ b/mk/re.mk
-@@ -438,11 +438,6 @@ endif
+@@ -439,11 +439,6 @@ endif
  
  CFLAGS        += -DARCH=\"$(ARCH)\"
  
diff --git a/libs/re/patches/010-openssl-deprecated.patch b/libs/re/patches/010-openssl-deprecated.patch
deleted file mode 100644 (file)
index bff18b9..0000000
+++ /dev/null
@@ -1,54 +0,0 @@
---- a/src/main/openssl.c
-+++ b/src/main/openssl.c
-@@ -103,6 +103,7 @@ static void dynlock_destroy_handler(struct CRYPTO_dynlock_value *l,
- #endif
-+#if OPENSSL_VERSION_NUMBER < 0x10100000L
- #ifdef SIGPIPE
- static void sigpipe_handler(int x)
- {
-@@ -110,10 +111,11 @@ static void sigpipe_handler(int x)
-       (void)signal(SIGPIPE, sigpipe_handler);
- }
- #endif
--
-+#endif
- int openssl_init(void)
- {
-+#if OPENSSL_VERSION_NUMBER < 0x10100000L
- #if defined (HAVE_PTHREAD) && (OPENSSL_VERSION_NUMBER < 0x10100000L)
-       int err, i;
-@@ -151,6 +153,7 @@ int openssl_init(void)
-       SSL_library_init();
-       SSL_load_error_strings();
-+#endif
-       return 0;
- }
-@@ -158,7 +161,9 @@ int openssl_init(void)
- void openssl_close(void)
- {
-+#if OPENSSL_VERSION_NUMBER < 0x10100000L
-       ERR_free_strings();
-+#endif
- #if defined (HAVE_PTHREAD) && (OPENSSL_VERSION_NUMBER < 0x10100000L)
-       lockv = mem_deref(lockv);
- #endif
---- a/src/tls/openssl/tls.c
-+++ b/src/tls/openssl/tls.c
-@@ -291,8 +291,8 @@ int tls_set_selfsigned(struct tls *tls, const char *cn)
-           !X509_set_subject_name(cert, subj))
-               goto out;
--      if (!X509_gmtime_adj(X509_get_notBefore(cert), -3600*24*365) ||
--          !X509_gmtime_adj(X509_get_notAfter(cert),   3600*24*365*10))
-+      if (!X509_gmtime_adj(X509_getm_notBefore(cert), -3600*24*365) ||
-+          !X509_gmtime_adj(X509_getm_notAfter(cert),   3600*24*365*10))
-               goto out;
-       if (!X509_set_pubkey(cert, key))
index 453423ce6b8df690091d430c84399b44170bb9a4..5e047ecdbae37c963dcb645fd0ac2be320ef2cc2 100644 (file)
@@ -9,12 +9,12 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=baresip
-PKG_VERSION:=0.6.4
-PKG_RELEASE:=3
+PKG_VERSION:=1.0.0
+PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
-PKG_SOURCE_URL:=http://www.creytiv.com/pub
-PKG_HASH:=61710bd1bec406ae1faf167c5743bad8eef9ced5152a3943b94d7e1cf9597581
+PKG_SOURCE_URL:=https://codeload.github.com/baresip/baresip/tar.gz/v$(PKG_VERSION)?
+PKG_HASH:=7b008c0a5b4fccfa0a4003f86dc4aaafeaabbdd259ece4757898e9cb5f04fdcf
 
 PKG_LICENSE:=BSD-3-Clause
 PKG_LICENSE_FILES:=docs/COPYING
@@ -58,7 +58,7 @@ define Package/baresip/Default
   SECTION:=net
   CATEGORY:=Network
   SUBMENU:=Telephony
-  URL:=http://www.creytiv.com
+  URL:=https://github.com/baresip/baresip
 endef
 
 define Package/baresip
@@ -67,6 +67,11 @@ $(call Package/baresip/Default)
   DEPENDS:=+libre +librem
   USERID:=$(PKG_NAME)=374:$(PKG_NAME)=374
   MENU:=1
+  FILE_MODES:= \
+         /etc/baresip:baresip:baresip:0750 \
+         /etc/baresip/accounts:baresip:baresip:0640 \
+         /etc/baresip/config:baresip:baresip:0640 \
+         /etc/baresip/contacts:baresip:baresip:0640
 endef
 
 baresip-mod-alsa        := USE_ALSA
@@ -92,17 +97,16 @@ baresip-mod-v4l2        := USE_V4L2
 
 BARESIP_MOD_OPTIONS:= \
        MOD_AUTODETECT= \
-       EXTRA_MODULES="dtmfio" \
        $(foreach m,$(baresip-mods),$(baresip-mod-$(m))=$(if $(CONFIG_PACKAGE_baresip-mod-$(subst _,-,$(m))),1))
 
 MAKE_FLAGS+= \
        CROSS_COMPILE="$(TARGET_CROSS)" \
+       DESTDIR="$(PKG_INSTALL_DIR)" \
        EXTRA_LFLAGS="$(TARGET_LDFLAGS)" \
        LD="$(TARGET_CC)" \
        LIBRE_MK="$(STAGING_DIR)/usr/share/re/re.mk" \
        LIBRE_INC="$(STAGING_DIR)/usr/include/re" \
        LIBRE_SO="$(STAGING_DIR)/usr/lib" \
-       LIBREM_PATH="$(STAGING_DIR)/usr" \
        OS=linux \
        RELEASE=1 \
        SYSROOT="$(shell $(FIND) $(TOOLCHAIN_DIR) -path '*/include/pthread.h' | sed -ne '1s|/include/pthread.h||p')" \
@@ -123,7 +127,7 @@ define Package/baresip/install
        $(INSTALL_DIR) $(1)/etc/baresip
        $(SED) '/^#/!s/^/#/' $(PKG_BUILD_DIR)/docs/examples/accounts
        $(SED) '/^#module_path/s|^#||;s|/local||' $(PKG_BUILD_DIR)/docs/examples/config
-       $(INSTALL_CONF) $(PKG_BUILD_DIR)/docs/examples/{accounts,config,contacts} $(1)/etc/baresip
+       $(INSTALL_DATA) $(PKG_BUILD_DIR)/docs/examples/{accounts,config,contacts} $(1)/etc/baresip
        $(INSTALL_DIR) $(1)/etc/default
        $(INSTALL_CONF) ./files/baresip.default $(1)/etc/default/baresip
        $(INSTALL_DIR) $(1)/etc/init.d
@@ -138,17 +142,6 @@ define Package/baresip/conffiles
 /etc/init.d/baresip
 endef
 
-define Package/baresip/postinst
-#!/bin/sh
-if [ -z "$${IPKG_INSTROOT}" ]; then
-  chown $(PKG_NAME):$(PKG_NAME) \
-    /etc/baresip/accounts \
-    /etc/baresip/config \
-    /etc/baresip/contacts
-fi
-exit 0
-endef
-
 ##################
 # bareSIP modules
 # 1. Name
@@ -189,7 +182,6 @@ $(eval $(call BuildPlugin,cons,UDP/TCP console UI driver,cons,))
 $(eval $(call BuildPlugin,ctrl_tcp,TCP control interface,ctrl_tcp,))
 $(eval $(call BuildPlugin,debug_cmd,Debug commands,debug_cmd,))
 $(eval $(call BuildPlugin,dtls_srtp,DTLS-SRTP end-to-end encryption,dtls_srtp,))
-$(eval $(call BuildPlugin,dtmfio,DTMF input/output,dtmfio,))
 $(eval $(call BuildPlugin,echo,Echo server module,echo,))
 $(eval $(call BuildPlugin,evdev,Linux input driver,evdev,))
 $(eval $(call BuildPlugin,fakevideo,Fake video input/output driver,fakevideo,))
index e4ecda0aaa785386f8294451811c8b57ae3c14d3..de530b9e51011299b14fac1b76bf9180728b75aa 100644 (file)
@@ -1,16 +1,53 @@
 --- a/Makefile
 +++ b/Makefile
-@@ -45,11 +45,11 @@ endif
+@@ -44,26 +44,15 @@ endif
+ include $(LIBRE_MK)
+ include mk/modules.mk
  
- CFLAGS    += -I. -Iinclude -I$(LIBRE_INC) -I$(SYSROOT)/include
- CFLAGS    += -I$(LIBREM_PATH)/include
+-ifndef LIBREM_PATH
+-LIBREM_PATH   := $(shell [ -d ../rem ] && echo "../rem")
+-endif
+-
+-
+ CFLAGS    += -I. -Iinclude -I$(LIBRE_INC)
+-ifneq ($(LIBREM_PATH),)
+-CFLAGS    += -I$(LIBREM_PATH)/include
+-endif
 -CFLAGS    += -I$(SYSROOT)/local/include/rem -I$(SYSROOT)/include/rem
-+CFLAGS    += -I$(SYSROOT)/local/include/rem -I$(SYSROOT_ALT)/include/rem
++CFLAGS    += -I$(SYSROOT_ALT)/include/rem
+ ifneq ($(SYSROOT_LOCAL),)
+ CFLAGS    += -I$(SYSROOT_LOCAL)/include/rem
+ endif
  
  CXXFLAGS  += -I. -Iinclude -I$(LIBRE_INC)
- CXXFLAGS  += -I$(LIBREM_PATH)/include
+-ifneq ($(LIBREM_PATH),)
+-CXXFLAGS  += -I$(LIBREM_PATH)/include
+-endif
 -CXXFLAGS  += -I$(SYSROOT)/local/include/rem -I$(SYSROOT)/include/rem
-+CXXFLAGS  += -I$(SYSROOT)/local/include/rem -I$(SYSROOT_ALT)/include/rem
- CXXFLAGS  += $(EXTRA_CXXFLAGS)
++CXXFLAGS  += -I$(SYSROOT_ALT)/include/rem
+ ifneq ($(SYSROOT_LOCAL),)
+ CXXFLAGS  += -I$(SYSROOT_LOCAL)/include/rem
+ endif
+@@ -73,10 +62,6 @@ CXXFLAGS  += $(EXTRA_CXXFLAGS)
  # XXX: common for C/C++
+ CPPFLAGS += -DHAVE_INTTYPES_H
+-ifneq ($(LIBREM_PATH),)
+-CLANG_OPTIONS  += -I$(LIBREM_PATH)/include
+-endif
+-
+ ifeq ($(OS),win32)
+ STATIC    := yes
+ endif
+@@ -144,10 +129,6 @@ LIB_OBJS  := $(OBJS) $(MOD_OBJS)
+ TEST_OBJS := $(patsubst %.c,$(BUILD)/test/%.o,$(filter %.c,$(TEST_SRCS)))
+ TEST_OBJS += $(patsubst %.cpp,$(BUILD)/test/%.o,$(filter %.cpp,$(TEST_SRCS)))
+-ifneq ($(LIBREM_PATH),)
+-LIBS  += -L$(LIBREM_PATH)
+-endif
+-
+ # Static build: include module linker-flags in binary
+ ifneq ($(STATIC),)
+ LIBS      += $(MOD_LFLAGS)
diff --git a/net/baresip/patches/010-openssl-deprecated.patch b/net/baresip/patches/010-openssl-deprecated.patch
deleted file mode 100644 (file)
index 4e691bc..0000000
+++ /dev/null
@@ -1,11 +0,0 @@
---- a/modules/debug_cmd/debug_cmd.c
-+++ b/modules/debug_cmd/debug_cmd.c
-@@ -56,7 +56,7 @@ static int print_system_info(struct re_printf *pf, void *arg)
- #ifdef USE_OPENSSL
-       err |= re_hprintf(pf, " OpenSSL:  %s\n",
--                        SSLeay_version(SSLEAY_VERSION));
-+                        OpenSSL_version(OPENSSL_VERSION));
- #endif
-       return err;
index 7a0ab63b2444f8c0c4f67b6b91f97b413b789fc1..fb30da6dafc742591f697d07cd3064992d393592 100644 (file)
@@ -10,7 +10,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=restund
 PKG_VERSION:=0.4.12
-PKG_RELEASE:=7
+PKG_RELEASE:=8
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=http://www.creytiv.com/pub
@@ -76,7 +76,7 @@ define Package/restund/install
                $(PKG_INSTALL_DIR)/usr/lib/restund/modules/turn.so \
                $(1)/usr/lib/restund/modules
        $(INSTALL_DIR) $(1)/etc
-       $(INSTALL_CONF) $(PKG_BUILD_DIR)/etc/restund.conf $(1)/etc
+       $(INSTALL_DATA) $(PKG_BUILD_DIR)/etc/restund.conf $(1)/etc
        $(SED) \
                's|^\(module_path\)\([ \t]\+\).*$$$$|\1\2/usr/lib/restund/modules|g' \
                $(1)/etc/restund.conf
@@ -92,14 +92,6 @@ define Package/restund/conffiles
 /etc/restund.conf
 endef
 
-define Package/restund/postinst
-#!/bin/sh
-if [ -z "$${IPKG_INSTROOT}" ]; then
-  chown $(PKG_NAME):$(PKG_NAME) /etc/restund.conf
-fi
-exit 0
-endef
-
 #
 # 1. Name
 # 2. Title