expat: small makefile fixes 273/head
authorMichael Heimpold <mhei@heimpold.de>
Wed, 3 Sep 2014 21:09:04 +0000 (23:09 +0200)
committerMichael Heimpold <mhei@heimpold.de>
Wed, 3 Sep 2014 21:09:04 +0000 (23:09 +0200)
- fix licensing file list
- install pkgconfig file
- drop explicite call to Build/Compile
- use PKG_INSTALL

Signed-off-by: Michael Heimpold <mhei@heimpold.de>
libs/expat/Makefile

index a8ba8b35e9b573cc909e8993bd467c17c39f8e6a..dee99e0c77ed13731a48d9bd798a9cea372c99c7 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2006 OpenWrt.org
+# Copyright (C) 2006-2014 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=expat
 PKG_VERSION:=2.1.0
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_MD5SUM:=dd7dab7a5fea97d2a6a43f511449b7cd
@@ -17,11 +17,12 @@ PKG_SOURCE_URL:=@SF/expat
 PKG_MAINTAINER:=Steven Barth <cyrus@openwrt.org>
 
 PKG_LICENSE:=MIT
-PACKAGE_LICENSE_FILES:=COPYING
+PKG_LICENSE_FILES:=COPYING
 
 PKG_FIXUP:=autoreconf
 PKG_REMOVE_FILES:=conftools/libtool.m4
 
+PKG_INSTALL:=1
 PKG_BUILD_PARALLEL:=1
 
 include $(INCLUDE_DIR)/host-build.mk
@@ -38,17 +39,12 @@ define Package/libexpat/description
  A fast, non-validating, stream-oriented XML parsing library.
 endef
 
-
 TARGET_CFLAGS += $(FPIC)
 
 CONFIGURE_ARGS += \
        --enable-shared \
        --enable-static
 
-define Build/Compile
-       +$(MAKE) $(PKG_JOBS) -C $(PKG_BUILD_DIR) DESTDIR="$(PKG_INSTALL_DIR)" install
-endef
-
 define Host/Install
        $(MAKE) -C $(HOST_BUILD_DIR) install
 endef
@@ -56,13 +52,17 @@ endef
 define Build/InstallDev
        $(INSTALL_DIR) $(1)/usr/include
        $(CP) $(PKG_INSTALL_DIR)/usr/include/expat{,_external}.h $(1)/usr/include/
+
+       $(INSTALL_DIR) $(1)/usr/lib/pkgconfig
+       $(INSTALL_DATA) $(PKG_INSTALL_DIR)/usr/lib/pkgconfig/expat.pc $(1)/usr/lib/pkgconfig/
+
        $(INSTALL_DIR) $(1)/usr/lib
        $(CP) $(PKG_INSTALL_DIR)/usr/lib/libexpat.{a,so*} $(1)/usr/lib/
 endef
 
 define Package/libexpat/install
        $(INSTALL_DIR) $(1)/usr/lib
-       $(CP) $(PKG_INSTALL_DIR)/usr/lib/libexpat.so.* $(1)/usr/lib/
+       $(CP) $(PKG_INSTALL_DIR)/usr/lib/libexpat.so* $(1)/usr/lib/
 endef
 
 $(eval $(call HostBuild))