python,python3: add dependency on CONFIG_PACKAGE_ symbols for setuptools & pip 4538/head
authorAlexandru Ardelean <ardeleanalex@gmail.com>
Mon, 3 Jul 2017 07:46:59 +0000 (10:46 +0300)
committerAlexandru Ardelean <ardeleanalex@gmail.com>
Mon, 3 Jul 2017 13:11:57 +0000 (16:11 +0300)
If you build python/python3 and later decide to build
python(3)-setuptools and/or python(3)-pip, the build won't
re-run without adding `CONFIG_PACKAGE_python(3)-setuptools`
and `CONFIG_PACKAGE_python(3)-pip`.

Seems to resolve issue:
https://github.com/openwrt/packages/issues/4529

Signed-off-by: Alexandru Ardelean <ardeleanalex@gmail.com>
lang/python/python/Makefile
lang/python/python3/Makefile

index 77652bd1f658acab001bec4702cdff5294a350bd..d4c657b4f2e601fa469eef33b03e5e5d42a8be07 100644 (file)
@@ -35,6 +35,8 @@ HOST_BUILD_PARALLEL:=1
 PKG_BUILD_DIR:=$(BUILD_DIR)/Python-$(PKG_VERSION)
 HOST_BUILD_DIR:=$(BUILD_DIR_HOST)/Python-$(PKG_VERSION)
 
+PKG_CONFIG_DEPENDS:=CONFIG_PACKAGE_python-setuptools CONFIG_PACKAGE_python-pip
+
 PKG_BUILD_DEPENDS:=python/host
 HOST_BUILD_DEPENDS:=bzip2/host expat/host
 
index 614dc2c88073172bf3f93ff281f37f7849fc33b4..02c1031932c186a4e68bef9e4657741222a8ad6d 100644 (file)
@@ -38,6 +38,8 @@ HOST_BUILD_PARALLEL:=1
 PKG_BUILD_DIR:=$(BUILD_DIR)/Python-$(PKG_VERSION)
 HOST_BUILD_DIR:=$(BUILD_DIR_HOST)/Python-$(PKG_VERSION)
 
+PKG_CONFIG_DEPENDS:=CONFIG_PACKAGE_python3-setuptools CONFIG_PACKAGE_python3-pip
+
 PKG_BUILD_DEPENDS:=python3/host
 HOST_BUILD_DEPENDS:=bzip2/host expat/host libffi/host