load of ide modules at boot (closes: #439)
authorNicolas Thill <nico@openwrt.org>
Sat, 1 Apr 2006 14:51:48 +0000 (14:51 +0000)
committerNicolas Thill <nico@openwrt.org>
Sat, 1 Apr 2006 14:51:48 +0000 (14:51 +0000)
SVN-Revision: 3565

openwrt/target/linux/Config.in
openwrt/target/linux/linux-2.4/Makefile

index d9eb58a40718026b0bec133f84265fec5a81b355..942d4da15e39e5b05b00c1d4f24d2e0c3cd2d5a4 100644 (file)
@@ -291,6 +291,12 @@ config BR2_PACKAGE_KMOD_IDE
        help
          Kernel modules for IDE support
          useful for usb mass storage devices (e.g. on WL-HDD)
+         
+         Includes:
+           - ide-core
+           - ide-detect
+           - ide-disk
+           - pdc202xx_old
 
 config BR2_PACKAGE_KMOD_VFAT
        tristate "VFAT filesystem support"
index 6400dbc20233a800e80333338855dc8dbdfe0964..83b30c531c7e570ad3f31945fad960a5ea3c52a2 100644 (file)
@@ -172,7 +172,7 @@ $(eval $(call KMOD_template,USB_ACM,usb-acm,\
 $(eval $(call KMOD_template,IDE,ide,\
        $(MODULES_DIR)/kernel/drivers/ide/*.o \
        $(MODULES_DIR)/kernel/drivers/ide/*/*.o \
-,CONFIG_IDE))
+,CONFIG_IDE,,20,pdc202xx_old ide-core ide-detect ide-disk))
 $(eval $(call KMOD_template,LOOP,loop,\
     $(MODULES_DIR)/kernel/drivers/block/loop.o \
 ,CONFIG_BLK_DEV_LOOP,,20,loop))