libshout: Fix build/configure errors
authorTed Hess <thess@kitschensync.net>
Sat, 28 Nov 2015 20:07:16 +0000 (15:07 -0500)
committerTed Hess <thess@kitschensync.net>
Sat, 28 Nov 2015 20:09:02 +0000 (15:09 -0500)
Signed-off-by: Ted Hess <thess@kitschensync.net>
libs/libshout/Makefile

index 3a67c922ece0c2d468f744700916214cffdf9c15..4559ddf89948e874d32c130d972eff911ab31ef5 100644 (file)
@@ -60,8 +60,8 @@ CONFIGURE_ARGS += \
        --enable-shared \
        --enable-static
 
-ifeq ($(BUILD_VARIANT),full)
-  CONFIGURE_ARGS += --with-theora=no --with-speex=no
+ifeq ($(BUILD_VARIANT),nospeex)
+  CONFIGURE_ARGS += --disable-theora --disable-speex
 endif
 
 CONFIGURE_VARS += \
@@ -84,7 +84,7 @@ define Package/libshout/install
        $(INSTALL_DIR) $(1)/usr/lib
        $(CP) $(PKG_INSTALL_DIR)/usr/lib/libshout.so.* $(1)/usr/lib/
 endef
-Package/libshout-full/install=Package/libshout/install
+Package/libshout-full/install=$(Package/libshout/install)
 
 $(eval $(call BuildPackage,libshout))
 $(eval $(call BuildPackage,libshout-full))