php7-pecl-krb5: migrate package to php8-pecl-krb5
authorMichael Heimpold <mhei@heimpold.de>
Thu, 9 Dec 2021 07:11:10 +0000 (08:11 +0100)
committerMichael Heimpold <mhei@heimpold.de>
Thu, 9 Dec 2021 20:57:44 +0000 (21:57 +0100)
Signed-off-by: Michael Heimpold <mhei@heimpold.de>
lang/php7-pecl-krb5/Makefile [deleted file]
lang/php8-pecl-krb5/Makefile [new file with mode: 0644]

diff --git a/lang/php7-pecl-krb5/Makefile b/lang/php7-pecl-krb5/Makefile
deleted file mode 100644 (file)
index 1fe42ea..0000000
+++ /dev/null
@@ -1,37 +0,0 @@
-#
-# This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
-#
-
-include $(TOPDIR)/rules.mk
-
-PECL_NAME:=krb5
-PECL_LONGNAME:=Bindings for the Kerberos library
-
-PKG_VERSION:=1.1.4
-PKG_RELEASE:=1
-PKG_HASH:=8aba35bb9f2892be9092e8717d3e13604a817cdfb478dbc3855a226abc6c5979
-
-PKG_NAME:=php7-pecl-krb5
-PKG_SOURCE:=$(PECL_NAME)-$(PKG_VERSION).tgz
-PKG_SOURCE_URL:=http://pecl.php.net/get/
-
-PKG_MAINTAINER:=W. Michael Petullo <mike@flyn.org>
-
-PKG_LICENSE:=MIT
-PKG_LICENSE_FILES:=LICENSE
-
-PKG_BUILD_DEPENDS:=php7
-PKG_BUILD_DIR:=$(BUILD_DIR)/pecl-php7/$(PECL_NAME)-$(PKG_VERSION)
-PKG_BUILD_PARALLEL:=1
-
-include $(INCLUDE_DIR)/package.mk
-include $(INCLUDE_DIR)/nls.mk
-include ../php7/pecl.mk
-
-CONFIGURE_ARGS+= \
-       --with-krb5=shared,"$(STAGING_DIR)/usr" \
-       --with-krb5config=$(STAGING_DIR)/usr/bin/krb5-config
-
-$(eval $(call PHP7PECLPackage,krb5,$(PECL_LONGNAME),+krb5-libs,30))
-$(eval $(call BuildPackage,$(PKG_NAME)))
diff --git a/lang/php8-pecl-krb5/Makefile b/lang/php8-pecl-krb5/Makefile
new file mode 100644 (file)
index 0000000..a331857
--- /dev/null
@@ -0,0 +1,37 @@
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+include $(TOPDIR)/rules.mk
+
+PECL_NAME:=krb5
+PECL_LONGNAME:=Bindings for the Kerberos library
+
+PKG_VERSION:=1.1.4
+PKG_RELEASE:=1
+PKG_HASH:=8aba35bb9f2892be9092e8717d3e13604a817cdfb478dbc3855a226abc6c5979
+
+PKG_NAME:=php8-pecl-krb5
+PKG_SOURCE:=$(PECL_NAME)-$(PKG_VERSION).tgz
+PKG_SOURCE_URL:=http://pecl.php.net/get/
+
+PKG_MAINTAINER:=W. Michael Petullo <mike@flyn.org>
+
+PKG_LICENSE:=MIT
+PKG_LICENSE_FILES:=LICENSE
+
+PKG_BUILD_DEPENDS:=php8
+PKG_BUILD_DIR:=$(BUILD_DIR)/pecl-php8/$(PECL_NAME)-$(PKG_VERSION)
+PKG_BUILD_PARALLEL:=1
+
+include $(INCLUDE_DIR)/package.mk
+include $(INCLUDE_DIR)/nls.mk
+include ../php8/pecl.mk
+
+CONFIGURE_ARGS+= \
+       --with-krb5=shared,"$(STAGING_DIR)/usr" \
+       --with-krb5config=$(STAGING_DIR)/usr/bin/krb5-config
+
+$(eval $(call PHP8PECLPackage,krb5,$(PECL_LONGNAME),+krb5-libs,30))
+$(eval $(call BuildPackage,$(PKG_NAME)))