glib2: bump version to 2.34.3
authorFlorian Fainelli <florian@openwrt.org>
Tue, 4 Dec 2012 16:20:58 +0000 (16:20 +0000)
committerFlorian Fainelli <florian@openwrt.org>
Tue, 4 Dec 2012 16:20:58 +0000 (16:20 +0000)
dropped all patches, they are no longer necessary.

Signed-off-by: Jonh Wendell <jonh.wendell@oiwifi.com.br>
Signed-off-by: Florian Fainelli <florian@openwrt.org>
SVN-Revision: 34490

libs/glib2/Makefile
libs/glib2/patches/001-automake-compat.patch [deleted file]
libs/glib2/patches/002-missing-gthread-include.patch [deleted file]
libs/glib2/patches/010-move-iconv-to-libs.patch [deleted file]
libs/glib2/patches/020-no-docs-tests-translations.patch [deleted file]

index 21a74260cb56f857c818b414899925a5ab3f882d..707bcde749796475d646638b3648043fbf552e01 100644 (file)
@@ -8,17 +8,16 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=glib2
-PKG_VERSION:=2.26.1
-PKG_RELEASE:=3
+PKG_VERSION:=2.34.3
+PKG_RELEASE:=1
 
-PKG_SOURCE:=glib-$(PKG_VERSION).tar.bz2
+PKG_SOURCE:=glib-$(PKG_VERSION).tar.xz
 PKG_BUILD_DIR:=$(BUILD_DIR)/glib-$(PKG_VERSION)
-PKG_SOURCE_URL:=@GNOME/glib/2.26
-PKG_MD5SUM:=17535accceef55bcb17a74d73f9c2aef
+PKG_SOURCE_URL:=@GNOME/glib/2.34
+PKG_MD5SUM:=a4ca31e258273c3761e3de2edd607661
 
-PKG_FIXUP:=autoreconf
-PKG_BUILD_DEPENDS:=glib2/host libpthread zlib libintl
-HOST_BUILD_DEPENDS:=gettext/host libiconv/host
+PKG_BUILD_DEPENDS:=glib2/host libpthread zlib libintl libffi
+HOST_BUILD_DEPENDS:=libintl/host libiconv/host libffi/host
 PKG_INSTALL:=1
 
 HOST_BUILD_DIR:=$(BUILD_DIR_HOST)/glib-$(PKG_VERSION)
@@ -30,7 +29,7 @@ include $(INCLUDE_DIR)/nls.mk
 define Package/glib2
   SECTION:=libs
   CATEGORY:=Libraries
-  DEPENDS:=$(ICONV_DEPENDS) $(INTL_DEPENDS) +zlib +libpthread
+  DEPENDS:=$(ICONV_DEPENDS) $(INTL_DEPENDS) +zlib +libpthread +libffi
   TITLE:=glib 2.0
   URL:=http://www.gtk.org/
 endef
diff --git a/libs/glib2/patches/001-automake-compat.patch b/libs/glib2/patches/001-automake-compat.patch
deleted file mode 100644 (file)
index aa6833a..0000000
+++ /dev/null
@@ -1,12 +0,0 @@
---- a/configure.ac
-+++ b/configure.ac
-@@ -2741,7 +2741,8 @@ dnl **************************
- dnl *** Checks for gtk-doc ***
- dnl **************************
--GTK_DOC_CHECK([1.15])
-+AM_CONDITIONAL([ENABLE_GTK_DOC], [false])
-+AM_CONDITIONAL([GTK_DOC_USE_LIBTOOL], [false])
- AC_ARG_ENABLE(man,
-               [AC_HELP_STRING([--enable-man],
diff --git a/libs/glib2/patches/002-missing-gthread-include.patch b/libs/glib2/patches/002-missing-gthread-include.patch
deleted file mode 100644 (file)
index 8def409..0000000
+++ /dev/null
@@ -1,10 +0,0 @@
---- a/glib/gatomic.c
-+++ b/glib/gatomic.c
-@@ -881,6 +881,7 @@ g_atomic_pointer_compare_and_exchange (v
- #endif /* DEFINE_WITH_WIN32_INTERLOCKED */
- #ifdef DEFINE_WITH_MUTEXES
-+#include "gthread.h"
- /* We have to use the slow, but safe locking method */
- static GMutex *g_atomic_mutex; 
diff --git a/libs/glib2/patches/010-move-iconv-to-libs.patch b/libs/glib2/patches/010-move-iconv-to-libs.patch
deleted file mode 100644 (file)
index 89b3fea..0000000
+++ /dev/null
@@ -1,10 +0,0 @@
---- a/glib-2.0.pc.in
-+++ b/glib-2.0.pc.in
-@@ -10,6 +10,5 @@ glib_mkenums=glib-mkenums
- Name: GLib
- Description: C Utility Library
- Version: @VERSION@
--Libs: -L${libdir} -lglib-2.0 @INTLLIBS@
--Libs.private: @ICONV_LIBS@
-+Libs: -L${libdir} -lglib-2.0 @INTLLIBS@ @ICONV_LIBS@
- Cflags: -I${includedir}/glib-2.0 -I${libdir}/glib-2.0/include @GLIB_EXTRA_CFLAGS@
diff --git a/libs/glib2/patches/020-no-docs-tests-translations.patch b/libs/glib2/patches/020-no-docs-tests-translations.patch
deleted file mode 100644 (file)
index 0460640..0000000
+++ /dev/null
@@ -1,81 +0,0 @@
---- a/configure.ac
-+++ b/configure.ac
-@@ -3737,18 +3737,6 @@ gio/fen/Makefile
- gio/fam/Makefile
- gio/win32/Makefile
- gio/tests/Makefile
--po/Makefile.in
--docs/Makefile
--docs/reference/Makefile
--docs/reference/glib/Makefile
--docs/reference/glib/version.xml
--docs/reference/gobject/Makefile
--docs/reference/gobject/version.xml
--docs/reference/gio/Makefile
--docs/reference/gio/version.xml
--tests/Makefile
--tests/gobject/Makefile
--tests/refcount/Makefile
- m4macros/Makefile
- ])
---- a/gio/Makefile.am
-+++ b/gio/Makefile.am
-@@ -264,8 +264,6 @@ giowin32include_HEADERS = \
- endif
--SUBDIRS += tests
--
- libgio_2_0_la_SOURCES =               \
-       gappinfo.c              \
-       gasynchelper.c          \
---- a/glib/Makefile.am
-+++ b/glib/Makefile.am
-@@ -48,9 +48,9 @@ else
- gatomic_c = gatomic.c
- endif
--SUBDIRS = libcharset $(PRINTF_SUBDIR) $(MAYBE_PCRE) update-pcre . tests
-+SUBDIRS = libcharset $(PRINTF_SUBDIR) $(MAYBE_PCRE) update-pcre .
--DIST_SUBDIRS = libcharset gnulib pcre update-pcre tests
-+DIST_SUBDIRS = libcharset gnulib pcre update-pcre
- AM_CPPFLAGS =                                 \
-       $(glib_INCLUDES)                \
---- a/gobject/Makefile.am
-+++ b/gobject/Makefile.am
-@@ -4,7 +4,7 @@
- ## Process this file with automake to produce Makefile.in
- include $(top_srcdir)/Makefile.decl
--SUBDIRS = . tests
-+SUBDIRS = .
- CLEANFILES=
---- a/gthread/Makefile.am
-+++ b/gthread/Makefile.am
-@@ -1,8 +1,8 @@
- ## Process this file with automake to produce Makefile.in
- include $(top_srcdir)/Makefile.decl
--SUBDIRS = . tests
--DIST_SUBDIRS = tests
-+SUBDIRS = .
-+DIST_SUBDIRS = 
- AM_CPPFLAGS =                                 \
-       $(glib_INCLUDES)                \
---- a/Makefile.am
-+++ b/Makefile.am
-@@ -3,7 +3,7 @@ include $(top_srcdir)/Makefile.decl
- ACLOCAL_AMFLAGS = -I m4macros ${ACLOCAL_FLAGS}
--SUBDIRS = . m4macros glib gmodule gthread gobject gio tests po docs
-+SUBDIRS = . m4macros glib gmodule gthread gobject gio
- DIST_SUBDIRS = $(SUBDIRS) build
- bin_SCRIPTS = glib-gettextize