sstp-client: fix musl compatibility 1468/head
authorJo-Philipp Wich <jow@openwrt.org>
Thu, 25 Jun 2015 14:30:32 +0000 (16:30 +0200)
committerJo-Philipp Wich <jow@openwrt.org>
Thu, 25 Jun 2015 14:31:58 +0000 (16:31 +0200)
 - Ship a `net/ppp_defs.h` replacement header since musl does not provide one
   but `pppd/pppd.h` provided by pppd is needing it.
 - Add missing `sys/types.h` includes

Signed-off-by: Jo-Philipp Wich <jow@openwrt.org>
net/sstp-client/Makefile
net/sstp-client/patches/100-musl-compat.patch [new file with mode: 0644]

index 6e6526982105b4a01793ab8c33104f8fd29ea455..baea8d2be27bb3c70c8e9123645516e24ddfe77b 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2006-2014 OpenWrt.org
+# Copyright (C) 2006-2015 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -18,6 +18,8 @@ PKG_LICENSE=GPLv2
 
 include $(INCLUDE_DIR)/package.mk
 
+TARGET_CPPFLAGS += -I$(PKG_BUILD_DIR)/include
+
 define Package/sstp-client
   SECTION:=net
   CATEGORY:=Network
diff --git a/net/sstp-client/patches/100-musl-compat.patch b/net/sstp-client/patches/100-musl-compat.patch
new file mode 100644 (file)
index 0000000..d19b2fa
--- /dev/null
@@ -0,0 +1,33 @@
+--- /dev/null
++++ b/include/net/ppp_defs.h
+@@ -0,0 +1,10 @@
++#ifndef _NET_PPP_DEFS_H
++#define _NET_PPP_DEFS_H 1
++
++#define __need_time_t
++#include <time.h>
++
++#include <asm/types.h>
++#include <linux/ppp_defs.h>
++
++#endif /* net/ppp_defs.h */
+--- a/src/libsstp-log/sstp-log-syslog.c
++++ b/src/libsstp-log/sstp-log-syslog.c
+@@ -32,6 +32,7 @@
+ #include <sys/uio.h>
+ #include <sys/un.h>
+ #include <sys/socket.h>
++#include <sys/types.h>
+ #include <unistd.h>
+ #include <sstp-common.h>
+--- a/src/libsstp-log/sstp-log-std.c
++++ b/src/libsstp-log/sstp-log-std.c
+@@ -25,6 +25,7 @@
+ #include <stdio.h>
+ #include <stdint.h>
+ #include <string.h>
++#include <sys/types.h>
+ #include <sys/uio.h>
+ #include <unistd.h>