Merge pull request #15406 from pprindeville/strongswan-add-chacha20poly1305
authorPhilip Prindeville <philipp@redfish-solutions.com>
Wed, 14 Apr 2021 03:48:04 +0000 (21:48 -0600)
committerGitHub <noreply@github.com>
Wed, 14 Apr 2021 03:48:04 +0000 (21:48 -0600)
strongswan: handle chacha20poly1305 as AEAD

21 files changed:
devel/meson/Makefile
devel/meson/patches/010-options.patch [deleted file]
lang/ruby/Makefile
lang/vala/Makefile
libs/glib2/Makefile
libs/glib2/patches/001-no-libelf.patch [deleted file]
libs/glib2/patches/002-no-tests.patch [deleted file]
libs/glib2/patches/004-no-distutils.patch
libs/glib2/patches/005-uclibc.patch
libs/glib2/patches/006-c99.patch
libs/vips/Makefile
net/bonding/Makefile
net/bonding/files/lib/netifd/proto/bonding.sh
net/hcxdumptool/Makefile
net/hcxdumptool/patches/010-openssl.patch [new file with mode: 0644]
net/hcxdumptool/patches/020-stdout.patch [new file with mode: 0644]
net/hcxtools/Makefile
net/hcxtools/patches/010-openssl.patch [new file with mode: 0644]
net/ooniprobe/Makefile
net/squid/Makefile
utils/collectd/Makefile

index 9142b1f8793a253888089559bf95b5dd2a113e34..64b31436bebf54afd9621174d355127283bd7a4f 100644 (file)
@@ -1,11 +1,11 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=meson
-PKG_VERSION:=0.57.1
+PKG_VERSION:=0.57.2
 PKG_RELEASE:=$(AUTORELEASE)
 
 PYPI_NAME:=meson
-PKG_HASH:=72e1c782ba9bda204f4a1ed57f98d027d7b6eb9414c723eebbd6ec7f1955c8a6
+PKG_HASH:=3a83e7b1c5de94fa991ec34d9b198d94f38ed699d3524cb0fdf3b99fd23d4cc5
 
 PKG_MAINTAINER:=Andre Heider <a.heider@gmail.com>
 PKG_LICENSE:=Apache-2.0
diff --git a/devel/meson/patches/010-options.patch b/devel/meson/patches/010-options.patch
deleted file mode 100644 (file)
index c96dabb..0000000
+++ /dev/null
@@ -1,31 +0,0 @@
-From 5277eb2232387312c64c79e5622a61cefc26dec0 Mon Sep 17 00:00:00 2001
-From: Dylan Baker <dylan@pnwbakers.com>
-Date: Mon, 5 Apr 2021 13:05:45 -0700
-Subject: [PATCH] coredata: Check for built-in options as host options
-
-These options often don't exist for the build machine, as they're
-generally invalid (ie, prefix, libdir, etc). So we should always check
-for their existance as host optiuons, since all we want to know in this
-case is if the option is yeilding (valid per-subproject), and build/vs
-host doesn't matter in that cases:
-
-Fixes #8613
----
- mesonbuild/coredata.py | 6 +++++-
- 1 file changed, 5 insertions(+), 1 deletion(-)
-
---- a/mesonbuild/coredata.py
-+++ b/mesonbuild/coredata.py
-@@ -754,7 +754,11 @@ class CoreData:
-             if k.subproject and k.subproject != subproject:
-                 continue
-             # If the option is a builtin and is yielding then it's not allowed per subproject.
--            if subproject and k.is_builtin() and self.options[k.as_root()].yielding:
-+            #
-+            # Always test this using the HOST machine, as many builtin options
-+            # are not valid for the BUILD machine, but the yielding value does
-+            # not differ between them even when they are valid for both.
-+            if subproject and k.is_builtin() and self.options[k.evolve(subproject='', machine=MachineChoice.HOST)].yielding:
-                 continue
-             # Skip base, compiler, and backend options, they are handled when
-             # adding languages and setting backend.
index 937ff76a23e5ebed19426ae3346b159bdea3503e..47413eead152bd8b6cfbd1c287c8a6dcbfab1ff9 100644 (file)
@@ -11,7 +11,7 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=ruby
-PKG_VERSION:=3.0.0
+PKG_VERSION:=3.0.1
 PKG_RELEASE:=1
 
 # First two numbes
@@ -19,7 +19,7 @@ PKG_ABI_VERSION:=$(subst $(space),.,$(wordlist 1, 2, $(subst .,$(space),$(PKG_VE
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
 PKG_SOURCE_URL:=https://cache.ruby-lang.org/pub/ruby/$(PKG_ABI_VERSION)/
-PKG_HASH:=68bfaeef027b6ccd0032504a68ae69721a70e97d921ff328c0c8836c798f6cb1
+PKG_HASH:=d06bccd382d03724b69f674bc46cd6957ba08ed07522694ce44b9e8ffc9c48e2
 PKG_MAINTAINER:=Luiz Angelo Daros de Luca <luizluca@gmail.com>
 PKG_LICENSE:=BSD-2-Clause
 PKG_LICENSE_FILES:=COPYING
index 3d7d4776d6714891baacd059df850ab65d88a3ae..c71921a39f4f368b7e5ee041bbf52b69caa3973e 100644 (file)
@@ -8,12 +8,12 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=vala
-PKG_VERSION:=0.50.2
-PKG_RELEASE:=1
+PKG_VERSION:=0.52.1
+PKG_RELEASE:=$(AUTORELEASE)
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
-PKG_SOURCE_URL:=@GNOME/vala/0.50
-PKG_HASH:=2c0d5dc6d65d070f724063075424c403765ab7935c9e6fbcb84981b94d07ceda
+PKG_SOURCE_URL:=@GNOME/vala/0.52
+PKG_HASH:=17a083ce2405f967efa7d92bce82c49e5f65af334513e3d087a6b4435ed6b9fa
 
 PKG_MAINTAINER:=
 PKG_LICENSE:=LGPL-2.1-or-later
index 3e46675ffc5d643e91cedd3e680e499b778070c6..e5aee0feec7bba011068790f1fcba9b8c7b14987 100644 (file)
@@ -8,12 +8,12 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=glib2
-PKG_VERSION:=2.66.4
-PKG_RELEASE:=1
+PKG_VERSION:=2.68.1
+PKG_RELEASE:=$(AUTORELEASE)
 
 PKG_SOURCE:=glib-$(PKG_VERSION).tar.xz
-PKG_SOURCE_URL:=@GNOME/glib/2.66
-PKG_HASH:=97df8670e32f9fd4f7392b0980e661dd625012015d58350da1e58e343f4af984
+PKG_SOURCE_URL:=@GNOME/glib/2.68
+PKG_HASH:=241654b96bd36b88aaa12814efc4843b578e55d47440103727959ac346944333
 
 PKG_MAINTAINER:=Peter Wagner <tripolar@gmx.at>
 PKG_LICENSE:=LGPL-2.1-or-later
@@ -57,15 +57,19 @@ COMP_ARGS= \
        -Dman=false \
        -Ddtrace=false \
        -Dsystemtap=false \
+       -Dsysprof=disabled \
        -Dgtk_doc=false \
        -Dbsymbolic_functions=true \
        -Dforce_posix_threads=true \
        -Dfam=false \
+       -Dtests=false \
        -Dinstalled_tests=false \
        -Dnls=$(if $(CONFIG_BUILD_NLS),en,dis)abled \
        -Doss_fuzz=disabled \
+       -Dglib_debug=disabled \
        -Dglib_assert=false \
-       -Dglib_checks=false
+       -Dglib_checks=false \
+       -Dlibelf=disabled
 
 MESON_HOST_ARGS += $(COMP_ARGS) -Dxattr=false
 MESON_ARGS += $(COMP_ARGS) -Dxattr=true -Db_lto=true
diff --git a/libs/glib2/patches/001-no-libelf.patch b/libs/glib2/patches/001-no-libelf.patch
deleted file mode 100644 (file)
index a1fe738..0000000
+++ /dev/null
@@ -1,23 +0,0 @@
---- a/gio/meson.build
-+++ b/gio/meson.build
-@@ -874,20 +874,6 @@ endif
- # Dependencies used by executables below
- have_libelf = false
--libelf = dependency('libelf', version : '>= 0.8.12', required : false)
--if libelf.found()
--  have_libelf = true
--else
--  # This fallback is necessary on *BSD. elfutils isn't the only libelf
--  # implementation, and *BSD usually includes their own libelf as a system
--  # library which doesn't have a corresponding .pc file.
--  libelf = cc.find_library('elf', required : false)
--  have_libelf = libelf.found()
--  have_libelf = have_libelf and cc.has_function('elf_begin', dependencies : libelf)
--  have_libelf = have_libelf and cc.has_function('elf_getshdrstrndx', dependencies : libelf)
--  have_libelf = have_libelf and cc.has_function('elf_getshdrnum', dependencies : libelf)
--  have_libelf = have_libelf and cc.has_header('libelf.h')
--endif
- if have_libelf
-   glib_conf.set('HAVE_LIBELF', 1)
diff --git a/libs/glib2/patches/002-no-tests.patch b/libs/glib2/patches/002-no-tests.patch
deleted file mode 100644 (file)
index fbd35b7..0000000
+++ /dev/null
@@ -1,11 +0,0 @@
---- a/meson.build
-+++ b/meson.build
-@@ -94,7 +94,7 @@ installed_tests_template = files('templa
- installed_tests_template_tap = files('template-tap.test.in')
- # Don’t build the tests unless we can run them (either natively, in an exe wrapper, or by installing them for later use)
--build_tests = not meson.is_cross_build() or (meson.is_cross_build() and meson.has_exe_wrapper()) or installed_tests_enabled
-+build_tests = false
- add_project_arguments('-D_GNU_SOURCE', language: 'c')
index b8c35d9a014005223ffc592cd5bae21baa3d01f5..5dc541189d941b8db850f544410af7bad39c5293 100644 (file)
@@ -1,6 +1,6 @@
 --- a/meson.build
 +++ b/meson.build
-@@ -2185,16 +2185,10 @@ endif
+@@ -2220,16 +2220,10 @@ endif
  
  glib_conf.set('HAVE_PROC_SELF_CMDLINE', have_proc_self_cmdline)
  
@@ -17,4 +17,4 @@
 -
  # Determine which user environment-dependent files that we want to install
  have_bash = find_program('bash', required : false).found() # For completion scripts
- have_sh = find_program('sh', required : false).found() # For glib-gettextize
+ bash_comp_dep = dependency('bash-completion', version: '>=2.0', required: false)
index 46fd16305d615d186fb3e0e7ae5bc03e6a811b15..ab3ac4ba21e186e68561d8c63424e7d7364711c3 100644 (file)
@@ -1,6 +1,6 @@
 --- a/meson.build
 +++ b/meson.build
-@@ -2003,8 +2003,8 @@ endif
+@@ -2038,8 +2038,8 @@ endif
  # FIXME: glib-gettext.m4 has much more checks to detect broken/uncompatible
  # implementations. This could be extended if issues are found in some platforms.
  libintl_deps = []
index 60db223fd36a45fcb076e8c7e2db04d43d4a412a..76180e2e8933d006130b6bbdb17896d4df06d451 100644 (file)
@@ -1,6 +1,6 @@
 --- a/meson.build
 +++ b/meson.build
-@@ -923,7 +923,7 @@ if host_system == 'windows' and (cc.get_
+@@ -944,7 +944,7 @@ if host_system == 'windows' and (cc.get_
    glib_conf.set('HAVE_C99_SNPRINTF', false)
    glib_conf.set('HAVE_C99_VSNPRINTF', false)
    glib_conf.set('HAVE_UNIX98_PRINTF', false)
index e13a9b5032c34f037635dc3c577cf125f017edba..a8eb4c7a49a4153a70de2cdf3bab124f11129706 100644 (file)
@@ -6,12 +6,12 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=vips
-PKG_VERSION:=8.10.5
-PKG_RELEASE:=2
+PKG_VERSION:=8.10.6
+PKG_RELEASE:=$(AUTORELEASE)
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=https://github.com/libvips/libvips/releases/download/v$(PKG_VERSION)
-PKG_HASH:=a4eef2f5334ab6dbf133cd3c6d6394d5bdb3e76d5ea4d578b02e1bc3d9e1cfd8
+PKG_HASH:=2468088d958e0e2de1be2991ff8940bf45664a826c0dad12342e1804e2805a6e
 
 PKG_MAINTAINER:=W. Michael Petullo <mike@flyn.org>
 PKG_LICENSE:=LGPL-2.1-or-later
index 5c74d6b5ced06c9f444efcd10147025e68a92c78..d3c1855f0245a239bdfc3bcb5508e635ec59a996 100644 (file)
@@ -8,7 +8,7 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=proto-bonding
-PKG_VERSION:=2020-03-30
+PKG_VERSION:=2021-04-09
 PKG_RELEASE:=1
 
 PKG_LICENSE:=GPL-2.0
index 556d7c824efde362bb611fd357905a369d5894fd..ac65516371670f55fdc88c8ad90b4b3a2f7e5144 100755 (executable)
@@ -37,7 +37,7 @@ proto_bonding_init_config() {
 
        proto_config_add_string "bonding_policy"
        proto_config_add_string "link_monitoring"
-       proto_config_add_string "slaves"
+       proto_config_add_array "slaves"
        proto_config_add_string "all_slaves_active"
 
        proto_config_add_string "min_links"
@@ -66,6 +66,28 @@ proto_bonding_init_config() {
        proto_config_add_string "use_carrier"
 }
 
+proto_bonding_add_slave() {
+       local slave=$1
+       local idx=$2
+       local cfg=$3
+       local link=$4
+
+       if [ ! -e "/sys/class/net/$slave" ]; then
+               echo "$cfg" "No slave device $slave found"
+               proto_notify_error "$cfg" NO_DEVICE
+               proto_block_restart "$cfg"
+               return
+       fi
+
+       ip link set dev "$slave" down
+
+       sleep 1
+
+       echo "+$slave" > /sys/class/net/"$link"/bonding/slaves
+
+       ip link set dev "$slave" up
+}
+
 proto_bonding_setup() {
        local cfg="$1"
        local link="bonding-$cfg"
@@ -157,24 +179,7 @@ proto_bonding_setup() {
        # Add slaves to bonding interface
        local slaves
        json_get_vars slaves
-
-       for slave in $slaves; do
-
-               if [ "$(cat /proc/net/dev |grep "$slave")" == "" ]; then
-                       echo "$cfg" "No slave device $slave found"
-                       proto_notify_error "$cfg" NO_DEVICE
-                       proto_block_restart "$cfg"
-                       return
-               fi
-
-               ifconfig "$slave" down
-
-               sleep 1
-
-               echo "+$slave" > /sys/class/net/"$link"/bonding/slaves
-
-               ifconfig "$slave" up
-       done
+       json_for_each_item proto_bonding_add_slave slaves "$cfg" "$link"
 
        [ -n "$all_slaves_active" ] && echo "$all_slaves_active" > /sys/class/net/"$link"/bonding/all_slaves_active
 
index 0f2cddf5d6a4345273905bfc92fa6a3b9d31e80c..94c757fd4c1eae792158d89ba8680ee1959a9268 100644 (file)
@@ -8,12 +8,12 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=hcxdumptool
-PKG_VERSION:=6.0.1
-PKG_RELEASE:=1
+PKG_VERSION:=6.1.6
+PKG_RELEASE:=$(AUTORELEASE)
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=https://codeload.github.com/zerbea/hcxdumptool/tar.gz/$(PKG_VERSION)?
-PKG_HASH:=32bc07b692f5682792dcfd1d5dcae749e5fed4a65a2a05d815ed59adc9b64b02
+PKG_HASH:=e3212bd808e228c28ecfeeb4a9709480aa178b2e8b15c0a7d96733b648f8da85
 
 PKG_MAINTAINER:=Andreas Nilsen <adde88@gmail.com>
 PKG_LICENSE:=MIT
diff --git a/net/hcxdumptool/patches/010-openssl.patch b/net/hcxdumptool/patches/010-openssl.patch
new file mode 100644 (file)
index 0000000..a837737
--- /dev/null
@@ -0,0 +1,39 @@
+--- a/hcxdumptool.c
++++ b/hcxdumptool.c
+@@ -480,10 +480,6 @@ if(rebootflag == true)
+               }
+       }
+-EVP_cleanup();
+-CRYPTO_cleanup_all_ex_data();
+-ERR_free_strings();
+-
+ if(errorcount != 0) exit(EXIT_FAILURE);
+ if(totflag == true) exit(USER_EXIT_TOT);
+ exit(EXIT_SUCCESS);
+@@ -7270,8 +7266,6 @@ return true;
+ /*===========================================================================*/
+ static inline bool tlsinit()
+ {
+-SSL_load_error_strings();
+-OpenSSL_add_ssl_algorithms();
+ if((tlsctx = SSL_CTX_new(SSLv23_server_method())) == NULL)
+       {
+       fprintf(stderr, "OpenSSl can't create SSL context\n");
+@@ -7290,7 +7284,6 @@ if(SSL_CTX_use_PrivateKey_file(tlsctx, e
+ if((eaptlsctx = (eaptlsctx_t*)malloc(EAPTLSCTX_SIZE)) == NULL) return false;
+ memset(eaptlsctx, 0, EAPTLSCTX_SIZE);
+ SSL_CTX_set_session_cache_mode(tlsctx, SSL_SESS_CACHE_OFF);
+-SSL_CTX_set_ecdh_auto(tlsctx, 1);
+ SSL_CTX_set_verify(tlsctx, (SSL_VERIFY_PEER|SSL_VERIFY_CLIENT_ONCE), eap_tls_clientverify_cb);
+ #if (OPENSSL_VERSION_NUMBER >= 0x10100000L)
+ SSL_CTX_set_min_proto_version(tlsctx, TLS1_VERSION);
+@@ -7364,8 +7357,6 @@ if(gpiostatusled > 0)
+       }
+-ERR_load_crypto_strings();
+-OpenSSL_add_all_algorithms();
+ opensslversion = OpenSSL_version_num();
+ opensslversionmajor = (opensslversion & 0x10000000L) >> 28;
+ opensslversionminor = (opensslversion & 0x01100000L) >> 20;
diff --git a/net/hcxdumptool/patches/020-stdout.patch b/net/hcxdumptool/patches/020-stdout.patch
new file mode 100644 (file)
index 0000000..53c6147
--- /dev/null
@@ -0,0 +1,21 @@
+From 63012853a81aa623f09304baf1f5b0b69f1ebfbd Mon Sep 17 00:00:00 2001
+From: Tristian <2220506+Tristian@users.noreply.github.com>
+Date: Tue, 16 Mar 2021 16:17:07 -0400
+Subject: [PATCH] fix assignment of read-only variable 'stdout'
+
+- stdout cannot be reassigned on some systems i.e OpenWRT on mipsel
+---
+ hcxdumptool.c | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+--- a/hcxdumptool.c
++++ b/hcxdumptool.c
+@@ -7958,7 +7958,7 @@ while((auswahl = getopt_long(argc, argv,
+                       else
+                               {
+                               fd_pcapng = fileno(stdout);
+-                              stdout = fopen("/dev/null", "w");
++                              freopen("/dev/null", "w", stdout);
+                               }
+                       }
+               pcapngoutname = optarg;
index 143bc447f888ca3d60f0281e4499d6faf472652b..4c555156801e032e882ef9310f6ab1f63c4c55a1 100644 (file)
@@ -8,12 +8,12 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=hcxtools
-PKG_VERSION:=5.3.0
-PKG_RELEASE:=1
+PKG_VERSION:=6.1.6
+PKG_RELEASE:=$(AUTORELEASE)
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=https://codeload.github.com/zerbea/hcxtools/tar.gz/$(PKG_VERSION)?
-PKG_HASH:=bc3465eb3b97c4db849af41ae3fa7c812d4683eb9e493f090ac82e922ba8a36d
+PKG_HASH:=27b1b1ad722b9d82f8e92c6bec92d081159e5b8225bd2a477bf8d304ff4aeb03
 
 PKG_MAINTAINER:=Andreas Nilsen <adde88@gmail.com>
 PKG_LICENSE:=MIT
@@ -41,29 +41,21 @@ define Build/Compile
                CFLAGS="$(TARGET_CFLAGS)"
 endef
 
-define Package/hcxtools-custom/install
+define Package/hcxtools/install
        $(INSTALL_DIR) $(1)/sbin
-       $(INSTALL_BIN) $(PKG_BUILD_DIR)/hcxpcapngtool   $(1)/sbin/
+       $(INSTALL_BIN) $(PKG_BUILD_DIR)/hcxeiutool      $(1)/sbin/
+       $(INSTALL_BIN) $(PKG_BUILD_DIR)/hcxessidtool    $(1)/sbin/
+       $(INSTALL_BIN) $(PKG_BUILD_DIR)/hcxhash2cap     $(1)/sbin/
+       $(INSTALL_BIN) $(PKG_BUILD_DIR)/hcxhashcattool  $(1)/sbin/
        $(INSTALL_BIN) $(PKG_BUILD_DIR)/hcxhashtool     $(1)/sbin/
+       $(INSTALL_BIN) $(PKG_BUILD_DIR)/hcxmactool      $(1)/sbin/
+       $(INSTALL_BIN) $(PKG_BUILD_DIR)/hcxpcapngtool   $(1)/sbin/
+       $(INSTALL_BIN) $(PKG_BUILD_DIR)/hcxpmkidtool    $(1)/sbin/
+       $(INSTALL_BIN) $(PKG_BUILD_DIR)/hcxpmktool      $(1)/sbin/
        $(INSTALL_BIN) $(PKG_BUILD_DIR)/hcxpsktool      $(1)/sbin/
        $(INSTALL_BIN) $(PKG_BUILD_DIR)/hcxwltool       $(1)/sbin/
-       $(INSTALL_BIN) $(PKG_BUILD_DIR)/wlancap2wpasec  $(1)/sbin/
        $(INSTALL_BIN) $(PKG_BUILD_DIR)/whoismac        $(1)/sbin/
-       $(INSTALL_BIN) $(PKG_BUILD_DIR)/hcxpmkidtool    $(1)/sbin/
-       $(INSTALL_BIN) $(PKG_BUILD_DIR)/wlanhcx2john    $(1)/sbin/
-       $(INSTALL_BIN) $(PKG_BUILD_DIR)/hcxpcaptool     $(1)/sbin/
-       $(INSTALL_BIN) $(PKG_BUILD_DIR)/hcxhashcattool  $(1)/sbin/
-       $(INSTALL_BIN) $(PKG_BUILD_DIR)/hcxmactool      $(1)/sbin/
-       $(INSTALL_BIN) $(PKG_BUILD_DIR)/hcxessidtool    $(1)/sbin/
-       $(INSTALL_BIN) $(PKG_BUILD_DIR)/hcxhash2cap     $(1)/sbin/
-       $(INSTALL_BIN) $(PKG_BUILD_DIR)/wlanhc2hcx      $(1)/sbin/
-       $(INSTALL_BIN) $(PKG_BUILD_DIR)/wlanwkp2hcx     $(1)/sbin/
-       $(INSTALL_BIN) $(PKG_BUILD_DIR)/wlanhcxinfo     $(1)/sbin/
-       $(INSTALL_BIN) $(PKG_BUILD_DIR)/wlanhcx2ssid    $(1)/sbin/
-       $(INSTALL_BIN) $(PKG_BUILD_DIR)/wlanhcxcat      $(1)/sbin/
-       $(INSTALL_BIN) $(PKG_BUILD_DIR)/wlanpmk2hcx     $(1)/sbin/
-       $(INSTALL_BIN) $(PKG_BUILD_DIR)/wlanjohn2hcx    $(1)/sbin/
-       $(INSTALL_BIN) $(PKG_BUILD_DIR)/wlancow2hcxpmk  $(1)/sbin/
+       $(INSTALL_BIN) $(PKG_BUILD_DIR)/wlancap2wpasec  $(1)/sbin/
 endef
 
 $(eval $(call BuildPackage,hcxtools))
diff --git a/net/hcxtools/patches/010-openssl.patch b/net/hcxtools/patches/010-openssl.patch
new file mode 100644 (file)
index 0000000..bae0027
--- /dev/null
@@ -0,0 +1,85 @@
+--- a/hcxhashtool.c
++++ b/hcxhashtool.c
+@@ -104,9 +104,6 @@ static void closelists()
+ {
+ if(hashlist != NULL) free(hashlist);
+ if(ouilist != NULL) free(ouilist);
+-EVP_cleanup();
+-CRYPTO_cleanup_all_ex_data();
+-ERR_free_strings();
+ return;
+ }
+ /*===========================================================================*/
+@@ -125,8 +122,6 @@ eapolwrittencount = 0;
+ essidwrittencount = 0;
+ hccapxwrittencount = 0;
+ hccapwrittencount = 0;
+-ERR_load_crypto_strings();
+-OpenSSL_add_all_algorithms();
+ if((hashlist = (hashlist_t*)calloc(hashlistcount, HASHLIST_SIZE)) == NULL) return false;
+ if((ouilist = (ouilist_t*)calloc(ouilistcount, OUILIST_SIZE)) == NULL) return false;
+ return true;
+--- a/hcxpcapngtool.c
++++ b/hcxpcapngtool.c
+@@ -358,9 +358,6 @@ if(eapmschapv2msglist != NULL) free(eapm
+ if(eapmschapv2hashlist != NULL) free(eapmschapv2hashlist);
+ if(tacacsplist != NULL) free(tacacsplist);
+-EVP_cleanup();
+-CRYPTO_cleanup_all_ex_data();
+-ERR_free_strings();
+ return;
+ }
+ /*===========================================================================*/
+@@ -369,8 +366,6 @@ static bool initlists()
+ static unsigned long opensslversion;
+ static const char nastring[] = { "N/A" };
+-ERR_load_crypto_strings();
+-OpenSSL_add_all_algorithms();
+ opensslversion = OpenSSL_version_num();
+ opensslversionmajor = (opensslversion & 0x10000000L) >> 28;
+ opensslversionminor = (opensslversion & 0x01100000L) >> 20;
+--- a/hcxpmktool.c
++++ b/hcxpmktool.c
+@@ -920,8 +920,6 @@ while((auswahl = getopt_long(argc, argv,
+               }
+       }
+-ERR_load_crypto_strings();
+-OpenSSL_add_all_algorithms();
+ printf("\n");
+ if((essidstring != NULL) && (pskstring != NULL) && (pmkstring == NULL) && (hashlinestring == NULL))
+       {
+@@ -953,9 +951,6 @@ else if((essidstring != NULL) && (pskstr
+       }
+ printf("\n");
+-EVP_cleanup();
+-CRYPTO_cleanup_all_ex_data();
+-ERR_free_strings();
+ return EXIT_SUCCESS;
+ }
+ /*===========================================================================*/
+--- a/hcxpsktool.c
++++ b/hcxpsktool.c
+@@ -61,8 +61,6 @@ essidglen = 32;
+ t = time(NULL);
+ tm = localtime(&t);
+ thisyear = tm->tm_year +1900;
+-ERR_load_crypto_strings();
+-OpenSSL_add_all_algorithms();
+ return;
+ }
+ /*===========================================================================*/
+@@ -2770,10 +2768,6 @@ if(pskname != NULL)
+       fclose(fhpsk);
+       }
+-EVP_cleanup();
+-CRYPTO_cleanup_all_ex_data();
+-ERR_free_strings();
+-
+ return EXIT_SUCCESS;
+ }
+ /*===========================================================================*/
index e4f1e5668d457a9e80f79ea5adf8f54436ce59ea..b766983757f38a9a8d9b701fd46d243504ede992 100644 (file)
@@ -8,12 +8,12 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=ooniprobe
-PKG_VERSION:=3.9.0
+PKG_VERSION:=3.9.2
 PKG_RELEASE:=1
 
 PKG_SOURCE:=probe-cli-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=https://codeload.github.com/ooni/probe-cli/tar.gz/v$(PKG_VERSION)?
-PKG_HASH:=92dc714472c473352d750d558962734a42894d67407e755f94fed8d099cc8504
+PKG_HASH:=d34dc096dfdebceaa027716fdf675eb9ab7f0085defb4235f52685d064bd5afa
 
 PKG_MAINTAINER:=Jan Pavlinec <jan.pavlinec@nic.cz>
 PKG_LICENSE:=BSD-3-Clause
index 661084024dee7aac1a927f4b1b97a982201aa7bc..f28fe770c773767eb247dfe77a56d7f79b596995 100644 (file)
@@ -8,14 +8,14 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=squid
-PKG_VERSION:=4.13
-PKG_RELEASE:=1
+PKG_VERSION:=4.14
+PKG_RELEASE:=$(AUTORELEASE)
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
 PKG_SOURCE_URL:=http://www3.us.squid-cache.org/Versions/v4/ \
        http://www2.pl.squid-cache.org/Versions/v4/ \
        http://www.squid-cache.org/Versions/v4/
-PKG_HASH:=6891a0f540e60779b4f24f1802a302f813c6f473ec7336a474ed68c3e2e53ee0
+PKG_HASH:=f1097daa6434897c159bc100978b51347c0339041610845d0afa128151729ffc
 
 PKG_MAINTAINER:=Marko Ratkaj <marko.ratkaj@sartura.hr>
 PKG_LICENSE:=GPL-2.0-or-later
index 52d523252e531b89e269ba95ae39da258f7f2491..8d9f1c2850ce6fb4d8e914b15d97c1b4782fcf4a 100644 (file)
@@ -434,7 +434,7 @@ $(eval $(call BuildPlugin,chrony,chrony status input,chrony,))
 $(eval $(call BuildPlugin,conntrack,connection tracking table size input,conntrack,))
 $(eval $(call BuildPlugin,contextswitch,context switch input,contextswitch,))
 $(eval $(call BuildPlugin,cpu,CPU input,cpu,))
-$(eval $(call BuildPlugin,cpufreq,CPU Freq input,cpufreq,@(TARGET_x86||TARGET_x86_64||TARGET_mvebu||TARGET_ipq806x||TARGET_armvirt||TARGET_ipq40xx||TARGET_bcm27xx_bcm2709))) # Only enable on targets with CPUs supporting frequency scaling
+$(eval $(call BuildPlugin,cpufreq,CPU Freq input,cpufreq,@(TARGET_x86||TARGET_x86_64||TARGET_mvebu||TARGET_ipq806x||TARGET_armvirt||TARGET_ipq40xx||TARGET_bcm27xx_bcm2709||TARGET_rockchip))) # Only enable on targets with CPUs supporting frequency scaling
 $(eval $(call BuildPlugin,csv,CSV output,csv,))
 $(eval $(call BuildPlugin,curl,cURL input,curl,+PACKAGE_collectd-mod-curl:libcurl))
 #$(eval $(call BuildPlugin,dbi,relational database input,dbi,+PACKAGE_collectd-mod-dbi:libdbi))